View Issue Details

IDProjectCategoryView StatusLast Update
0004733FreeCADFeaturepublic2021-09-13 19:58
ReporterEvgeniy Assigned Tochennes  
PriorityhighSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.20 
Target Version0.20Fixed in Version0.20 
Summary0004733: Add the ability to test the translation from Crowdin in the FreeCAD interface on Windows OS
DescriptionThis feature exists in Linux, but when testing, I found that this does not work on Windows.

On Linux, one needs to manually create the ~/.FreeCAD/translations directory and add the .qm files from crowdin in to it. Restart FC and the new translations should be available.

We need to find the Windows equivalent.

Discussion on them forum:
Request 1+Windows tests
Request 2
Request 3
Tagstesting, translation
FreeCAD InformationOS: Windows 10 Version 1909
Word size of FreeCAD: 64-bit
Version: 0.20.25541 (Git)
Build type: Release
Branch: master
Hash: ca043dcb6d20d70b8e24d75e810683214eecc5d4
Python version: 3.8.6+
Qt version: 5.15.2
Coin version: 4.0.1
OCC version: 7.5.0

Activities

Evgeniy

2021-08-25 14:13

reporter   ~0015858

This function may also be required for translation into languages not yet added to FreeCAD. For example, the Bulgarian language is currently missing in the FreeCAD interface and one user tried to insert Bulgarian translation into Polish *.ts files, for see how the interface will look in Bulgarian. I don't know if something worked out for him, because he also seems to have Windows OS.

Kunda1

2021-08-25 14:26

administrator   ~0015859

CC @sgrogan @yorik

Kunda1

2021-09-08 11:31

administrator   ~0015915

@chennes can you weigh in on this if you have a moment?

Kunda1

2021-09-08 11:40

administrator   ~0015916

Last edited: 2021-09-08 11:43

We basically need to find the Windows equivalent to ~/.FreeCAD/translations

Maybe this is the start of the rabbit hole, https://doc.qt.io/qt-5/linguist-programmers.html#deploying-translations ?

Edit: updated the ticket summary

chennes

2021-09-08 22:43

developer   ~0015920

Last edited: 2021-09-08 22:44

I tested putting the Bulgarian *.qm files in $USER/AppData/Roaming/FreeCAD/translations and manually changing the language to Bulgarian, and I got no complaints from FreeCAD. I don't know Bulgarian so I'm not sure if it was actually displaying the correct language strings, though.

chennes

2021-09-11 20:38

developer   ~0015923

It appears that this more-or-less already works, but I've submitted PR 5021 to improve the process for testing new languages and new language strings in FreeCAD.

chennes

2021-09-13 19:58

developer   ~0015924

The PR has been merged and documented in the Wiki. There are now several ways to test translations on Windows.

Issue History

Date Modified Username Field Change
2021-08-25 13:16 Evgeniy New Issue
2021-08-25 13:16 Evgeniy Tag Attached: testing
2021-08-25 14:13 Evgeniy Note Added: 0015858
2021-08-25 14:26 Kunda1 Note Added: 0015859
2021-08-25 14:26 Kunda1 Tag Attached: translation
2021-09-08 11:31 Kunda1 Note Added: 0015915
2021-09-08 11:40 Kunda1 Note Added: 0015916
2021-09-08 11:43 Kunda1 Description Updated
2021-09-08 11:43 Kunda1 Note Edited: 0015916
2021-09-08 11:45 Kunda1 Target Version => 0.20
2021-09-08 22:43 chennes Note Added: 0015920
2021-09-08 22:44 chennes Note Edited: 0015920
2021-09-11 20:36 chennes Assigned To => chennes
2021-09-11 20:36 chennes Status new => assigned
2021-09-11 20:38 chennes Note Added: 0015923
2021-09-13 19:58 chennes Status assigned => closed
2021-09-13 19:58 chennes Resolution open => fixed
2021-09-13 19:58 chennes Fixed in Version => 0.20
2021-09-13 19:58 chennes Note Added: 0015924