View Issue Details

IDProjectCategoryView StatusLast Update
0004732FreeCADBugpublic2021-09-09 15:03
Reporterm3g1dd0 Assigned Tojnxd  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAnyOSAnyOS VersionAny
Fixed in Version0.20 
Summary0004732: Mesh repair: self-intersection: co-planar: self-intersection is not detected when intersecting triangles are on the same plane
DescriptionThe observation is reported here:

https://stackoverflow.com/q/68892925/3405291

Sorry for putting up just a link. I'm trying to save time by not repeating the report here.
Steps To ReproduceSteps to reproduced are described here:

https://stackoverflow.com/q/68892925/3405291
Additional InformationForum post:
https://forum.freecadweb.org/viewtopic.php?f=8&t=61757
TagsNo tags attached.
FreeCAD InformationOS: Ubuntu 18.04.3 LTS (ubuntu:GNOME/ubuntu)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.18984 (Git)
Build type: Unknown
Branch: master
Hash: c251caa934597d4b32def43ca8ac2ab479931d73
Python version: 3.6.9
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)

Activities

m3g1dd0

2021-08-23 13:03

reporter   ~0015850

I couldn't find a way to edit the report. Sorry, the FreeCAD information is actually this:

OS: Windows 10 Version 2009
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.24291 (Git)
Build type: Release
Branch: releases/FreeCAD-0-19
Hash: 7b5e18a0759de778b74d3a5c17eba9cb815035ac
Python version: 3.8.6+
Qt version: 5.15.2
Coin version: 4.0.1
OCC version: 7.5.0
Locale: English/United States (en_US)

Kunda1

2021-08-25 01:31

administrator   ~0015855

Please x-post to the forum

m3g1dd0

2021-08-28 05:19

reporter   ~0015879

Cross-posted on the forum here:

https://forum.freecadweb.org/viewtopic.php?f=8&t=61681

Kunda1

2021-08-28 15:19

administrator   ~0015880

@m3g1dd0 forum 'topic doesn't exist'. is the URL correct ?

m3g1dd0

2021-08-30 10:31

reporter   ~0015884

I think the forum moderator deleted it since it was just a link to stackoverflow.com!

I posted another one which awaits moderator approval.

m3g1dd0

2021-08-30 10:37

reporter   ~0015885

I posted another one with complete explanation here:

https://forum.freecadweb.org/viewtopic.php?f=8&t=61757

Maybe this one gets approved by the forum moderator!

jnxd

2021-09-02 01:14

developer   ~0015889

Last edited: 2021-09-09 04:44

PR: https://github.com/FreeCAD/FreeCAD/pull/5002 Currently a draft because of new(?) occasional bug.

jnxd

2021-09-09 04:45

developer   ~0015921

Closing because the PR is merged. @m3g1dd0 can you confirm the bug is resolved for your use case?

Kunda1

2021-09-09 15:03

administrator   ~0015922

c:FreeCAD:642836d58a6d:

Issue History

Date Modified Username Field Change
2021-08-23 12:51 m3g1dd0 New Issue
2021-08-23 13:03 m3g1dd0 Note Added: 0015850
2021-08-25 01:32 Kunda1 Note Added: 0015855
2021-08-25 01:32 Kunda1 Tag Attached: #post-to-forum
2021-08-25 01:32 Kunda1 Status new => feedback
2021-08-28 05:19 m3g1dd0 Note Added: 0015879
2021-08-28 05:19 m3g1dd0 Status feedback => new
2021-08-28 15:19 Kunda1 Note Added: 0015880
2021-08-28 15:19 Kunda1 Status new => feedback
2021-08-30 10:31 m3g1dd0 Note Added: 0015884
2021-08-30 10:31 m3g1dd0 Status feedback => new
2021-08-30 10:37 m3g1dd0 Note Added: 0015885
2021-08-30 15:28 jnxd Steps to Reproduce Updated
2021-08-30 15:28 jnxd Additional Information Updated
2021-08-30 15:33 jnxd Assigned To => jnxd
2021-08-30 15:33 jnxd Status new => assigned
2021-09-02 01:14 jnxd Note Added: 0015889
2021-09-09 04:44 jnxd Note Edited: 0015889
2021-09-09 04:45 jnxd Note Added: 0015921
2021-09-09 04:45 jnxd Tag Detached: #post-to-forum
2021-09-09 04:46 jnxd Status assigned => resolved
2021-09-09 04:46 jnxd Resolution open => fixed
2021-09-09 04:46 jnxd Fixed in Version => 0.20
2021-09-09 15:03 Kunda1 Note Added: 0015922