View Issue Details

IDProjectCategoryView StatusLast Update
0004583PartDesignBugpublic2021-08-16 15:51
ReporterAKielhorn Assigned Tochennes  
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
PlatformiMacOSmacOSOS Version10.13
Product Version0.19 
Fixed in Version0.20 
Summary0004583: Some items in the PartDesign Workbench are not translatable.
DescriptionWhile working on the german translation I found a few items that do not appear in CrowIn and are therefore not translatable.

Missing translatable in Part Design

The files involved:

FreeCAD/src/Mod/PartDesign/Gui/Workbench.cpp (l. 51)
FreeCAD/src/Mod/PartDesign/Gui/Workbench.cpp (l. 548)
FreeCAD/src/Mod/PartDesign/InvoluteGearFeature.py (l. 53)
FreeCAD/src/Mod/PartDesign/SprocketFeature.py (l. 60)
src/Mod/PartDesign/WizardShaft/WizardShaft.py (l. 183 and 206)
Steps To Reproduce
  • Open FreeCad
  • Switch to Language German
  • Open Menü "PartDesign"
  • Observe that "Erzeugen eines zusätzlichen Grundkörpers" is translated while "Create an additiv feature" is not.
  • Search for "Create an additiv feature" on CrowdIn and get nil as a result.
Tags#pending, #tobeclosed, translation
FreeCAD InformationOS: macOS High Sierra (10.13)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.24267 (Git)
Build type: Release
Branch: master
Hash: b2ca86d8d72b636011a73394bf9bcdedb3b109b7
Python version: 3.8.8
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)

Relationships

child of 0004578 assignedKunda1 Project Tools & Websites Strings in the UI that aren't being translated 

Activities

AKielhorn

2021-03-01 07:38

reporter  

Translation-PD.png (68,295 bytes)   
Translation-PD.png (68,295 bytes)   

Kunda1

2021-03-01 12:58

administrator   ~0015463

Last edited: 2021-03-01 12:58

Yikes, src/Mod/PartDesign/Gui/Workbench.cpp is super hard to read
https://github.com/FreeCAD/FreeCAD/blob/c7c420ca1d2f7779d2cd75f3fd98162c62f235b8/src/Mod/PartDesign/Gui/Workbench.cpp#L51-L62
@openBrain do you mind with an assist? :)

openBrain

2021-03-02 17:59

developer   ~0015470

@Kunda1 : saw your ping. Beyond I'm not sure I can help here, I've entered a tough busy period that will basically keep me away from contributing for some weeks (hopefully not more). Sorry for that.

Kunda1

2021-03-03 17:12

administrator   ~0015481

@chennes would you have a moment to help me with this?

chennes

2021-03-03 22:47

developer   ~0015483

Sure - you really need to be looking at lines 491-522, that's where the untranslated strings are. I don't know why they aren't translated, maybe that comment above was intended as a sort of "note to self"? Anyway, I think I can make a PR here if you want.

chennes

2021-03-03 23:42

developer   ~0015484

I see - they aren't commands, they are submenus. Those have to get handled differently. PR 4570

chennes

2021-03-04 15:34

developer   ~0015485

Oh, it looks like there is a problem in the regex for directories that are getting stripped "src/Mod/Part" also matches "src/Mod/PartDesign" so updatets isn't doing that one.

chennes

2021-03-05 00:20

developer   ~0015488

Apologies for not including this tracker ticket # in the commit -- I believe that this issue will be fixed by FreeCAD master 6789ddaa, but I wouldn't close the ticket until it's confirmed that those PartDesign TS files are being processed correctly now.

chennes

2021-03-05 15:10

developer   ~0015489

Setting to Confirmed pending confirmation that this did indeed fix the issue.

Kunda1

2021-08-10 12:14

administrator   ~0015793

Last edited: 2021-08-10 12:18

OS: Manjaro Linux (KDE/plasma)
Word size of FreeCAD: 64-bit
Version: 0.20.25429 (Git) AppImage
Build type: Release
Branch: master
Hash: acce57a25d82b0408fa07b9452ed31c8a06c7a1b
Python version: 3.9.6
Qt version: 5.12.9
Coin version: 4.0.0
OCC version: 7.5.2
Locale: English/United States (en_US)

"Create [additive|subtractive] feature" is fixed.
But some translations remain broken (bottom of screenshot of the first notation of this ticket)
Sprocket...
Involute gear
Shaft design wizard

A while back I tried to address this in PR FreeCAD Pull Request 4850
Specifically commit c:FreeCAD:c46036a1b8a0c57c8b160afa8bdf56e75a33aa04:
(link to commit)
But still unsuccessful

chennes

2021-08-10 14:19

developer   ~0015794

It doesn't look like any of the Python code in PartDesign is being translated: at least, it's not listed in the PyCommands variable in updatets.py.

chennes

2021-08-10 14:43

developer   ~0015795

OK, can you test this PR and see if it grabs the missing translation strings in PartDesign? https://github.com/FreeCAD/FreeCAD/pull/4961

chennes

2021-08-16 15:51

developer   ~0015819

That PR has now been merged, and I believe fully addresses the missing translations in PartDesign's Python code.

Issue History

Date Modified Username Field Change
2021-03-01 07:38 AKielhorn New Issue
2021-03-01 07:38 AKielhorn Tag Attached: translation
2021-03-01 07:38 AKielhorn File Added: Translation-PD.png
2021-03-01 12:58 Kunda1 Note Added: 0015463
2021-03-01 12:58 Kunda1 Note Edited: 0015463
2021-03-01 12:59 Kunda1 Status new => confirmed
2021-03-01 18:26 Kunda1 Relationship added child of 0004578
2021-03-02 17:59 openBrain Note Added: 0015470
2021-03-03 17:12 Kunda1 Note Added: 0015481
2021-03-03 22:47 chennes Note Added: 0015483
2021-03-03 23:42 chennes Note Added: 0015484
2021-03-04 09:09 Kunda1 Assigned To => chennes
2021-03-04 09:09 Kunda1 Status confirmed => assigned
2021-03-04 15:34 chennes Note Added: 0015485
2021-03-05 00:20 chennes Note Added: 0015488
2021-03-05 15:10 chennes Status assigned => confirmed
2021-03-05 15:10 chennes Note Added: 0015489
2021-08-10 12:14 Kunda1 Note Added: 0015793
2021-08-10 12:15 Kunda1 Note Edited: 0015793
2021-08-10 12:17 Kunda1 Note Edited: 0015793
2021-08-10 12:18 Kunda1 Note Edited: 0015793
2021-08-10 14:19 chennes Note Added: 0015794
2021-08-10 14:43 chennes Note Added: 0015795
2021-08-12 00:54 Kunda1 Tag Attached: #pending
2021-08-12 00:54 Kunda1 Tag Attached: #tobeclosed
2021-08-16 15:51 chennes Status confirmed => closed
2021-08-16 15:51 chennes Resolution open => fixed
2021-08-16 15:51 chennes Fixed in Version => 0.20
2021-08-16 15:51 chennes Note Added: 0015819