View Issue Details

IDProjectCategoryView StatusLast Update
0004569PartDesignBugpublic2021-02-20 01:30
ReporterDeeJayOne Assigned Towmayer  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOS10OS Version10.0.19041.804
Product Version0.19 
Summary0004569: Part Design Workbench - New Bodies selection issues
DescriptionSince the beginning of v0.19-xxxxx series, I can see an issue if you create several bodies into a Part container with the Part Design Workbench :
  • All appear as "selected" (All new body's name are displayed as Bold)
  • To unselect all, you need to do a double click twice on each created body
Steps To Reproduce
  1. Create a new document
  2. Create a new part
  3. Select the new part previously created
  4. Create a new body
  5. Create a new body
  6. Create a new body
Additional InformationForum Topic Link : https://forum.freecadweb.org/viewtopic.php?f=3&t=55579
Tags0.19, Part Design, regression, tree view
FreeCAD InformationOS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.24012 (Git)
Build type: Release
Branch: master
Hash: 46a899c437cc5e731cc0648d883a2926bfa7c347
Python version: 3.8.6
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: French/France (fr_FR)

Activities

wmayer

2021-02-20 01:03

administrator   ~0015369

Regression is caused by this line in the function DocumentItem::slotHighlightObject:
https://github.com/FreeCAD/FreeCAD/commit/c18bf118217aa624688d3d3fcbf28be78c624b63#diff-dc3857ef72e04bcd565ae8aec99ea783b876640433b9cf381d54be972f2603adR3569

wmayer

2021-02-20 01:30

administrator   ~0015370

Fix committed to master branch.

Related Changesets

FreeCAD: master e5e07445

2021-02-20 01:06:27

wmayer

Details Diff
Gui: [skip ci] fixes 0004569: Part Design Workbench - New Bodies selection issues Affected Issues
0004569
mod - src/Gui/Tree.cpp Diff File

Issue History

Date Modified Username Field Change
2021-02-15 16:59 DeeJayOne New Issue
2021-02-15 17:00 DeeJayOne Description Updated View Revisions
2021-02-15 17:05 DeeJayOne Additional Information Updated View Revisions
2021-02-15 17:06 DeeJayOne Description Updated View Revisions
2021-02-15 17:06 DeeJayOne Description Updated View Revisions
2021-02-15 17:08 DeeJayOne Steps to Reproduce Updated View Revisions
2021-02-15 20:10 DeeJayOne Tag Attached: 0.19
2021-02-15 20:10 DeeJayOne Tag Attached: Part Design
2021-02-15 20:10 DeeJayOne Tag Attached: tree view
2021-02-15 20:11 DeeJayOne Tag Attached: regression
2021-02-19 20:37 wmayer Status new => confirmed
2021-02-20 01:03 wmayer Note Added: 0015369
2021-02-20 01:30 wmayer Changeset attached => FreeCAD master e5e07445
2021-02-20 01:30 wmayer Note Added: 0015370
2021-02-20 01:30 wmayer Assigned To => wmayer
2021-02-20 01:30 wmayer Status confirmed => closed
2021-02-20 01:30 wmayer Resolution open => fixed