View Issue Details

IDProjectCategoryView StatusLast Update
0004565FreeCADBugpublic2021-02-28 16:55
Reporterturn211 Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.19 
Fixed in Version0.20 
Summary0004565: Status bar text runs under Navigation Button
DescriptionThe Green arrow in attatched image points to text running under the button and pushing the QSpacerItem Widget? into the other QSpacerItem Widget? Text should be truncated or word wrapped?
Steps To ReproduceHover over Make Compound Copys button as seen in attached image
Tagsstylesheet
FreeCAD InformationOS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23756 (Git)
Build type: Release
Branch: master
Hash: 9c6e9184930a52b165a0b7274e3a45d1006bfe67
Python version: 3.8.6
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: English/Canada (en_CA)

Relationships

related to 0004566 closed Status Bar Verticle Spacers are not visually pleasing. Elements can not be styled with stylesheets. 

Activities

turn211

2021-02-15 03:40

reporter  

What_are_these_verticle_bars_annotated.png (Attachment missing)

turn211

2021-02-16 16:17

reporter   ~0015359

Steps to Reproduce: Hover over Point Array toolbar button

Kunda1

2021-02-16 18:26

administrator   ~0015361

How does this need to be fixed ? With QtDesigner ?

turn211

2021-02-17 00:48

reporter   ~0015362

Yes. looks like it https://wiki.qt.io/Word_Wrap_of_Text_in_QLabel

wmayer

2021-02-23 18:50

administrator   ~0015427

Problem must be caused by the Tux module. Limiting the width of the status base makes the label shorter but the text still overrides the Navigation menu. The reason could be that the Navigation menu is added in an unconventional way.

wmayer

2021-02-25 17:12

administrator   ~0015433

https://github.com/wwmayer/FreeCAD/pull/new/bug4565

wmayer

2021-02-28 12:30

administrator   ~0015460

Fix committed to master branch.

Related Changesets

FreeCAD: master 59048fb9

2021-02-25 17:09:21

wmayer


Committer: wwmayer Details Diff
Tux: fixes 0004565: Status bar text runs under Navigation Button Affected Issues
0004565
mod - src/Mod/Tux/NavigationIndicatorGui.py Diff File

Issue History

Date Modified Username Field Change
2021-02-15 03:40 turn211 New Issue
2021-02-15 03:40 turn211 Tag Attached: stylesheet
2021-02-15 03:40 turn211 File Added: What_are_these_verticle_bars_annotated.png
2021-02-15 19:51 Kunda1 Relationship added related to 0004566
2021-02-16 16:17 turn211 Note Added: 0015359
2021-02-16 18:26 Kunda1 Note Added: 0015361
2021-02-17 00:48 turn211 Note Added: 0015362
2021-02-23 18:50 wmayer Note Added: 0015427
2021-02-25 17:12 wmayer Note Added: 0015433
2021-02-28 12:30 wmayer Changeset attached => FreeCAD master 59048fb9
2021-02-28 12:30 wmayer Note Added: 0015460
2021-02-28 12:30 wmayer Assigned To => wmayer
2021-02-28 12:30 wmayer Status new => closed
2021-02-28 12:30 wmayer Resolution open => fixed
2021-02-28 16:55 Kunda1 Fixed in Version => 0.20