View Issue Details

IDProjectCategoryView StatusLast Update
0004549TechDrawBugpublic2021-03-01 16:00
Reporterbitacovir Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
OSWindowsOS Version10 
Target Version0.20Fixed in Version0.19 
Summary0004549: [TD] ArchView only shows objects if section plane cuts through them
DescriptionIn TechDraw, TD_ArchView does not render any image in the TechDraw sheet, when you move the Arch Section outside the 3D object. Only an image is rendered when Arch Section cut through the object.

This is a regression of TD_ArchView's functionality in FC 0.18 when TD_ArchView was able to render views of objects and sections views.

Bug detected on September 2020
Forum Discussion with additional information about possible causes: https://forum.freecadweb.org/viewtopic.php?f=35&t=50242
Steps To ReproduceCreate a wall (or any object).
Select the wall and create an Arch Section.
Rotate the section and move away from the wall, with the section "looking" the wall.
Create a TechDraw sheet.
Select the ArchSection and create a TD-ArchView
When the section plane cuts the wal, the ArchView shows the section of the wall in the Techdraw.
But if I move the section plane outside of the wall, the TD-ArchView does not render anything.
Tags#post-to-forum, 0.19, TechDraw
FreeCAD InformationOS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23756 (Git)
Build type: Release
Branch: master
Hash: 9c6e9184930a52b165a0b7274e3a45d1006bfe67
Python version: 3.8.6
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: English/United States (en_US)

Activities

bitacovir

2021-02-01 23:42

reporter  

[TD]ArchView_Bug.FCStd (Attachment missing)

Eric Myers

2021-02-02 05:37

reporter   ~0015249

Clarifying that this affects wireframe mode. Other modes do render.

My info:
OS: Ubuntu 20.04.2 LTS (KDE/plasma)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23756 (Git) AppImage
Build type: Release
Branch: master
Hash: 9c6e9184930a52b165a0b7274e3a45d1006bfe67
Python version: 3.8.6
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: English/United States (en_US)

bitacovir

2021-02-23 01:57

reporter   ~0015420

Last edited: 2021-02-23 02:00

Target version in 0.20? This is a regression in 0.19 with respect of 0.18
Normal workflow in TD is interrupted...
This should be fix it during 0.19 life cycle if possible...
Maybe could Yorik address this...?

uwestoehr

2021-02-23 17:17

developer   ~0015425

@yorik could you please have a quick look at this regression bug?

uwestoehr

2021-02-23 17:19

developer   ~0015426

In case this is no bug in the Arch WB but in TechDraw please tell me. However, most probably this is too late for FC 0.19 since the deadline is tonight.

yorik

2021-03-01 15:51

administrator   ~0015465

Damn.. How could we not see this for so long
It's now fixed with https://github.com/FreeCAD/FreeCAD/commit/deaf74856b3e90b27f542c91ab1a38cd3c6aa051 and backported to 0.19

yorik

2021-03-01 16:00

administrator   ~0015466

Fix committed to master branch.

Related Changesets

FreeCAD: master deaf7485

2021-03-01 15:49:31

yorik

Details Diff
Arch: Fixed SectionPlane outside objects bug in ArchSectionPlane - Fixes 0004549 Affected Issues
0004549
mod - src/Mod/Arch/ArchSectionPlane.py Diff File

Issue History

Date Modified Username Field Change
2021-02-01 23:42 bitacovir New Issue
2021-02-01 23:42 bitacovir Tag Attached: #post-to-forum
2021-02-01 23:42 bitacovir Tag Attached: 0.19
2021-02-01 23:42 bitacovir Tag Attached: TechDraw
2021-02-01 23:42 bitacovir File Added: [TD]ArchView_Bug.FCStd
2021-02-02 05:37 Eric Myers Note Added: 0015249
2021-02-06 06:38 abdullah Target Version => 0.20
2021-02-23 01:57 bitacovir Note Added: 0015420
2021-02-23 02:00 bitacovir Note Edited: 0015420
2021-02-23 17:17 uwestoehr Note Added: 0015425
2021-02-23 17:19 uwestoehr Note Added: 0015426
2021-03-01 15:51 yorik Note Added: 0015465
2021-03-01 15:52 yorik Assigned To => yorik
2021-03-01 15:52 yorik Status new => closed
2021-03-01 15:52 yorik Resolution open => fixed
2021-03-01 15:52 yorik Fixed in Version => 0.19
2021-03-01 16:00 yorik Changeset attached => FreeCAD master deaf7485
2021-03-01 16:00 yorik Note Added: 0015466