View Issue Details

IDProjectCategoryView StatusLast Update
0004540FreeCADBugpublic2021-02-20 13:00
Reporterkisolre Assigned Towmayer  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Target Version0.20 
Summary0004540: When manual size of DatumPlane is selected its Length property is not saved to the file and consequently not restored on opening
DescriptionForum thread
Steps To ReproduceCreate new file, add new body.
Add Datum plane. attach to XY plane.
Change Resize property of DatumPlane to Manual.
Change Length and Width to different values.
Save file. Close file.
Open file, check DatumPlane Length and Width values - Width is as entered, Length is not.
Additional InformationInspecting the Document.xml shows that there is no entry for Length property.
TagsNo tags attached.
FreeCAD InformationOS: Windows 8.1 Version 6.3 (Build 9600)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23717 (Git)
Build type: Release
Branch: master
Hash: 254ed951f924687e3dffb325288bbc0333980b9c
Python version: 3.8.6+
Qt version: 5.15.1
Coin version: 4.0.1
OCC version: 7.5.0
Locale: Bulgarian/Bulgaria (bg_BG)

Activities

kisolre

2021-01-18 22:24

reporter  

test datum plane sizes.FCStd (Attachment missing)

wmayer

2021-02-20 12:31

administrator   ~0015373

Last edited: 2021-02-20 12:31

Length is also saved to the project file but the problem is that when reading in the properties it first reads Length, ResizeMode and then Width.

Because the default mode is "Automatic" it automatically adjusts Length when reading it in. Afterwards resize mode is set to manual so that when reading in Width it won't changed.

wmayer

2021-02-20 13:00

administrator   ~0015374

Fix committed to master branch.

Related Changesets

FreeCAD: master 13ed4bc6

2021-02-20 12:33:54

wmayer

Details Diff
PD: [skip ci] fixes 0004540: When manual size of DatumPlane is selected its Length property is not saved to the file and consequently not restored on opening Affected Issues
0004540
mod - src/Mod/PartDesign/App/DatumPlane.cpp Diff File
mod - src/Mod/PartDesign/App/DatumPlane.h Diff File

Issue History

Date Modified Username Field Change
2021-01-18 22:24 kisolre New Issue
2021-01-18 22:24 kisolre File Added: test datum plane sizes.FCStd
2021-02-06 06:49 abdullah Target Version => 0.20
2021-02-20 12:31 wmayer Note Added: 0015373
2021-02-20 12:31 wmayer Note Edited: 0015373
2021-02-20 13:00 wmayer Changeset attached => FreeCAD master 13ed4bc6
2021-02-20 13:00 wmayer Note Added: 0015374
2021-02-20 13:00 wmayer Assigned To => wmayer
2021-02-20 13:00 wmayer Status new => closed
2021-02-20 13:00 wmayer Resolution open => fixed