View Issue Details

IDProjectCategoryView StatusLast Update
0004518PartDesignBugpublic2021-02-27 13:32
Reporterakamenskiy Assigned Tochennes  
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Target Version0.20Fixed in Version0.20 
Summary0004518: Segfault in some models when making chamfer or fillet (on macos)
DescriptionAttached is example of model where it crashes. It does crash 100% of the time.

ALSO FFS get rid of Mantis, it is the worst bugtracker (has been the worst since I've worked with it in 2006). Even Github issues is way better than this. You can get Jira for open source projects for free.
Steps To Reproduce1. Open attached model
2. Select an inner edge of cutout in top surface (last pocket operation with sharp edges)
3. Try to create fillet or chamfer on selected edge
4. Segfault
Additional InformationThere is a stacktrace from the segfault. But it is not showing up anymore after being dismissed first time.
TagsChamfer, crash, fillet, OCC Bug, upstream
FreeCAD InformationOS: macOS 10.15
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23463 (Git)
Build type: Release
Branch: master
Hash: adc6db8f32c17e9f67cb82aa7962d1e42ce061c6
Python version: 3.8.6
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)

Relationships

duplicate of 0004543 resolvedchennes FreeCAD FreeCAD crashes when OCC fails with fillets and chamfers 

Activities

akamenskiy

2020-12-24 06:41

reporter  

30 mm fan guard.FCStd (113,429 bytes)

chennes

2021-02-04 05:26

developer   ~0015265

In my testing, this is resolved by the fix discussed in 0004543.

Kunda1

2021-02-27 13:32

administrator   ~0015452

@chennes has created a downstream patch that fixes the crash. It is slowly being integrated in to downstream packages (ATM libpack is the only one but more will follow). This issue is therefore being marked as resolved. It will be closed once all packages are patched or when (if) upstream merges.

Issue History

Date Modified Username Field Change
2020-12-24 06:41 akamenskiy New Issue
2020-12-24 06:41 akamenskiy File Added: 30 mm fan guard.FCStd
2021-02-03 16:57 Kunda1 Tag Attached: crash
2021-02-03 16:57 Kunda1 Tag Attached: fillet
2021-02-03 16:57 Kunda1 Tag Attached: Chamfer
2021-02-03 16:57 Kunda1 Tag Attached: OCC Bug
2021-02-03 16:57 Kunda1 Tag Attached: upstream
2021-02-04 05:26 chennes Note Added: 0015265
2021-02-06 06:43 abdullah Target Version => 0.20
2021-02-27 13:32 Kunda1 Assigned To => chennes
2021-02-27 13:32 Kunda1 Status new => resolved
2021-02-27 13:32 Kunda1 Resolution open => fixed
2021-02-27 13:32 Kunda1 Fixed in Version => 0.20
2021-02-27 13:32 Kunda1 Note Added: 0015452
2021-02-27 13:32 Kunda1 Relationship added duplicate of 0004543