View Issue Details

IDProjectCategoryView StatusLast Update
0004505DraftBugpublic2020-12-03 16:06
Reporteralexyash Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx64OSWindowsOS Version20H2 (19042.630)
Product Version0.19 
Summary0004505: Annotation styles form incorrectly works with Arrow style property
DescriptionThere are only 3 Arrow styles out of 5 available in Annotation styles form and Dimension styles are incorrectly being applied. It looks like there is an issue with arrow style property text values and their mapping. At the moment there is such mapping: "Dot" -> Dot, "Arrow" -> Circle, "Tick" -> Arrow.

Initially reported here - https://forum.freecadweb.org/viewtopic.php?f=8&t=52554
Steps To Reproduce1. Create some objects in Draft workbench.
2. Set default arrow style in Draft workbench preferences to other than Circle (Edit -> Preferences...).
3. Create a dimension (using default preferences).
4. Create an Annotation style, set arrow style to Arrow.
5. Apply this style to the dimension. The dimension's arrow style changes to Circle instead of Arrow.
TagsNo tags attached.
FreeCAD InformationOS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23127 (Git)
Build type: Release
Branch: master
Hash: e92fff2ca50a5a7b0048c5aabd856f6dc6cd9de1
Python version: 3.6.8
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/United States (en_US)

Activities

alexyash

2020-11-27 15:39

reporter  

Kunda1

2020-12-03 15:36

administrator   ~0015054

Last edited: 2020-12-03 15:37

View 2 revisions

Wonder why mantisbt didn't get triggered by FreeCAD master 0add97a1 ??
Edit: Probably because it hasn't sync'd yet.

yorik

2020-12-03 16:00

administrator   ~0015055

Fix committed to master branch.

yorik

2020-12-03 16:06

administrator   ~0015056

Yes it takes a couple of minutes before a commit appears here...

Related Changesets

FreeCAD: master 0add97a1

2020-12-03 15:30:05

yorik

Details Diff
Draft: Fixed Annotation style dialog's arrow types - fixes 0004505 Affected Issues
0004505
mod - src/Mod/Draft/Resources/ui/dialog_AnnotationStyleEditor.ui Diff File

Issue History

Date Modified Username Field Change
2020-11-27 15:39 alexyash New Issue
2020-11-27 15:39 alexyash File Added: FreeCAD_Annotation_styles_issue.png
2020-12-03 15:36 Kunda1 Note Added: 0015054
2020-12-03 15:37 Kunda1 Note Edited: 0015054 View Revisions
2020-12-03 16:00 yorik Changeset attached => FreeCAD master 0add97a1
2020-12-03 16:00 yorik Note Added: 0015055
2020-12-03 16:00 yorik Assigned To => yorik
2020-12-03 16:00 yorik Status new => closed
2020-12-03 16:00 yorik Resolution open => fixed
2020-12-03 16:06 yorik Note Added: 0015056