View Issue Details

IDProjectCategoryView StatusLast Update
0004494PartDesignBugpublic2020-11-16 14:00
Reporterchrisb Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.19 
Summary0004494: Error "Result is empty" for Pads and Pockets with non zero Offset
DescriptionIn some cases Pad offset does nothing in others it works. I couldn't find out the criteria.
In the corresponding forum post I have attached an example.

Steps to reproduce:
- load the file PadOffset.FCStd
- double click Pad001
- change Type to one of ToFirst, ToLast, UpToFace
- if changed to UpToFace select one of the faces parallel to the sketch, e.g. the selected face in the post.
- change offset to 10, any other value <0 or >0 will do as well
- confirm: error "Pad: Result is empty" occurs

Same behaviour is shown if the changes are made without the dialog directly in the Data tab.
TagsNo tags attached.
FreeCAD InformationOS: macOS High Sierra (10.13)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.22960 (Git)
Build type: Release
Branch: master
Hash: c5a4b01d2e4218bcc0eb6650337650a6c65ef0e4
Python version: 3.8.6
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)

Activities

wmayer

2020-11-16 12:52

administrator   ~0014992

https://github.com/wwmayer/FreeCAD/tree/fix_offset_in_pad_or_pocket

wmayer

2020-11-16 13:44

administrator   ~0014993

I can observe the behaviour with a pad but not with a pocket.

The reason for the problem is if the Fuse parameter of BRepFeat_MakePrism is set to 2 when an offset is set. Both of the values 2 and 1 does a fusion while for 0 a cut is done that is used by the pocket.

The solution (at least in this case) is to use the value 1 if at the same time an offset is used.

wmayer

2020-11-16 14:00

administrator   ~0014994

Fix committed to master branch.

Related Changesets

FreeCAD: master 42ccdb81

2020-11-16 13:45:55

wmayer

Details Diff
PartDesign: [skip ci] fixes 0004494: Error "Result is empty" for Pads and Pockets with non zero Offset Affected Issues
0004494
mod - src/Mod/PartDesign/App/FeaturePad.cpp Diff File
mod - src/Mod/PartDesign/App/FeaturePocket.cpp Diff File

Issue History

Date Modified Username Field Change
2020-11-14 09:15 chrisb New Issue
2020-11-16 12:52 wmayer Note Added: 0014992
2020-11-16 13:44 wmayer Note Added: 0014993
2020-11-16 14:00 wmayer Changeset attached => FreeCAD master 42ccdb81
2020-11-16 14:00 wmayer Note Added: 0014994
2020-11-16 14:00 wmayer Assigned To => wmayer
2020-11-16 14:00 wmayer Status new => closed
2020-11-16 14:00 wmayer Resolution open => fixed