View Issue Details

IDProjectCategoryView StatusLast Update
0004493SketcherBugpublic2020-11-15 17:15
Reporterdennisb Assigned Towmayer  
PrioritylowSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Fixed in Version0.19 
Summary0004493: InsertDatum.ui dialog height too small
DescriptionOn Fedora 33 in the InsertDatum dialog the input field is too small for the text making it hard to read. I've attached a screenshot of what it looks like on my computer.

Altering the height in src/Mod/Sketcher/Gui/InsertDatum.ui from 140 to 170 makes it look a lot nicer. I've attached a screenshot with the result after setting the height to 170 as well.
TagsNo tags attached.
FreeCAD InformationOS: Fedora 33 (Workstation Edition) (GNOME/gnome)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.22998 (Git)
Build type: Release
Branch: master
Hash: 68673c6ad1a96e1ac34c24d23c3887bf6486fbc6
Python version: 3.9.0
Qt version: 5.15.1
Coin version: 4.0.0a
OCC version: 7.4.0.beta
Locale: Swedish/Sweden (sv_SE)

Activities

dennisb

2020-11-13 21:49

reporter  

InsertDatum.png (29,503 bytes)   
InsertDatum.png (29,503 bytes)   
InsertDatum-height-170.png (20,219 bytes)   
InsertDatum-height-170.png (20,219 bytes)   

Kunda1

2020-11-14 10:55

administrator   ~0014984

@dennisb have you asked on the forum if this issue is also reproducible on other platforms or is it just unique to Fedora 33?

dennisb

2020-11-14 11:17

reporter   ~0014986

I assumed it looked good on other platforms since someone selected that original height value and it must look good for that person.

I hoped that making the dialog a little higher it would still look good elsewhere. But let me ask in the forum for screenshots on other platforms and hopefully we can get some more data.

dennisb

2020-11-14 23:02

reporter   ~0014987

The discussion thread in the forum:

  https://forum.freecadweb.org/viewtopic.php?f=34&t=52139

dennisb

2020-11-15 12:38

reporter   ~0014988

Fixed by https://github.com/FreeCAD/FreeCAD/commit/ed175c9f66

Kunda1

2020-11-15 17:14

administrator   ~0014989

FreeCAD master ed175c9f

Kunda1

2020-11-15 17:15

administrator   ~0014990

Closing ticket. Thanks to all involved!

Related Changesets

FreeCAD: master ed175c9f

2020-11-15 10:07:19

wmayer

Details Diff
Sketcher: [skip ci] revert minimum size hint from widgets in datum dialog
because this leads to a squashed appearance on some systems.

For more details see: https://forum.freecadweb.org/viewtopic.php?f=34&t=52139
Affected Issues
0004493
mod - src/Mod/Sketcher/Gui/InsertDatum.ui Diff File

Issue History

Date Modified Username Field Change
2020-11-13 21:49 dennisb New Issue
2020-11-13 21:49 dennisb File Added: InsertDatum.png
2020-11-13 21:49 dennisb File Added: InsertDatum-height-170.png
2020-11-13 22:04 dennisb Description Updated View Revisions
2020-11-14 10:55 Kunda1 Note Added: 0014984
2020-11-14 10:56 Kunda1 Status new => feedback
2020-11-14 11:17 dennisb Note Added: 0014986
2020-11-14 11:17 dennisb Status feedback => new
2020-11-14 23:00 dennisb Description Updated View Revisions
2020-11-14 23:02 dennisb Note Added: 0014987
2020-11-15 12:38 dennisb Note Added: 0014988
2020-11-15 17:14 Kunda1 Note Added: 0014989
2020-11-15 17:15 Kunda1 Changeset attached => FreeCAD master ed175c9f
2020-11-15 17:15 Kunda1 Assigned To => wmayer
2020-11-15 17:15 Kunda1 Status new => closed
2020-11-15 17:15 Kunda1 Resolution open => fixed
2020-11-15 17:15 Kunda1 Fixed in Version => 0.19
2020-11-15 17:15 Kunda1 Note Added: 0014990