View Issue Details

IDProjectCategoryView StatusLast Update
0004487PartDesignBugpublic2021-02-27 13:31
Reporterchrisb Assigned Tochennes  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Target Version0.20Fixed in Version0.20 
Summary0004487: Crash on changing Fillet Radius (OCC issue to be retested with OCC > 7.5)
DescriptionWith the model from this post: https://forum.freecadweb.org/viewtopic.php?p=445664#p445631 FreeCAD crashes when Radius of Fillet004
is changed.
Forum discussion
Steps To Reproduce- open the file Fertig.FCStd
- double click Fillet004
- change radius to 13mm

-> crash.
Tagscrash, fillet, OCC 7.5, OCC Bug, upstream
FreeCAD InformationOS: macOS 10.15
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.22846 (Git)
Build type: Release
Branch: master
Hash: 1f46b72491a0008384a6db4f2615a656249f6f08
Python version: 3.8.6
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)

Relationships

duplicate of 0004543 resolvedchennes FreeCAD FreeCAD crashes when OCC fails with fillets and chamfers 

Activities

chrisb

2020-11-08 04:22

developer   ~0014965

Werner tested with OCC 7.5 and still crashes.

Kunda1

2020-12-31 11:52

administrator   ~0015182

@chrisb any idea if there is an open upstream ticket ?

kisolre

2021-01-07 19:25

reporter   ~0015202

Last edited: 2021-01-07 19:25

Actually that body is broken at first fillet - there is a hole at the underside. So we should not expect proper results later. This still should not crash FreeCAD. Why does crashing OCCT still crash FreeCAD? Shouldn't it just show an error?

OS: Windows 8.1 Version 6.3 (Build 9600)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23652 (Git)
Build type: Release
Branch: master
Hash: d339e4067107df2f83bed009c381f39162211c22
Python version: 3.8.6+
Qt version: 5.15.1
Coin version: 4.0.1
OCC version: 7.5.0
Locale: Bulgarian/Bulgaria (bg_BG)
NotConnectedFillet.JPG (72,326 bytes)   
NotConnectedFillet.JPG (72,326 bytes)   

chennes

2021-02-04 05:23

developer   ~0015264

In my testing, this is resolved by the fix discussed in 0004543.

Kunda1

2021-02-27 13:31

administrator   ~0015451

@chennes has created a downstream patch that fixes the crash. It is slowly being integrated in to downstream packages (ATM libpack is the only one but more will follow). This issue is therefore being marked as resolved. It will be closed once all packages are patched or when (if) upstream merges.

Issue History

Date Modified Username Field Change
2020-11-07 21:53 chrisb New Issue
2020-11-08 04:19 chrisb Summary Crash on changing Fillet Radius (OCC issue to be retested wit OCC7.5)y => Crash on changing Fillet Radius (OCC issue to be retested wit OCC7.5)
2020-11-08 04:21 chrisb Summary Crash on changing Fillet Radius (OCC issue to be retested wit OCC7.5) => Crash on changing Fillet Radius (OCC issue to be retested wit OCC > 7.5)
2020-11-08 04:22 chrisb Note Added: 0014965
2020-11-08 04:25 chrisb Tag Attached: OCC Bug
2020-11-21 16:23 Kunda1 Tag Attached: OCC 7.5
2020-12-31 11:50 Kunda1 Summary Crash on changing Fillet Radius (OCC issue to be retested wit OCC > 7.5) => Crash on changing Fillet Radius (OCC issue to be retested witj OCC > 7.5)
2020-12-31 11:52 Kunda1 Note Added: 0015182
2020-12-31 11:52 Kunda1 Status new => confirmed
2021-01-07 19:25 kisolre Note Added: 0015202
2021-01-07 19:25 kisolre File Added: NotConnectedFillet.JPG
2021-01-07 19:25 kisolre Note Edited: 0015202
2021-01-25 21:24 chrisb Description Updated
2021-02-03 16:50 Kunda1 Summary Crash on changing Fillet Radius (OCC issue to be retested witj OCC > 7.5) => Crash on changing Fillet Radius (OCC issue to be retested with OCC > 7.5)
2021-02-03 16:52 Kunda1 Tag Attached: fillet
2021-02-03 16:52 Kunda1 Tag Attached: crash
2021-02-03 16:57 Kunda1 Tag Attached: upstream
2021-02-04 05:23 chennes Note Added: 0015264
2021-02-06 06:43 abdullah Target Version => 0.20
2021-02-27 13:31 Kunda1 Assigned To => chennes
2021-02-27 13:31 Kunda1 Status confirmed => resolved
2021-02-27 13:31 Kunda1 Resolution open => fixed
2021-02-27 13:31 Kunda1 Fixed in Version => 0.20
2021-02-27 13:31 Kunda1 Note Added: 0015451
2021-02-27 13:31 Kunda1 Relationship added duplicate of 0004543