View Issue Details

IDProjectCategoryView StatusLast Update
0004462DraftBugpublic2020-12-01 11:17
Reporterhardrock Assigned To 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Platformx86-64OSUbuntuOS Version18.04
Product Version0.19 
Fixed in Version0.19 
Summary0004462: Upgrade from shell to solid failed - UnboundLocalError
DescriptionTherhe is number of faces. Need to make solid from them.
Use Draft Upgrade to make shell. Use it again to make solid -> UnboundLocalError.
Steps To Reproduce1. Select all faces
2. Use Draft Upgrade -> Shell will appear
3. Select shell, use Draft Upgrade -> error
Additional InformationReport

22:30:42 ----------------
22:30:42 GuiCommand: Upgrade
22:30:42 ----------------
22:30:42 Upgrade objects
22:30:42 Found several objects: creating a shell
22:30:45 ----------------
22:30:45 GuiCommand: Upgrade
22:30:45 ----------------
22:30:45 Upgrade objects
22:30:45 Traceback (most recent call last):
  File "/usr/share/freecad-daily/Mod/Draft/draftutils/todo.py", line 167, in doTasks
    Gui.doCommand(string)
  File "<string>", line 1, in <module>
  File "/usr/share/freecad-daily/Mod/Draft/draftfunctions/upgrade.py", line 416, in upgrade
    result = makeSolid(objects[0])
  File "/usr/share/freecad-daily/Mod/Draft/draftfunctions/upgrade.py", line 148, in makeSolid
    return newobj
UnboundLocalError: local variable 'newobj' referenced before assignment

22:30:45 ToDo.doTasks, Unexpected error:
<class 'UnboundLocalError'>
in ['_objs_ = Draft.upgrade(FreeCADGui.Selection.getSelection(), delete=True)', 'FreeCAD.ActiveDocument.recompute()']
TagsNo tags attached.
FreeCAD InformationOS: Ubuntu 18.04.4 LTS (Unity:Unity7:ubuntu/unity)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.
Build type: Release
Branch: unknown
Hash: b0d7850406e046f3b7a8cd5da261e7d54df6bd99
Python version: 3.6.9
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Russian/Russia (ru_RU)

Relationships

related to 0004460 closedyorik Draft Upgrade - Incorrect result 

Activities

hardrock

2020-10-15 19:31

reporter  

Kunda1

2020-10-15 21:19

administrator   ~0014878

Discussion thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=51204

chrisb

2020-10-15 22:46

developer   ~0014879

fixed in this version:

OS: macOS 10.15
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.22670 (Git)
Build type: Release
Branch: master
Hash: 12155f4aab09047c5697db0c1b3cf93b02edda03
Python version: 3.8.6
Qt version: 5.12.9
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)

jmaustpc

2020-10-16 08:11

manager   ~0014884

Many of the original faces do not pass the check geometry test. So it is expected that this would not work.

Kunda1

2020-11-14 11:12

administrator   ~0014985

How should we proceed. It sounds like PEBKAC

Kunda1

2020-11-20 17:24

administrator   ~0015009

Reopening as it seems FreeCAD Pull Request 4067 is related and has a fix for this ticket

marioalexis

2020-11-21 01:43

reporter   ~0015012

Certainly the error is because the shape is not closed, but the makeSolid function fails to catch this and generates the reported error.
In the mentioned pull request this behavior is corrected.

marioalexis

2020-11-25 10:30

reporter   ~0015019

Fix committed to master branch.

Kunda1

2020-12-01 11:17

administrator   ~0015030

Changing status to 'fixed' and closing ticket

Related Changesets

FreeCAD: master 8e080f1d

2020-11-16 04:56:50

marioalexis

Details Diff
Draft: Some fixes in upgrade function. bug 0004460, fixes 0004462, 0004080 Affected Issues
0004080, 0004460, 0004462
mod - src/Mod/Draft/DraftGeomUtils.py Diff File
mod - src/Mod/Draft/draftfunctions/upgrade.py Diff File
mod - src/Mod/Draft/draftgeoutils/faces.py Diff File

Issue History

Date Modified Username Field Change
2020-10-15 19:31 hardrock New Issue
2020-10-15 19:31 hardrock File Added: bug_upgrade_from_shell_to_solid_failed.FCStd
2020-10-15 21:19 Kunda1 Note Added: 0014878
2020-10-15 21:19 Kunda1 Tag Attached: #pending-forum
2020-10-15 22:46 chrisb Assigned To => chrisb
2020-10-15 22:46 chrisb Status new => closed
2020-10-15 22:46 chrisb Resolution open => unable to reproduce
2020-10-15 22:46 chrisb Fixed in Version => 0.19
2020-10-15 22:46 chrisb Note Added: 0014879
2020-10-16 08:11 jmaustpc Note Added: 0014884
2020-10-16 14:04 openBrain Tag Detached: #pending-forum
2020-11-14 11:12 Kunda1 Note Added: 0014985
2020-11-20 17:23 Kunda1 Assigned To chrisb =>
2020-11-20 17:23 Kunda1 Status closed => confirmed
2020-11-20 17:24 Kunda1 Note Added: 0015009
2020-11-20 17:27 Kunda1 Relationship added related to 0004460
2020-11-21 01:43 marioalexis Note Added: 0015012
2020-11-25 10:30 marioalexis Changeset attached => FreeCAD master 8e080f1d
2020-11-25 10:30 marioalexis Note Added: 0015019
2020-12-01 11:16 Kunda1 Status confirmed => resolved
2020-12-01 11:16 Kunda1 Description Updated View Revisions
2020-12-01 11:16 Kunda1 Steps to Reproduce Updated View Revisions
2020-12-01 11:16 Kunda1 Additional Information Updated View Revisions
2020-12-01 11:16 Kunda1 FreeCAD Information OS: Ubuntu 18.04.4 LTS (Unity:Unity7:ubuntu/unity) Word size of OS: 64-bit Word size of FreeCAD: 64-bit Version: 0.19. Build type: Release Branch: unknown Hash: b0d7850406e046f3b7a8cd5da261e7d54df6bd99 Python version: 3.6.9 Qt version: 5.9.5 Coin versi... => OS: Ubuntu 18.04.4 LTS (Unity:Unity7:ubuntu/unity) Word size of OS: 64-bit Word size of FreeCAD: 64-bit Version: 0.19. Build type: Release Branch: unknown Hash: b0d7850406e046f3b7a8cd5da261e7d54df6bd99 Python version: 3.6.9 Qt version: 5.9.5 C...
2020-12-01 11:17 Kunda1 Resolution unable to reproduce => fixed
2020-12-01 11:17 Kunda1 Status resolved => closed
2020-12-01 11:17 Kunda1 Note Added: 0015030