View Issue Details

IDProjectCategoryView StatusLast Update
0004461PartBugpublic2020-10-16 14:03
Reporterhardrock Assigned Tojmaustpc  
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionno change required 
Platformx86-64OSUbuntuOS Version18.04
Product Version0.19 
Summary0004461: Solid from Shell is not solid
DescriptionThere is "good shell", all shell operations done without errors. Now need to convert it to solid and cut something from that.
Convertion to solid using Part - Solid from Shell have completed without any errors. Fruther operations has incorrect result.
Steps To Reproduce1. Use Part - Create solid from shell to create solid object
2. Draw something, for example sketch with square and extrude it to solid
3. Cut extruded sketch from body from #1 - result incorrect
Additional InformationAnother way to get solid from shell - using Draft Upgrade also failed (will post as new issue)
TagsNo tags attached.
FreeCAD InformationOS: Ubuntu 18.04.4 LTS (Unity:Unity7:ubuntu/unity)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.
Build type: Release
Branch: unknown
Hash: b0d7850406e046f3b7a8cd5da261e7d54df6bd99
Python version: 3.6.9
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Russian/Russia (ru_RU)

Activities

Kunda1

2020-10-15 21:18

administrator   ~0014877

Discussion thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=51203

hardrock

2020-10-16 04:23

reporter   ~0014881

Here is it
1_bug_solid_not_solid.tar.gz (1,041,024 bytes)

jmaustpc

2020-10-16 07:36

manager   ~0014882

Last edited: 2020-10-16 07:37

View 2 revisions

I have uncompressed the archive and tested the file in today's FreeCAD 0.19 from the daily PPA, the object so called "OriginalShell", which you appear to think you had converted to a solid, however
1)it is still a shell and
2) it does not pass the Part WB check Geometry test, it contains errors.

I am closing this ticket for now so it can be triaged in the forums first since it appears at this stage to be more of a help request rather than a bug. We can open this ticket again if a bug is found.

Jim

jmaustpc

2020-10-16 07:39

manager   ~0014883

The object is not a solid
1)it is still a shell and
2) it does not pass the Part WB check Geometry test, it contains errors.

I am closing this ticket for now so it can be triaged in the forums first since it appears at this stage to be more of a help request rather than a bug. We can open this ticket again if a bug is found.

Issue History

Date Modified Username Field Change
2020-10-15 19:25 hardrock New Issue
2020-10-15 21:18 Kunda1 Note Added: 0014877
2020-10-15 21:18 Kunda1 Tag Attached: #pending-forum
2020-10-16 04:23 hardrock Note Added: 0014881
2020-10-16 04:23 hardrock File Added: 1_bug_solid_not_solid.tar.gz
2020-10-16 07:36 jmaustpc Note Added: 0014882
2020-10-16 07:37 jmaustpc Note Edited: 0014882 View Revisions
2020-10-16 07:39 jmaustpc Assigned To => jmaustpc
2020-10-16 07:39 jmaustpc Status new => closed
2020-10-16 07:39 jmaustpc Resolution open => no change required
2020-10-16 07:39 jmaustpc Note Added: 0014883
2020-10-16 14:03 openBrain Tag Detached: #pending-forum