View Issue Details

IDProjectCategoryView StatusLast Update
0004457PartDesignBugpublic2021-02-07 13:25
Reporterle_avion Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Target Version0.19Fixed in Version0.19 
Summary0004457: Crash when selecting a line or face and then "select reference" while trying to Revolve
DescriptionCan be reproduced at will.

If I select a sketch and try to revolve it, if I select a line or a face then click on Select Reference... in the dialog freeCAD crashes. I've attache a simple sketch as an example.
Steps To Reproduce1. Start freeCAD
2. Create a new document.
3. Switch to Part Design
4. Create a simple sketch and close out of it.
5. In the Model tab select the sketch.
6. In the Tasks click on Revolution or click on the "Revolve a selected sketch" in the toolbar.
7. Click on any line or face in the sketch.
8. In the "Revolution parameters" dialog box, in the Axis drop-down, select "Select reference..."
9. Crash
Tagscrash, Part Design
FreeCAD InformationOS: KDE Flatpak runtime
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.14555 (Git shallow)
Build type: Release
Branch: (HEAD detached at 783e134)
Hash: 783e1346c7a078f5265c3f0c6a927d09a8c1fe70
Python version: 3.7.4
Qt version: 5.14.2
Coin version: 4.0.0
OCC version: 7.3.0
Locale: English/United States (en_US)

Activities

le_avion

2020-10-12 05:21

reporter  

simple sketch.FCStd (5,134 bytes)

le_avion

2020-10-13 02:18

reporter   ~0014838

I now tested this issue with version 0.19 and it crashes just the same.

OS: Ubuntu Core 16 (ubuntu:GNOME/ubuntu)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.22133 (Git)
Build type: Unknown
Branch: master
Hash: a6df94e37fb4f6595b4674600c22a2e31a56e0a0
Python version: 3.5.2
Qt version: 5.5.1
Coin version: 4.0.0a
OCC version: 7.4.0
Locale: English/UnitedStates (en_US)

Kunda1

2020-10-13 03:24

administrator   ~0014841

Please post to forum to generate discussion (per our guidelines at the top of this page). Thanks.

Kunda1

2020-10-13 03:24

administrator   ~0014842

Changed ticket product version from 0.18 to 0.19

openBrain

2020-10-13 15:14

developer   ~0014843

Can't reproduce based on mentioned procedure
OS: Ubuntu 18.04.5 LTS (KDE/plasma)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19. (20/10/06)
Build type: Release
Branch: unknown
Hash: 566d32177a831855a23d19b013ae96bba42c5a02
Python version: 3.6.9
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/France (fr_FR)

Kunda1

2020-10-14 12:56

administrator   ~0014849

Thread created for discussion: https://forum.freecadweb.org/viewtopic.php?f=8&t=51139

le_avion

2020-10-14 15:27

reporter   ~0014853

The discussion thread I created is here: https://forum.freecadweb.org/viewtopic.php?f=3&t=51132

wmayer was able to reproduce the crash and committed a fix: http://github.com/FreeCAD/FreeCAD/commit/b33f92898

This is amazing how fast a fix was committed. Thank you all for the help!

le_avion

2020-10-19 06:00

reporter   ~0014911

I verified with the daily and wmayer's fix indeed eliminated the crash.

Kunda1

2021-02-07 13:20

administrator   ~0015295

FreeCAD master b33f9289

Kunda1

2021-02-07 13:25

administrator   ~0015296

Closing. Attached commit ticket. Marked the forum thread [Solved]

Related Changesets

FreeCAD: master b33f9289

2020-10-14 13:20:52

wmayer

Details Diff
PartDesign: [skip ci] Improve revolution function
+ Fix hard crash when selecting an edge or face of the created feature before selecting option to choose a reference.
+ In ProfileBased::getAxis() convert OCCT into FreeCAD exception to simplify handling of calling instances.
+ Change return value of getReferencedSelection() from void to bool to mkae it easier for calling instance to detect if the selection failed.
This is needed to avoid to add invalid items to the combo box of the revolution task panel
Affected Issues
0004457
mod - src/Mod/PartDesign/App/FeatureSketchBased.cpp Diff File
mod - src/Mod/PartDesign/Gui/ReferenceSelection.cpp Diff File
mod - src/Mod/PartDesign/Gui/ReferenceSelection.h Diff File
mod - src/Mod/PartDesign/Gui/TaskRevolutionParameters.cpp Diff File

Issue History

Date Modified Username Field Change
2020-10-12 05:21 le_avion New Issue
2020-10-12 05:21 le_avion Tag Attached: 0.18
2020-10-12 05:21 le_avion Tag Attached: crash
2020-10-12 05:21 le_avion Tag Attached: Part Design
2020-10-12 05:21 le_avion File Added: simple sketch.FCStd
2020-10-13 02:18 le_avion Note Added: 0014838
2020-10-13 03:23 Kunda1 Tag Attached: #post-to-forum
2020-10-13 03:24 Kunda1 Status new => feedback
2020-10-13 03:24 Kunda1 Note Added: 0014841
2020-10-13 03:24 Kunda1 Product Version 0.18 => 0.19
2020-10-13 03:24 Kunda1 Description Updated View Revisions
2020-10-13 03:24 Kunda1 Steps to Reproduce Updated View Revisions
2020-10-13 03:24 Kunda1 FreeCAD Information OS: KDE Flatpak runtime Word size of OS: 64-bit Word size of FreeCAD: 64-bit Version: 0.18.14555 (Git shallow) Build type: Release Branch: (HEAD detached at 783e134) Hash: 783e1346c7a078f5265c3f0c6a927d09a8c1fe70 Python version: 3.7.4 Qt version: 5.14.... => OS: KDE Flatpak runtime Word size of OS: 64-bit Word size of FreeCAD: 64-bit Version: 0.18.14555 (Git shallow) Build type: Release Branch: (HEAD detached at 783e134) Hash: 783e1346c7a078f5265c3f0c6a927d09a8c1fe70 Python version: 3.7.4 Qt versio...
2020-10-13 03:24 Kunda1 Note Added: 0014842
2020-10-13 15:14 openBrain Note Added: 0014843
2020-10-14 12:56 Kunda1 Note Added: 0014849
2020-10-14 12:57 Kunda1 Tag Detached: #post-to-forum
2020-10-14 12:57 Kunda1 Tag Detached: 0.18
2020-10-14 12:57 Kunda1 Tag Attached: #pending-forum
2020-10-14 15:27 le_avion Note Added: 0014853
2020-10-14 15:27 le_avion Status feedback => new
2020-10-19 06:00 le_avion Note Added: 0014911
2021-02-06 06:43 abdullah Target Version => 0.20
2021-02-07 13:20 Kunda1 Note Added: 0015295
2021-02-07 13:20 Kunda1 Changeset attached => FreeCAD master b33f9289
2021-02-07 13:21 Kunda1 Tag Detached: #pending-forum
2021-02-07 13:25 Kunda1 Fixed in Version => 0.19
2021-02-07 13:25 Kunda1 Target Version 0.20 => 0.19
2021-02-07 13:25 Kunda1 Note Added: 0015296
2021-02-07 13:25 Kunda1 Status new => closed
2021-02-07 13:25 Kunda1 Resolution open => fixed