View Issue Details

IDProjectCategoryView StatusLast Update
0004437FreeCADBugpublic2020-10-09 21:36
ReporterMUrsavas Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version20.04
Product Version0.18 
Fixed in Version0.19 
Summary0004437: Appearance dialog window placement is wrong in multi display setup
DescriptionHi,

I have an annoying issue with Appearance Window on my multi display setup. If I right click an object in the tree and select "Appearance" from the menu the dialog window is placed at the virtual (0,0) point. But this point is actually doesn't match to my actual hardware mapping. Please check the attached picture, which shows my current display setup.

Left one is my laptop's display and aligned to the bottom side of the primary monitor. I need to use tricks to move the dialog window to the primary display every time I use it. This is pretty annoying and slows me down.

Two options can be considered for a solution.
1) Dialog windows can remember their last X,Y, width and height information.
2) Dialog windows can be opened in the center (or inside the limits) of the main window.
Steps To Reproduce1) Create a multi monitor setup which lacks top left section (refer to attached picture)
2) Open FreeCAD (0.18.4)
3) Open "Parts" workbench
4) Create a box
5) Right Click on the box in the Model window tree
6) Choose "Appearance"
7) Window should be shown on virtual 0,0 and window decoration (title bar, buttons etc) should be inaccessible.
TagsNo tags attached.
FreeCAD InformationOS: Ubuntu 20.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.4.
Build type: Release
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.3.0
Locale: English/United States (en_US)

Activities

MUrsavas

2020-09-16 06:56

reporter  

display-settings.png (36,495 bytes)   
display-settings.png (36,495 bytes)   

MUrsavas

2020-09-18 08:18

reporter   ~0014760

After posting this report I was able to build FreeCAD 0.19 from source and checked the same situation. Looks like it has been fixed and no need to keep this report active.

openBrain

2020-10-09 21:36

developer   ~0014811

Closing following reporter found issue fixed in 0.19

Issue History

Date Modified Username Field Change
2020-09-16 06:56 MUrsavas New Issue
2020-09-16 06:56 MUrsavas File Added: display-settings.png
2020-09-18 08:18 MUrsavas Note Added: 0014760
2020-10-09 21:36 openBrain Status new => closed
2020-10-09 21:36 openBrain Resolution open => fixed
2020-10-09 21:36 openBrain Fixed in Version => 0.19
2020-10-09 21:36 openBrain Note Added: 0014811