View Issue Details

IDProjectCategoryView StatusLast Update
0004432FreeCADBugpublic2020-09-11 17:30
ReporterPedjaS Assigned Torealthunder  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
OSWindowsOS Version8.1 
Product Version0.19 
Fixed in Version0.19 
Summary0004432: Cutting array of cylinders into cube fails
DescriptionForum thread: https://forum.freecadweb.org/viewtopic.php?f=3&t=50002

I have Created simple array of Cylinders and Cube, and I want to use array of Cylinders to cut holes into Cube.

It fails. Instead cutting holes both objects vanish. This is not first time I have this issue. It started with upgrade to 0.19.

Solution I received on forum was to create Array of Cylinders with Link array unchecked and it indeed works.

Link array is checked by default. As it creates problem and it is hard to undo if problem is detected later in a project, my suggestion is to at least set it to be unchecked by default.
Steps To ReproduceCreate Cube,
Create Cylinder
Make array of cylinders
Try to Cut Cube with array of cylinders.

It fails.

Example file is attached.
TagsClone
FreeCAD InformationOS: Windows 8.1 (6.3)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.22284 (Git)
Build type: Release
Branch: master
Python version: 3.8.5
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: English/United States (en_US)

Activities

PedjaS

2020-09-10 18:37

reporter  

holes.FCStd (12,996 bytes)

Kunda1

2020-09-11 17:28

administrator   ~0014743

PR submitted by realthunder
https://github.com/FreeCAD/FreeCAD/pull/3848
Merged by wmayer in FreeCAD master 18c0d8ab

Related Changesets

FreeCAD: master 18c0d8ab

2020-09-06 08:01:16

realthunder


Committer: wwmayer Details Diff
Part: fix dangerous static_cast usage in view provider

Because Gui::ViewProviderLink can be used to override the view provider
of any object, it is not safe to assume view provider type without
explicit checking.
Affected Issues
0004432
mod - src/Mod/Part/Gui/ViewProviderBoolean.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderCompound.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderMirror.cpp Diff File

Issue History

Date Modified Username Field Change
2020-09-10 18:37 PedjaS New Issue
2020-09-10 18:37 PedjaS Tag Attached: Clone
2020-09-10 18:37 PedjaS File Added: holes.FCStd
2020-09-11 17:27 Kunda1 Assigned To => realthunder
2020-09-11 17:27 Kunda1 Status new => assigned
2020-09-11 17:28 Kunda1 Note Added: 0014743
2020-09-11 17:28 Kunda1 Changeset attached => FreeCAD master 18c0d8ab
2020-09-11 17:30 Kunda1 Status assigned => closed
2020-09-11 17:30 Kunda1 Resolution open => fixed
2020-09-11 17:30 Kunda1 Fixed in Version => 0.19