View Issue Details

IDProjectCategoryView StatusLast Update
0004422PartDesignBugpublic2020-09-14 09:00
ReporterJGeo Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows 10OS Version64-bit
Product Version0.19 
Fixed in Version0.19 
Summary0004422: PartDesign value input does not accept trailing slash
DescriptionOther math symbols like +, -, and * are accepted, but not a / as math symbol when typing a numeric value for some constraint, like the radius of a circle or a distance measure. However, sometimes you want to enter the diameter divided by 2, for example. Entering "14/2" does not work, as the "/" is not accepted after the "14". The only way to achieve this is typing "142", then placing the carer one character to the left, and entering the "/" to get "14/2". This is not very intuitive nor convenient. I suppose a syntax checker is running while entering the numeric values, to check for valid numerical entries. However, it is possible to type "7*2" at once, so there must be some regular expression that accepts a *+- but not a /, probably because / is an escape character in a regular expression.
Steps To Reproduce
  1. Open the Part Design module
  2. Start a body
  3. Start a sketch
  4. Create a circle
  5. Select the circle
  6. Click "constrain an arc or a circle"
  7. Enter "14/2"
  8. Note that the entry field shows "142"
  9. Press the left cursor arrow key
  10. Enter "/"
  11. Note that the entry field now shows "14/2"
Tags#pending-forum
FreeCAD InformationOS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.22234 (Git)
Build type: Release
Branch: master
Hash: 068bfc2ebeab8577608f2bdd47200a141dd02c02
Python version: 3.8.5
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: English/United States (en_US)

Activities

Junzo Gordon

2020-08-25 10:14

reporter   ~0014711

Seems it's caused by some violations of the input syntax rules.
Since when I delete the 'mm' unit after the number, I can input '/' after the number.
And If the '/' exists at the end of the input box, 'm' is not accepted any more.

jasincole

2020-08-25 16:33

reporter   ~0014712

I'll verify this bug report. I've noticed the same thing using imperial units. if (in) or (") is at the end of the string you can not type a / slash. Remove the measurement tag and you can enter a /

Kunda1

2020-08-26 11:54

administrator   ~0014718

@JGeo Thanks for the effort in creating a bug report. Did you miss the yellow banner at the top? Next time, please open a forum thread to discuss bugs before opening a ticket. Do you mind going ahead and x-posting to the forum (add links to forum and this ticket so we can track the discussion). Thanks.
@jasincole thanks for confirming. Please always post your full 'About' information so we know in what context you're re-creating the bug.

bananu7

2020-09-09 20:34

reporter   ~0014730

Would this be a good first issue for a beginning FreeCAD contributor?

Kunda1

2020-09-10 14:51

administrator   ~0014732

@bananu7 possibly, the PartDesign code IIRC is in c++
You can open a forum thread to discuss this to see if it makes sense to mark it with the 'low-hanging fruit' tag

Kunda1

2020-09-13 21:55

administrator   ~0014752

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=50189

wmayer

2020-09-14 08:48

administrator   ~0014753

https://github.com/FreeCAD/FreeCAD/commit/d20512216052f049ac76311a9c825852daf712e5

wmayer

2020-09-14 09:00

administrator   ~0014754

Fix committed to master branch.

Related Changesets

FreeCAD: master d2051221

2020-09-14 08:37:46

wmayer

Details Diff
Gui: [skip ci] fixes 0004422: PartDesign value input does not accept trailing slash Affected Issues
0004422
mod - src/Gui/QuantitySpinBox.cpp Diff File

Issue History

Date Modified Username Field Change
2020-08-21 21:22 JGeo New Issue
2020-08-25 10:14 Junzo Gordon Note Added: 0014711
2020-08-25 16:33 jasincole Note Added: 0014712
2020-08-26 11:54 Kunda1 Note Added: 0014718
2020-08-26 11:54 Kunda1 Tag Attached: #post-to-forum
2020-09-09 20:34 bananu7 Note Added: 0014730
2020-09-10 14:51 Kunda1 Note Added: 0014732
2020-09-13 21:55 Kunda1 Note Added: 0014752
2020-09-13 21:56 Kunda1 Tag Detached: #post-to-forum
2020-09-13 21:56 Kunda1 Tag Attached: #pending-forum
2020-09-14 08:48 wmayer Assigned To => wmayer
2020-09-14 08:48 wmayer Status new => closed
2020-09-14 08:48 wmayer Resolution open => fixed
2020-09-14 08:48 wmayer Fixed in Version => 0.19
2020-09-14 08:48 wmayer Note Added: 0014753
2020-09-14 09:00 wmayer Changeset attached => FreeCAD master d2051221
2020-09-14 09:00 wmayer Note Added: 0014754