View Issue Details

IDProjectCategoryView StatusLast Update
0004411PathBugpublic2020-10-15 03:41
Reporterracemaniac Assigned Tosliptonic  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.19 
Summary0004411: Can't regenerate pocket toolpath in certain cases
DescriptionForum thread discussing the issue

For attached example file: after creating a pocket operation, any refresh to the pocket toolpath fails.

Workaround: manually triggering a recompute of the object.
Steps To ReproduceOpen the file
Start a job (default settings)
Create a pocket operation for the highlighted plane, all default settings
Make any change, for example set step over to 80 -> it fails. From then on you can do whatever you want, it'll no longer create any toolpath for that plane with the pocket operation...
Additional InformationCan be worked around by doing a recompute on the body, and then refreshing the toolpath
TagsNo tags attached.
FreeCAD InformationFreeCAD version: OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.22111 (Git)
Build type: Release
Branch: master
Hash: cb2099aa6bb287a8d7843eb70684cce79bdef26b
Python version: 3.6.8
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Dutch/Belgium (nl_BE)

Activities

racemaniac

2020-07-30 07:53

reporter  

Bug.FCStd (269,958 bytes)

sliptonic

2020-10-15 03:41

manager   ~0014856

Mantis cleanup. This appears to be fixed by an earlier PR. I can't reproduce the problem at this time.

Issue History

Date Modified Username Field Change
2020-07-30 07:53 racemaniac New Issue
2020-07-30 07:53 racemaniac File Added: Bug.FCStd
2020-10-15 03:41 sliptonic Assigned To => sliptonic
2020-10-15 03:41 sliptonic Status new => closed
2020-10-15 03:41 sliptonic Resolution open => fixed
2020-10-15 03:41 sliptonic Note Added: 0014856