View Issue Details

IDProjectCategoryView StatusLast Update
0004405FreeCADBugpublic2021-02-24 23:00
ReporterJee-Bee Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Target Version0.20 
Summary0004405: Using PartDesign axis / plane as direction for constraints
DescriptionCurrently it is impossible to set the direction of a force with PD axis or PD planes.
more info see https://forum.freecadweb.org/viewtopic.php?p=414993
Steps To Reproduce - load pd_fem_test.FCstd
 - edit force constraint
 - select direction and click on axis
  + error
TagsFEM, Part Design
FreeCAD Information<!--ATTENTION:
COMPLETELY ERASE THIS AFTER PASTING YOUR
Help > About FreeCAD > Copy to clipboard
NOTE: just the snippet alone will do without anything else included.
The ticket will not be submitted without it.
-->

Activities

Jee-Bee

2020-07-09 13:10

reporter  

pd_fem_test.FCStd (Attachment missing)

openBrain

2020-07-25 09:49

developer   ~0014685

@Jee-Bee : shouldn't this be qualified as a "Feature request" ? In my understanding there is no bug implied here, just a limitation.

Jee-Bee

2021-02-11 11:57

reporter   ~0015322

I'm doubting. Because i think it is just a half implementation. some workbenches / features work some don't. This makes it for me more a bug than a FR(Know i'm just looking from user perspective as developer perspective you are alloud to disagree).
as a site note. for some reason i'm aloud to create reports but i'm not able to change them...

wmayer

2021-02-24 23:00

administrator   ~0015430

Fix committed to master branch.

Related Changesets

FreeCAD: master 8be8c08b

2021-02-24 22:59:10

wmayer

Details Diff
FEM: [skip ci] fixes 0004405: Using PartDesign axis / plane as direction for constraints Affected Issues
0004405
mod - src/Mod/Fem/Gui/TaskFemConstraintForce.cpp Diff File
mod - src/Mod/Fem/Gui/TaskFemConstraintForce.h Diff File

Issue History

Date Modified Username Field Change
2020-07-09 13:10 Jee-Bee New Issue
2020-07-09 13:10 Jee-Bee Tag Attached: FEM
2020-07-09 13:10 Jee-Bee File Added: pd_fem_test.FCStd
2020-07-25 09:49 openBrain Note Added: 0014685
2021-02-06 06:49 abdullah Target Version => 0.20
2021-02-11 11:43 Jee-Bee Tag Attached: sketcher
2021-02-11 11:44 Jee-Bee Tag Detached: sketcher
2021-02-11 11:44 Jee-Bee Tag Attached: Part Design
2021-02-11 11:57 Jee-Bee Note Added: 0015322
2021-02-24 23:00 wmayer Changeset attached => FreeCAD master 8be8c08b
2021-02-24 23:00 wmayer Note Added: 0015430
2021-02-24 23:00 wmayer Assigned To => wmayer
2021-02-24 23:00 wmayer Status new => closed
2021-02-24 23:00 wmayer Resolution open => fixed