View Issue Details

IDProjectCategoryView StatusLast Update
0004385FreeCADBugpublic2020-12-06 17:25
Reporterpandarian Assigned To 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionunable to reproduce 
Product Version0.18 
Summary0004385: Crashed after new project clicked
DescriptionFreeCad Crashed during new project creation. Also opening recent problem have same issue.
Ubuntu 20.04
FreeCad 0.18
Console output on crash:

Program received signal SIGSEGV, Segmentation fault.
#0  /lib/x86_64-linux-gnu/libc.so.6(+0x46210) [0x7fdec3a86210]
#1  /lib/x86_64-linux-gnu/libc.so.6(+0x18d03e) [0x7fdec3bcd03e]
0000002  /usr/lib/x86_64-linux-gnu/libCoin.so.80c(cc_glglue_instance+0x158) [0x7fdec35e3ed8]
0000003  0x7fdec34861a8 in SoGLRenderActionP::isDirectRendering(SoState const*) const from /usr/lib/x86_64-linux-gnu/libCoin.so.80c+0x48
0000004  0x7fdec3488577 in SoGLRenderActionP::render(SoNode*) from /usr/lib/x86_64-linux-gnu/libCoin.so.80c+0xc7
0000005  0x7fdec34887c3 in SoGLRenderAction::beginTraversal(SoNode*) from /usr/lib/x86_64-linux-gnu/libCoin.so.80c+0xa3
0000006  0x7fdec348171a in SoAction::apply(SoNode*) from /usr/lib/x86_64-linux-gnu/libCoin.so.80c+0x28a
0000007  0x7fdec5a7023d in Gui::SoBoxSelectionRenderAction::apply(SoNode*) from /usr/lib/freecad-python3/lib/libFreeCADGui.so+0x2d
0000008  0x7fdec5b082a5 in Gui::View3DInventorViewer::renderScene() from /usr/lib/freecad-python3/lib/libFreeCADGui.so+0x145
0000009  0x7fdec5adb299 in SIM::Coin3D::Quarter::QuarterWidget::paintEvent(QPaintEvent*) from /usr/lib/freecad-python3/lib/libFreeCADGui.so+0x89
0000010  0x7fdec5ae2ee1 in SIM::Coin3D::Quarter::SoQTQuarterAdaptor::paintEvent(QPaintEvent*) from /usr/lib/freecad-python3/lib/libFreeCADGui.so+0x21
0000011  0x7fdec45262b6 in QWidget::event(QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x286
0000012  0x7fdec45d3d52 in QFrame::event(QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x22
0000013  0x7fdec483e421 in QGraphicsView::viewportEvent(QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x161
0000014  0x7fdec5adb45e in SIM::Coin3D::Quarter::QuarterWidget::viewportEvent(QEvent*) from /usr/lib/freecad-python3/lib/libFreeCADGui.so+0x9e
0000015  0x7fdec40b664b in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x9b
0000016  0x7fdec44e3a55 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x75
0000017  0x7fdec44ed0f0 in QApplication::notify(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x330
0000018  0x7fdec58bc208 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib/freecad-python3/lib/libFreeCADGui.so+0x88
0000019  0x7fdec40b693a in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x18a
0000020  0x7fdec451ef4a in QWidgetPrivate::sendPaintEvent(QRegion const&) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x3a
0000021  0x7fdec451f799 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x7f9
0000022  0x7fdec4520423 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x4d3
0000023  0x7fdec451f4a4 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x504
0000024  0x7fdec4520423 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x4d3
0000025  0x7fdec451f4a4 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x504
0000026  0x7fdec4520423 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x4d3
0000027  0x7fdec451f4a4 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x504
0000028  0x7fdec4520423 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x4d3
0000029  0x7fdec451f4a4 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x504
0000030  /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x17cb8e) [0x7fdec44f5b8e]
0000031  /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x17cdc1) [0x7fdec44f5dc1]
0000032  0x7fdec450e385 in QWidgetPrivate::syncBackingStore() from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0xa5
0000033  0x7fdec4526cac in QWidget::event(QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0xc7c
0000034  0x7fdec463b148 in QMainWindow::event(QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x68
0000035  0x7fdec5b701ab in Gui::MainWindow::event(QEvent*) from /usr/lib/freecad-python3/lib/libFreeCADGui.so+0x18b
0000036  0x7fdec44e3a66 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x86
0000037  0x7fdec44ed0f0 in QApplication::notify(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x330
0000038  0x7fdec58bc208 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib/freecad-python3/lib/libFreeCADGui.so+0x88
#39  0x7fdec40b693a in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x18a
#40  /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x17de53) [0x7fdec44f6e53]
0000041  /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x17edb0) [0x7fdec44f7db0]
0000042  0x7fdec4510231 in QWidget::repaint(QRect const&) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x91
0000043  0x7fdec45102a0 in QWidget::repaint() from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x40
0000044  /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x260e3a) [0x7fdec45d9e3a]
0000045  0x7fdec45da035 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0xe5
0000046  0x7fdec46cd5fe in QToolButton::mouseReleaseEvent(QMouseEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0xe
0000047  0x7fdec45262b6 in QWidget::event(QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x286
0000048  0x7fdec46cd6a8 in QToolButton::event(QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x38
0000049  0x7fdec44e3a66 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x86
0000050  0x7fdec44ed343 in QApplication::notify(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x583
0000051  0x7fdec58bc208 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib/freecad-python3/lib/libFreeCADGui.so+0x88
0000052  0x7fdec40b693a in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x18a
0000053  0x7fdec44ec457 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x1b7
0000054  /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x1c935d) [0x7fdec454235d]
0000055  /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x1cc1ec) [0x7fdec45451ec]
0000056  0x7fdec44e3a66 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x86
0000057  0x7fdec44ed0f0 in QApplication::notify(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x330
0000058  0x7fdec58bc208 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib/freecad-python3/lib/libFreeCADGui.so+0x88
0000059  0x7fdec40b693a in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x18a
0000060  0x7fdec22e17d3 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5+0x6e3
0000061  0x7fdec22e310b in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5+0x25b
0000062  0x7fdec22bd35b in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5+0xbb
0000063  /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5(+0x7932e) [0x7fdebdba132e]
0000064  /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x27d) [0x7fdec192efbd]
0000065  /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x52240) [0x7fdec192f240]
0000066  /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x33) [0x7fdec192f2e3]
0000067  0x7fdec410e565 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x65
0000068  0x7fdec40b54db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x12b
0000069  0x7fdec40bd246 in QCoreApplication::exec() from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x96
0000070  0x7fdec584a92f in Gui::Application::runApplication() from /usr/lib/freecad-python3/lib/libFreeCADGui.so+0x165f
0000071  freecad(main+0x6a6) [0x55b5f4a43bd6]
0000072  /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0x7fdec3a670b3]
0000073  freecad(_start+0x2e) [0x55b5f4a43f3e]
Tags#post-to-forum
FreeCAD Information<!--ATTENTION:
COMPLETELY ERASE THIS AFTER PASTING YOUR
Help > About FreeCAD > Copy to clipboard
NOTE: just the snippet alone will do without anything else included.
The ticket will not be submitted without it.
-->

Activities

Kunda1

2020-06-26 17:02

administrator   ~0014585

@pandarian big yellow box at the top of this bugtracker explains to post issues to forum before opening a ticket. Please do so and link back to this ticket + post the the forum thread here so we can track.

Kunda1

2020-12-06 17:25

administrator   ~0015095

No follow up from OP. OP should've tested on v0.19 as we weren't accepting v0.18 bugs at the time the ticket was makde. Closing ticket.

Issue History

Date Modified Username Field Change
2020-06-26 13:00 pandarian New Issue
2020-06-26 17:02 Kunda1 Status new => feedback
2020-06-26 17:02 Kunda1 Note Added: 0014585
2020-06-26 17:02 Kunda1 Tag Attached: #post-to-forum
2020-12-06 17:25 Kunda1 Status feedback => closed
2020-12-06 17:25 Kunda1 Resolution open => unable to reproduce
2020-12-06 17:25 Kunda1 Note Added: 0015095