View Issue Details

IDProjectCategoryView StatusLast Update
0004355FreeCADBugpublic2021-02-08 11:46
ReporterKonstantinIT Assigned Towmayer  
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target Version0.19 
Summary0004355: When exporting, an unreadable STEP file is created
DescriptionWhen exporting, an unreadable STEP file is created
If you create a STEP file in a directory whose name includes Cyrillic characters (and possibly any non-Latin characters), the created STEP file does not open in FreeCAD.
Steps To ReproduceCreate /tmp/Директория
Create /tmp/freecad

Save any as STEP to Create /tmp/Директория/test1.step and /tmp/freecad/test1.step

Open them



Additional Information--- /tmp/freecad/test2.step
+++ /tmp/freecad/test1.step
@@ -1,8 +1,9 @@
 ISO-10303-21;
 HEADER;
 FILE_DESCRIPTION(('FreeCAD Model'),'2;1');
-FILE_NAME('/tmp/freecad/test2.step','2020-06-01T10:03:44',('Author'),(''
- ),'Open CASCADE STEP processor 7.3','FreeCAD','Unknown');
+FILE_NAME('/tmp/Директория/test1.step','2020-06-01T10:03:36',(
+ 'Author'),(''),'Open CASCADE STEP processor 7.3','FreeCAD','Unknown'
+ );
 FILE_SCHEMA(('CONFIG_CONTROL_DESIGN','SHAPE_APPEARANCE_LAYER_MIM'));
 ENDSEC;
 DATA;
TagsNo tags attached.
FreeCAD InformationOS: Ubuntu 18.04.4 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.4.
Build type: Release
Python version: 3.6.8
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Russian/Russia (ru_RU)

Relationships

duplicate of 0004477 closedwmayer Can't import .STEP files with cyrillic symbols 

Activities

KonstantinIT

2020-06-01 07:09

reporter  

test2.step (Attachment missing)
test1.step (Attachment missing)

openBrain

2020-06-04 18:09

developer   ~0014459

@KonstantinIT : please address your issue following our reporting guidelines by opening first a topic in our forum. Thx
We generally accept tickets when issue has been vet by the community, and especially confirmed to still exist in current development version (which you can test by yourself).

Kunda1

2020-06-05 14:17

administrator   ~0014469

@KonstantinIT bump

KonstantinIT

2020-06-05 22:22

reporter   ~0014485

Added topic on forum:
https://forum.freecadweb.org/viewtopic.php?f=29&t=47289

chennes

2020-12-15 04:01

developer   ~0015144

This is probably a duplicate of 0004477, resolved by 78c6cc1.

Kunda1

2021-02-08 11:46

administrator   ~0015310

Indeed, I can open this with OS: Manjaro Linux (KDE//usr/share/xsessions/plasma)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23882 (Git)
Build type: Release
Branch: master
Hash: bead9bb9381d039d6dda438b07e30dace7cf33ae
Python version: 3.9.1
Qt version: 5.15.2
Coin version: 4.0.1
OCC version: 7.5.0
Locale: English/United States (en_US)

Thanks @chennes. Closing ticket as dupe.

Issue History

Date Modified Username Field Change
2020-06-01 07:09 KonstantinIT New Issue
2020-06-01 07:09 KonstantinIT File Added: test2.step
2020-06-01 07:09 KonstantinIT File Added: test1.step
2020-06-04 18:09 openBrain Status new => feedback
2020-06-04 18:09 openBrain Description Updated
2020-06-04 18:09 openBrain Steps to Reproduce Updated
2020-06-04 18:09 openBrain Additional Information Updated
2020-06-04 18:09 openBrain FreeCAD Information OS: Ubuntu 18.04.4 LTS Word size of OS: 64-bit Word size of FreeCAD: 64-bit Version: 0.18.4. Build type: Release Python version: 3.6.8 Qt version: 5.9.5 Coin version: 4.0.0a OCC version: 7.3.0 Locale: Russian/Russia (ru_RU) => OS: Ubuntu 18.04.4 LTS Word size of OS: 64-bit Word size of FreeCAD: 64-bit Version: 0.18.4. Build type: Release Python version: 3.6.8 Qt version: 5.9.5 Coin version: 4.0.0a OCC version: 7.3.0 Locale: Russian/Russia (ru_RU)
2020-06-04 18:09 openBrain Note Added: 0014459
2020-06-04 18:09 openBrain Tag Attached: #post-to-forum
2020-06-05 14:17 Kunda1 Note Added: 0014469
2020-06-05 22:22 KonstantinIT Note Added: 0014485
2020-06-05 22:22 KonstantinIT Status feedback => new
2020-06-06 10:15 openBrain Tag Detached: #post-to-forum
2020-06-06 10:16 openBrain Tag Attached: #pending-forum
2020-12-15 04:01 chennes Note Added: 0015144
2021-02-06 06:49 abdullah Target Version => 0.20
2021-02-08 11:46 Kunda1 Assigned To => wmayer
2021-02-08 11:46 Kunda1 Status new => closed
2021-02-08 11:46 Kunda1 Resolution open => fixed
2021-02-08 11:46 Kunda1 Note Added: 0015310
2021-02-08 11:46 Kunda1 Relationship added duplicate of 0004477
2021-02-08 11:46 Kunda1 Target Version 0.20 => 0.19
2021-02-08 11:46 Kunda1 Tag Detached: #pending-forum