View Issue Details

IDProjectCategoryView StatusLast Update
0004349FreeCADBugpublic2020-10-10 12:15
Reporterdoronbehar Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version0.18 
Summary0004349: Can't build with opencascade 7.4.0 (downstream NixOS repo trying to build v0.18)
DescriptionHi,

On NixOS, we'd like to update opencascade (from https://www.opencascade.org/ ) to version 7.4.0 but we encounter a regression for the build of freecad with this update for opencascade.

The build errors are as follows:


[124/3309] Building CXX object src/3rdParty/salomesmesh/CMakeFiles/MEFISTO2.dir/src/MEFISTO2/aptrte.cpp.o
FAILED: src/3rdParty/salomesmesh/CMakeFiles/MEFISTO2.dir/src/MEFISTO2/aptrte.cpp.o
/nix/store/2ddwl0cyff2cd4dkb2nqf1xich7halj0-gcc-wrapper-9.3.0/bin/g++  -DCSFDB -DHAVE_CONFIG_H -DHAVE_LIMITS_H -DLIN -DMEFISTO2_EXPORTS -DOCC_CONVERT_SIGNALS -D_OCC64 -I. -Isrc -I../src -I../src/3rdParty/salomesmesh/src/SMDS -I../src/3rdParty/salomesmesh/src/Driver -I../src/3rdParty/salomesmesh/src/DriverUNV -I../src/3rdParty/salomesmesh/src/DriverDAT -I../src/3rdParty/salomesmesh/src/DriverSTL -I../src/3rdParty/salomesmesh/src/StdMeshers -I../src/3rdParty/salomesmesh/inc -Isrc/3rdParty/salomesmesh -I/nix/store/k0qp4m6fp9bfwbsar0w53zp1vv1rvx10-opencascade-occt-7.4.0/include/opencascade -I/nix/store/mcycq83xcq84hz1lyc9j13ddhk1225qn-vtk-7.1.1/include/vtk-7.1 -Wall -Wextra -Wno-write-strings  -std=c++11 -D_OCC64 -Wno-sign-compare -Wno-reorder -Wno-switch -Wno-unused-variable -Wno-unused-but-set-variable -Wno-comment -Wno-unused-parameter -O3 -DNDEBUG -fPIC   -DMEFISTO2D_EXPORTS -pthread -I/nix/store/rd6dn4jljlb5418lqxmwdimy6s9sawwg-openmpi-4.0.3/include -MD -MT src/3rdParty/salomesmesh/CMakeFiles/MEFISTO2.dir/src/MEFISTO2/aptrte.cpp.o -MF src/3rdParty/salomesmesh/CMakeFiles/MEFISTO2.dir/src/MEFISTO2/aptrte.cpp.o.d -o src/3rdParty/salomesmesh/CMakeFiles/MEFISTO2.dir/src/MEFISTO2/aptrte.cpp.o -c ../src/3rdParty/salomesmesh/src/MEFISTO2/aptrte.cpp
In file included from ../src/3rdParty/salomesmesh/src/MEFISTO2/aptrte.cpp:27:
../src/3rdParty/salomesmesh/inc/Rn.h:183:10: error: 'istream' does not name a type
  183 |   friend istream& operator >>(istream& f,  R4 & P)
      |          ^~~~~~~
../src/3rdParty/salomesmesh/inc/Rn.h:188:10: error: 'istream' does not name a type
  188 |   friend istream& operator >>(istream& f,  R4 * P)
      |          ^~~~~~~

Feel free to close this if this error no longer appears in the 0.19 branch.
Steps To ReproduceWell you have to install Nix and all that so I wouldn't expect you to actually do that, but for reference, the PR for updating opencascade is here: https://github.com/NixOS/nixpkgs/pull/70668
Tagsdownstream, linux, OCC Bug, packaging
FreeCAD InformationIt's a build error so I don't have this info.

Activities

Kunda1

2020-10-10 12:08

administrator   ~0014814

@doronbehar thanks for posting, glad to see there are FreeCAD users on NixOS
Heads up:We may not backport a fix like this to v0.18 (per the large yellow banner at the top of this page)
Our attention is strictly on getting the postponed v0.19 release out ASAP.
You are welcome to post this ticket to the forum (per our guidelines).
Also we are currently patching our sourcecode to support the upcoming OCCT 7.5 which is currently in beta.

Kunda1

2020-10-10 12:15

administrator   ~0014815

Looks like downstream decided to package v0.19 dev for now. Thanks for bearing with is.
Reference downstream ticket https://github.com/NixOS/nixpkgs/pull/70668 has been closed.
PR: https://github.com/NixOS/nixpkgs/pull/98845

Issue History

Date Modified Username Field Change
2020-05-23 10:44 doronbehar New Issue
2020-10-10 12:08 Kunda1 Note Added: 0014814
2020-10-10 12:08 Kunda1 Tag Attached: OCC Bug
2020-10-10 12:08 Kunda1 Tag Attached: packaging
2020-10-10 12:10 Kunda1 Severity block => minor
2020-10-10 12:10 Kunda1 Status new => feedback
2020-10-10 12:10 Kunda1 Summary Can't build with opencascade 7.4.0 => Can't build with opencascade 7.4.0 (downstream NixOS repo trying to build v0.18)
2020-10-10 12:10 Kunda1 Tag Attached: linux
2020-10-10 12:11 Kunda1 Tag Attached: downstream
2020-10-10 12:15 Kunda1 Note Added: 0014815
2020-10-10 12:15 Kunda1 Status feedback => closed
2020-10-10 12:15 Kunda1 Resolution open => no change required