View Issue Details

IDProjectCategoryView StatusLast Update
0004347FreeCADBugpublic2020-12-06 17:42
ReporterAurawin Assigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version0.19 
Summary0004347: Upgrade to Ubuntu 20.04 yields slow performance
DescriptionI recently upgraded my Ubuntu to 20.04 from 19.10. Daily worked flawlessly for me w/r/t performance.

Since I can't automatically get daily I downloaded appImage from site and to my disappointment, it is dog slow.

Opening projects that have recursive fusions/cuts can take minutes. CPU pegged at 100%. The projects eventually open or update (A2Plus).
Steps To ReproduceOpen existing project

or

Change fusion child object and wait for refresh

or

Change file and refresh using A2Plus
Additional InformationNo crash, no warnings. Just performance.
TagsNo tags attached.
FreeCAD InformationOS: Ubuntu 20.04 LTS (GNOME/gnome-xorg)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.21097 (Git) AppImage
Build type: Release
Branch: master
Hash: a5ab09aa0941cc945e59848897b160f8cbfc0831
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: English/United States (en_US)

Activities

openBrain

2020-05-18 12:34

developer   ~0014421

@Aurawin : please address your issue following our reporting guidelines by opening first a topic in our forum. Please get familiar with this important notice before. Once topic is created, please post here a link to it. Thx

Kunda1

2020-12-06 17:42

administrator   ~0015096

No follow-up from OP. Not enough information or stats provided. No discussion thread.
Therefore closing this ticket.

Issue History

Date Modified Username Field Change
2020-05-18 03:38 Aurawin New Issue
2020-05-18 12:34 openBrain Status new => feedback
2020-05-18 12:34 openBrain Note Added: 0014421
2020-05-18 12:34 openBrain Tag Attached: #post-to-forum
2020-12-06 17:42 Kunda1 Status feedback => closed
2020-12-06 17:42 Kunda1 Resolution open => unable to reproduce
2020-12-06 17:42 Kunda1 Note Added: 0015096
2020-12-06 17:42 Kunda1 Tag Detached: #post-to-forum