View Issue Details

IDProjectCategoryView StatusLast Update
0000434FreeCADBugpublic2011-09-11 10:25
Reporterunauthenticated Assigned To 
Status closedResolutionno change required 
Product Versiontrunk 
Fixed in Version0.12 
Summary0000434: Error: "No module named SketcherGUI" (or TestSketcherApp)
DescriptionRunning ./FreeCAD, app opens fine, and a all workbenches can be activated, but on attempting to select workbenches 'complete' or 'part design', a dialog with "No module named SketcherGUI" pops up.
Additional Informationcompiled and made FreeCAD from trunk on Ubuntu 11.04 64bit (using
attempted multiple times over a couple of days. Doesn't matter if 0.10 (from Ubuntu repostitory) is installed or not. I also tried copying the named folder from 0.10 into the 0.12 folder, with caused lots more errors.

When run with command lines get two possible errors:-
./FreeCAD -t 0
FreeCAD 0.12, Libs: 0.12R4905
No module named TestSketcherApp
[then exits back to command line]

FreeCAD 0.12, Libs: 0.12R4905
No module named SketcherGui
[then FreeCAD loads and runs as noted in description]

On running the self tests from the Test framework workbench,
  *TestApp.All fails with:-
  Error loading specified test: <type 'exceptions.ImportError'>, No module named TestSketcherApp
  *TestSketcherApp fails with same error,
  *Workbench comes up with SketcherGUI popup (as above)

Application was complied with the following script:-
#NB: The default install directory is ~/FreeCAD

read -p "make takes about 30mins..."

sudo apt-get install build-essential python libcoin60-dev libsoqt4-dev \
libxerces-c2-dev libboost-dev libboost-date-time-dev libboost-filesystem-dev \
libboost-graph-dev libboost-iostreams-dev libboost-program-options-dev \
libboost-serialization-dev libboost-signals-dev libboost-regex-dev libboost-thread-dev \
libqt4-dev qt4-dev-tools python2.6-dev libopencascade-dev libsoqt4-dev \
libode-dev subversion cmake libeigen2-dev libsimage-dev python-qt4 \
libtool autotools-dev automake bison flex libf2c2-dev gfortran

# checkout the latest source
svn co freecad

# go to source dir
cd freecad

# build configuration
cmake .

# build FreeCAD

# test FreeCAD
cd bin
./FreeCAD -t 0

# use FreeCAD

read -p "Done - Please press ctl-c to stop execution..."

TagsNo tags attached.
FreeCAD Information



2011-09-11 03:15

manager   ~0001056

Last edited: 2011-09-11 04:16

I'm not sure this is the source of your problem, but the CompileOnUnix wiki page is outdated. The Sketcher requires libeigen3-dev, which is available in Ubuntu 11.10 repository, or on the freecad-maintainers PPA. I suggest you install this dependency and try again.

I'm going to add this to the wiki.

Edit: done, check


2011-09-11 08:35

viewer   ~0001058

Thanks that was the problem. Now resolved, and works fine!

Issue History

Date Modified Username Field Change
2011-09-10 19:44 unauthenticated New Issue
2011-09-11 03:15 normandc Note Added: 0001056
2011-09-11 04:16 normandc Note Edited: 0001056
2011-09-11 08:35 unauthenticated Note Added: 0001058
2011-09-11 10:25 wmayer Status new => closed
2011-09-11 10:25 wmayer Resolution open => no change required
2011-09-11 10:25 wmayer Fixed in Version => 0.12