View Issue Details

IDProjectCategoryView StatusLast Update
0004324SketcherBugpublic2020-06-09 11:40
Reporterlc03 Assigned Toabdullah  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.19 
Fixed in Version0.19 
Summary0004324: In expression editor in the sketcher the tooltip hides the input field.
DescriptionWhen one want to enter an expression in a dimension constraint the help tooltip hides the text input field.
I am assuming that this happens because the error message "Property 'Sketch' not found in 'Sketch'" in red takes two lines instead of one.
This appens for any dimenssioning tools (vertical, horizontal, angle, radius, length).
Steps To Reproduce1) Create a sketch
2) Create a line
3) Add a dimension constraint to this line and trying to enter a formula for the value.
Result: during the input of the expression the input help tooltip (which lists the accessible objects) hides the input field as shown on the attachment.
Tags#post-to-forum
FreeCAD InformationOS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.20738 (Git)
Build type: Release
Branch: master
Hash: 0c96f77184edc0a6747483b2ff1462fc6dae46ff
Python version: 3.6.8
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/France (fr_FR)

Activities

lc03

2020-04-27 08:51

reporter  

openBrain

2020-04-28 19:43

developer   ~0014384

@lc03 : Please address your issue according our reporting guidelines by first opening a topic on our forum ("Help on using FreeCAD" subsection in English or "Forum français" in French) so community can vet the issue and narrow down the causes. Cross-link the topic with this ticket. Thx

abdullah

2020-06-06 14:15

manager   ~0014486

PR:
https://github.com/FreeCAD/FreeCAD/pull/3572

abdullah

2020-06-07 05:24

manager   ~0014490

git commit ac4196fb66a34cc4f246afa3c5858e6d4b821875

abdullah

2020-06-09 11:40

manager   ~0014521

Fix committed to master branch.

Related Changesets

FreeCAD: master ac4196fb

2020-06-06 14:12:06

abdullah


Committer: abdullahtahiriyo Details Diff
Expressions: Avoid multiline error messages

===========================================

fixes 0004324

A multiline error message produces poor visualisation when used in the UI, while
there is no need for it to be multiline.
Affected Issues
0004324
mod - src/App/ObjectIdentifier.cpp Diff File

Issue History

Date Modified Username Field Change
2020-04-27 08:51 lc03 New Issue
2020-04-27 08:51 lc03 File Added: Bug Tooltip shadow input field.jpg
2020-04-28 19:39 openBrain Tag Attached: #post-to-forum
2020-04-28 19:43 openBrain Status new => feedback
2020-04-28 19:43 openBrain Note Added: 0014384
2020-06-06 14:15 abdullah Note Added: 0014486
2020-06-07 05:24 abdullah Assigned To => abdullah
2020-06-07 05:24 abdullah Status feedback => closed
2020-06-07 05:24 abdullah Resolution open => fixed
2020-06-07 05:24 abdullah Fixed in Version => 0.19
2020-06-07 05:24 abdullah Note Added: 0014490
2020-06-09 11:40 abdullah Changeset attached => FreeCAD master ac4196fb
2020-06-09 11:40 abdullah Note Added: 0014521