View Issue Details

IDProjectCategoryView StatusLast Update
0004321FreeCADBugpublic2021-03-16 21:13
ReporterAmoscaceca Assigned Tochennes  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformmacOSosxOS Versionhigh sierra
Target Version0.20 
Summary0004321: Crash program during chamfer
DescriptionCreating a chamfer on edge 183 when increasing over 1 mm the program closes
Steps To ReproduceCreating a chamfer on edge 183 when increasing over 1 mm the program closes
Additional InformationLast login: Fri Apr 24 09:04:42 on ttys000
You have new mail.
iMac:~ amosfrer$ cd /Applications/FreeCAD.app/Contents/Resources/bin 
iMac:bin amosfrer$ lldb freecad
(lldb) target create "freecad"
runCurrent executable set to 'freecad' (x86_64).
(lldb) run
Process 4730 launched: '/Applications/FreeCAD.app/Contents/Resources/bin/freecad' (x86_64)
FreeCAD 0.19, Libs: 0.19R20655 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre and others 2001-2020
FreeCAD is free and open-source software licensed under the terms of LGPL2+ license.
FreeCAD wouldn't be possible without FreeCAD community.
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

2020-04-24 09:20:46.025447+0200 freecad[4730:119971] MessageTracer: Falling back to default whitelist
During initialization the error "invalid character in identifier (<string>, line 1)" occurred in /Users/amosfrer/Library/Preferences/FreeCAD/Mod/fasteners/InitGui.py
Please look into the log file for further information
GVA error: Not detecting IGPU in IORegistry!
GVA error: Not detecting valid offline codec!
GVA info: Successfully connected to the Intel plugin, offline Gen6 
2020-04-24 09:20:58.021002+0200 freecad[4730:120297] GVA info: preferred scaler idx 0
4.6e-08 <App> Document.cpp(3715): Failed to recompute coperchio_hotend#Chamfer003: Failed to create chamfer
Process 4730 stopped
* thread #1, name = 'CrBrowserMain', queue = 'com.apple.main-thread', stop reason = EXC_BAD_ACCESS (code=1, address=0x60)
    frame #0: 0x0000000127e8e78b libTKBRep.7.dylib`BRep_Tool::Curve(TopoDS_Edge const&, TopLoc_Location&, double&, double&) + 43
libTKBRep.7.dylib`BRep_Tool::Curve:
->  0x127e8e78b <+43>: movq   0x60(%rax), %rbx
    0x127e8e78f <+47>: testq  %rbx, %rbx
    0x127e8e792 <+50>: je     0x127e8e7b6               ; <+86>
    0x127e8e794 <+52>: movq   %rdi, %r14
Target 0: (freecad) stopped.
(lldb) bt
* thread #1, name = 'CrBrowserMain', queue = 'com.apple.main-thread', stop reason = EXC_BAD_ACCESS (code=1, address=0x60)
  * frame #0: 0x0000000127e8e78b libTKBRep.7.dylib`BRep_Tool::Curve(TopoDS_Edge const&, TopLoc_Location&, double&, double&) + 43
    frame #1: 0x0000000127e8e8f8 libTKBRep.7.dylib`BRep_Tool::Curve(TopoDS_Edge const&, double&, double&) + 72
    frame 0000002: 0x000000012666b929 libTKFillet.7.dylib`ChFi3d_Builder::PerformIntersectionAtEnd(int) + 27577
    frame 0000003: 0x000000012665c4c2 libTKFillet.7.dylib`ChFi3d_Builder::PerformOneCorner(int, bool) + 6162
    frame 0000004: 0x00000001265f8376 libTKFillet.7.dylib`ChFi3d_Builder::PerformFilletOnVertex(int) + 1094
    frame 0000005: 0x00000001265f5aeb libTKFillet.7.dylib`ChFi3d_Builder::Compute() + 1691
    frame 0000006: 0x00000001267ef50a libTKFillet.7.dylib`BRepFilletAPI_MakeChamfer::Build() + 42
    frame 0000007: 0x000000013fe15f31 _PartDesign.so`PartDesign::Chamfer::execute() + 1121
    frame 0000008: 0x00000001016a082e libFreeCADApp.dylib`App::DocumentObject::recompute() + 174
    frame 0000009: 0x00000001253564bc Part.so`Part::Feature::recompute() + 12
    frame 0000010: 0x000000010160cf95 libFreeCADApp.dylib`App::Document::_recomputeFeature(App::DocumentObject*) + 837
    frame 0000011: 0x0000000101610372 libFreeCADApp.dylib`App::Document::recomputeFeature(App::DocumentObject*, bool) + 418
    frame 0000012: 0x0000000102661400 libQt5Core.5.dylib`QMetaObject::activate(QObject*, int, int, void**) + 1798
    frame 0000013: 0x00000001005839d2 libFreeCADGui.dylib`Gui::QuantitySpinBox::userInput(QString const&) + 562
    frame 0000014: 0x0000000102661400 libQt5Core.5.dylib`QMetaObject::activate(QObject*, int, int, void**) + 1798
    frame 0000015: 0x0000000101d6c3c4 libQt5Widgets.5.dylib`QLineEdit::textChanged(QString const&) + 44
    frame 0000016: 0x0000000102661400 libQt5Core.5.dylib`QMetaObject::activate(QObject*, int, int, void**) + 1798
    frame 0000017: 0x0000000101d6e937 libQt5Widgets.5.dylib`QWidgetLineControl::textChanged(QString const&) + 45
    frame 0000018: 0x0000000101d6d357 libQt5Widgets.5.dylib`QWidgetLineControl::finishChange(int, bool, bool) + 447
    frame 0000019: 0x0000000101d70633 libQt5Widgets.5.dylib`QWidgetLineControl::processKeyEvent(QKeyEvent*) + 913
    frame 0000020: 0x0000000101d69f51 libQt5Widgets.5.dylib`QLineEdit::keyPressEvent(QKeyEvent*) + 27
    frame 0000021: 0x0000000101cc0f1e libQt5Widgets.5.dylib`QWidget::event(QEvent*) + 1414
    frame 0000022: 0x0000000101d69987 libQt5Widgets.5.dylib`QLineEdit::event(QEvent*) + 503
    frame 0000023: 0x0000000101da601b libQt5Widgets.5.dylib`QAbstractSpinBox::keyPressEvent(QKeyEvent*) + 935
    frame 0000024: 0x000000010058324d libFreeCADGui.dylib`Gui::QuantitySpinBox::keyPressEvent(QKeyEvent*) + 317
    frame 0000025: 0x0000000101cc0f1e libQt5Widgets.5.dylib`QWidget::event(QEvent*) + 1414
    frame 0000026: 0x0000000101da53a1 libQt5Widgets.5.dylib`QAbstractSpinBox::event(QEvent*) + 161
    frame 0000027: 0x0000000101c99f98 libQt5Widgets.5.dylib`QApplicationPrivate::notify_helper(QObject*, QEvent*) + 214
    frame 0000028: 0x0000000101c9b148 libQt5Widgets.5.dylib`QApplication::notify(QObject*, QEvent*) + 1338
    frame 0000029: 0x000000010017b2e9 libFreeCADGui.dylib`Gui::GUIApplication::notify(QObject*, QEvent*) + 89
    frame 0000030: 0x0000000102644aa0 libQt5Core.5.dylib`QCoreApplication::notifyInternal2(QObject*, QEvent*) + 138
    frame 0000031: 0x0000000101cd2560 libQt5Widgets.5.dylib`___lldb_unnamed_symbol1124$$libQt5Widgets.5.dylib + 442
    frame 0000032: 0x0000000101c99f98 libQt5Widgets.5.dylib`QApplicationPrivate::notify_helper(QObject*, QEvent*) + 214
    frame 0000033: 0x0000000101c9ae26 libQt5Widgets.5.dylib`QApplication::notify(QObject*, QEvent*) + 536
    frame 0000034: 0x000000010017b2e9 libFreeCADGui.dylib`Gui::GUIApplication::notify(QObject*, QEvent*) + 89
    frame 0000035: 0x0000000102644aa0 libQt5Core.5.dylib`QCoreApplication::notifyInternal2(QObject*, QEvent*) + 138
    frame 0000036: 0x0000000102185134 libQt5Gui.5.dylib`QGuiApplicationPrivate::processKeyEvent(QWindowSystemInterfacePrivate::KeyEvent*) + 158
    frame 0000037: 0x0000000102177ef4 libQt5Gui.5.dylib`QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 84
    frame 0000038: 0x0000000102175a86 libQt5Gui.5.dylib`QWindowSystemInterface::flushWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 310
    frame #39: 0x000000010c299790 libqcocoa.dylib`___lldb_unnamed_symbol769$$libqcocoa.dylib + 1086
    frame #40: 0x000000010c29990e libqcocoa.dylib`___lldb_unnamed_symbol770$$libqcocoa.dylib + 60
    frame 0000041: 0x00007fff4728b43d AppKit`-[NSWindow(NSEventRouting) _reallySendEvent:isDelayedEvent:] + 5040
    frame 0000042: 0x00007fff47289c70 AppKit`-[NSWindow(NSEventRouting) sendEvent:] + 497
    frame 0000043: 0x000000010c29c56e libqcocoa.dylib`___lldb_unnamed_symbol862$$libqcocoa.dylib + 445
    frame 0000044: 0x00007fff470eb236 AppKit`-[NSApplication(NSEvent) sendEvent:] + 2462
    frame 0000045: 0x000000010c2a1421 libqcocoa.dylib`___lldb_unnamed_symbol1043$$libqcocoa.dylib + 59
    frame 0000046: 0x00007fff4694b87d AppKit`-[NSApplication run] + 812
    frame 0000047: 0x000000010c29eb61 libqcocoa.dylib`___lldb_unnamed_symbol935$$libqcocoa.dylib + 1277
    frame 0000048: 0x00000001026426bf libQt5Core.5.dylib`QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) + 267
    frame 0000049: 0x0000000102644ece libQt5Core.5.dylib`QCoreApplication::exec() + 116
    frame 0000050: 0x00000001000bf955 libFreeCADGui.dylib`Gui::Application::runApplication() + 10645
    frame 0000051: 0x0000000100004f16 freecad`main + 5958
    frame 0000052: 0x00007fff713a7015 libdyld.dylib`start + 1
    frame 0000053: 0x00007fff713a7015 libdyld.dylib`start + 1
(lldb) 
TagsChamfer, crash, fillet, OCC Bug, upstream
FreeCAD InformationOS: macOS High Sierra (10.13)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.20655 (Git)
Build type: Release
Branch: master
Hash: e8e67e8c5ebbc9f9ed9ea67aba5b891969595ece
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)

Relationships

duplicate of 0004543 resolvedchennes FreeCAD crashes when OCC fails with fillets and chamfers 
related to 0004322 closed Crash on Chamfer 

Activities

Amoscaceca

2020-04-24 08:09

reporter  

openBrain

2020-04-24 17:53

developer   ~0014370

@Amoscaceca : please address your issue according our reporting guidelines by opening a topic in our forum. Thx

Kunda1

2020-04-25 14:14

administrator   ~0014380

@Amoscaceca please open a thread on the forum to discuss (paste URL back here to track issue)

Kunda1

2020-05-02 04:04

administrator   ~0014397


During initialization the error "invalid character in identifier (<string>, line 1)" occurred in /Users/amosfrer/Library/Preferences/FreeCAD/Mod/fasteners/InitGui.py


@Amoscaceca open a forum topic please

dulouie

2020-05-05 13:07

reporter   ~0014402

I can not find egde183. Sorry but your description is faulty.
Maybe its's the same ? https://forum.freecadweb.org/viewtopic.php?f=3&t=46063

Kunda1

2020-09-10 15:09

administrator   ~0014738

@chrisb looks similar to 0004322
Please test on OSX as well. Thanks!

chennes

2021-02-04 05:22

developer   ~0015263

I cannot download the posted FCStd file to test, but based on the backtrace I believe this is resolved by the fix discussed in 0004543.

chennes

2021-02-07 22:48

developer   ~0015305

OK, I was able to download the file. Edge183 is a very tiny 39.25µm (probably unintentional?) edge -- applying the patch discussed on 0004543 eliminates the segfault, but there is no chamfer setting that will result in a successful chamfer on this edge.
TinyEdge.png (130,171 bytes)   
TinyEdge.png (130,171 bytes)   

Kunda1

2021-02-27 13:36

administrator   ~0015455

@chennes how to you propose to proceed? close this ticket? or open a new ticket to address the auxiliary issue?

chennes

2021-03-14 22:18

developer   ~0015522

I think we can close it -- that very tiny edge won't be able to be filleted, and the segfault is resolved.

Kunda1

2021-03-16 21:13

administrator   ~0015527

Closing

Issue History

Date Modified Username Field Change
2020-04-24 08:09 Amoscaceca New Issue
2020-04-24 08:09 Amoscaceca File Added: coperchio hotend (Copia in conflitto di amos freri 2020-04-24).FCStd
2020-04-24 17:52 openBrain Tag Attached: #post-to-forum
2020-04-24 17:53 openBrain Status new => feedback
2020-04-24 17:53 openBrain Note Added: 0014370
2020-04-25 14:14 Kunda1 Note Added: 0014380
2020-05-02 04:04 Kunda1 Note Added: 0014397
2020-05-05 13:07 dulouie Note Added: 0014402
2020-09-10 15:08 Kunda1 Relationship added related to 0004322
2020-09-10 15:09 Kunda1 Note Added: 0014738
2021-02-03 16:58 Kunda1 Tag Attached: crash
2021-02-03 16:58 Kunda1 Tag Attached: upstream
2021-02-03 16:58 Kunda1 Tag Attached: Chamfer
2021-02-03 16:58 Kunda1 Tag Attached: fillet
2021-02-03 16:58 Kunda1 Tag Attached: OCC Bug
2021-02-04 05:22 chennes Note Added: 0015263
2021-02-06 06:49 abdullah Target Version => 0.20
2021-02-07 22:48 chennes Note Added: 0015305
2021-02-07 22:48 chennes File Added: TinyEdge.png
2021-02-27 13:36 Kunda1 Note Added: 0015455
2021-02-27 13:37 Kunda1 Additional Information Updated
2021-03-14 22:18 chennes Note Added: 0015522
2021-03-16 21:12 Kunda1 Relationship added child of 0004543
2021-03-16 21:13 Kunda1 Assigned To => chennes
2021-03-16 21:13 Kunda1 Status feedback => closed
2021-03-16 21:13 Kunda1 Resolution open => duplicate
2021-03-16 21:13 Kunda1 Note Added: 0015527
2021-03-16 21:13 Kunda1 Relationship replaced duplicate of 0004543
2021-03-16 21:13 Kunda1 Tag Detached: #post-to-forum