View Issue Details

IDProjectCategoryView StatusLast Update
0004319PartDesignBugpublic2021-02-27 13:30
Reporteraxos88 Assigned Tochennes  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntu OS Version19.10
Target Version0.20Fixed in Version0.20 
Summary0004319: Segfault removing edge from sketch
DescriptionProbably something to do with the chamfering of the edge of the inner circle.
Steps To ReproduceRepro:

1. Open Sketch "Sketch" within "Pad"
2. Delete inner circle
3. Segfault occurs
Additional InformationReproduces on FreeCAD_0.19-20514-Linux-Conda_glibc2.12-x86_64.AppImage
TagsChamfer, crash, fillet, OCC Bug, upstream
FreeCAD InformationOS: Ubuntu 19.04 (ubuntu:GNOME/ubuntu)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.20514 (Git) AppImage
Build type: Release
Branch: master
Hash: a05ffd499366ab12fa1b43f37db73f4f1e9c332d
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: English/United States (en_US)

Relationships

duplicate of 0004543 resolvedchennes FreeCAD FreeCAD crashes when OCC fails with fillets and chamfers 

Activities

axos88

2020-04-20 18:22

reporter  

RuhaRudTarto.FCStd (42,451 bytes)

Kunda1

2020-04-22 11:22

administrator   ~0014362

@axos88 thank you, per our guidelines, it is customary to open a forum thread first to discuss bugs with the community. Please then open a forum thread and x-post back to this thread (and vice versa) to better track the progress of this issue.

axos88

2020-04-22 12:55

reporter   ~0014364

https://forum.freecadweb.org/viewtopic.php?f=8&t=45563

voskos

2021-01-02 09:47

reporter   ~0015197

I can reproduce it on latest-ish daily ppa


Program received signal SIGSEGV, Segmentation fault.
#0 /lib/x86_64-linux-gnu/libc.so.6(+0x46210) [0x7fbc1506a210]
#1 0x7fbbfefddbc0 in Geom_TrimmedCurve::Geom_TrimmedCurve(opencascade::handle<Geom_Curve> const&, double, double, bool, bool) from /usr/lib/x86_64-linux-gnu/libTKG3d.so.7+0x1b0
0000002 /usr/lib/x86_64-linux-gnu/libTKFillet.so.7(+0x17d2b2) [0x7fbbff3942b2]
0000003 0x7fbbff39b236 in ChFi3d_Builder::PerformMoreThreeCorner(int, int) from /usr/lib/x86_64-linux-gnu/libTKFillet.so.7+0x5a96
0000004 0x7fbbff37cc52 in ChFi3d_Builder::PerformIntersectionAtEnd(int) from /usr/lib/x86_64-linux-gnu/libTKFillet.so.7+0x1c82
0000005 0x7fbbff389133 in ChFi3d_Builder::PerformOneCorner(int, bool) from /usr/lib/x86_64-linux-gnu/libTKFillet.so.7+0x2d83
0000006 0x7fbbff32775c in ChFi3d_Builder::PerformFilletOnVertex(int) from /usr/lib/x86_64-linux-gnu/libTKFillet.so.7+0x46c
0000007 0x7fbbff328b1e in ChFi3d_Builder::Compute() from /usr/lib/x86_64-linux-gnu/libTKFillet.so.7+0xdbe
0000008 0x7fbbff4ba711 in BRepFilletAPI_MakeChamfer::Build() from /usr/lib/x86_64-linux-gnu/libTKFillet.so.7+0x31
0000009 0x7fbbb03558d1 in PartDesign::Chamfer::execute() from /home/vosk/FreeCAD/build/Mod/PartDesign/_PartDesign.so+0x577
0000010 0x7fbc17965f25 in App::DocumentObject::recompute() from /home/vosk/FreeCAD/build/lib/libFreeCADApp.so+0xd5
0000011 0x7fbc045b03a1 in Part::Feature::recompute() from /home/vosk/FreeCAD/build/Mod/Part/Part.so+0x1f
0000012 0x7fbc178645c9 in App::Document::_recomputeFeature(App::DocumentObject*) from /home/vosk/FreeCAD/build/lib/libFreeCADApp.so+0x1d1
0000013 0x7fbc178623f6 in App::Document::recompute(std::vector<App::DocumentObject*, std::allocator<App::DocumentObject*> > const&, bool, bool*, int) from /home/vosk/FreeCAD/build/lib/libFreeCADApp.so+0x908
0000014 0x7fbc179f6d15 in App::DocumentPy::recompute(_object*) from /home/vosk/FreeCAD/build/lib/libFreeCADApp.so+0x35f
0000015 0x7fbc179ee040 in App::DocumentPy::staticCallback_recompute(_object*, _object*) from /home/vosk/FreeCAD/build/lib/libFreeCADApp.so+0xee
0000016 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(+0x2a8357) [0x7fbc1688b357]
0000017 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(_PyObject_MakeTpCall+0xab) [0x7fbc1688b7db]
0000018 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(+0x74df3) [0x7fbc16657df3]
0000019 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(_PyEval_EvalFrameDefault+0x7d86) [0x7fbc1665fef6]
0000020 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(_PyEval_EvalCodeWithName+0x8fb) [0x7fbc167add3b]
0000021 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(PyEval_EvalCodeEx+0x42) [0x7fbc167ae0c2]
0000022 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(PyEval_EvalCode+0x1f) [0x7fbc167ae4af]
0000023 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(+0x18bf0c) [0x7fbc1676ef0c]
0000024 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(PyRun_StringFlags+0x79) [0x7fbc1676f269]
0000025 0x7fbc16d519fd in Base::InterpreterSingleton::runString[abi:cxx11](char const*) from /home/vosk/FreeCAD/build/lib/libFreeCADBase.so+0xeb
0000026 0x7fbc18ffae9b in Gui::Command::_runCommand(char const*, int, Gui::Command::DoCmd_Type, char const*) from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0xdd
0000027 0x7fbc18ffaaea in Gui::Command::_doCommand(char const*, int, Gui::Command::DoCmd_Type, char const*, ...) from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0x128
0000028 0x7fbc18ffbdb2 in Gui::Command::updateActive() from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0x4a
0000029 0x7fbba9213e79 in SketcherGui::ViewProviderSketch::unsetEdit(int) from /home/vosk/FreeCAD/build/Mod/Sketcher/SketcherGui.so+0x18f
0000030 0x7fbc1946e101 in Gui::ViewProvider::finishEditing() from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0x35
0000031 0x7fbc18f02bde in Gui::Document::_resetEdit() from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0x114
0000032 0x7fbc18e666cc in Gui::Application::setEditDocument(Gui::Document*) from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0xbc
0000033 0x7fbc18f02ac7 in Gui::Document::resetEdit() from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0x27
0000034 0x7fbc18f88058 in Gui::DocumentPy::resetEdit(_object*) from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0x50
0000035 0x7fbc18f83200 in Gui::DocumentPy::staticCallback_resetEdit(_object*, _object*) from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0xee
0000036 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(+0x2a8357) [0x7fbc1688b357]
0000037 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(_PyObject_MakeTpCall+0xab) [0x7fbc1688b7db]
0000038 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(+0x74df3) [0x7fbc16657df3]
#39 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(_PyEval_EvalFrameDefault+0x7d86) [0x7fbc1665fef6]
#40 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(_PyEval_EvalCodeWithName+0x8fb) [0x7fbc167add3b]
0000041 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(PyEval_EvalCodeEx+0x42) [0x7fbc167ae0c2]
0000042 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(PyEval_EvalCode+0x1f) [0x7fbc167ae4af]
0000043 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(+0x18bf0c) [0x7fbc1676ef0c]
0000044 /usr/lib/x86_64-linux-gnu/libpython3.8.so.1.0(PyRun_StringFlags+0x79) [0x7fbc1676f269]
0000045 0x7fbc16d519fd in Base::InterpreterSingleton::runString[abi:cxx11](char const*) from /home/vosk/FreeCAD/build/lib/libFreeCADBase.so+0xeb
0000046 0x7fbc18ffae9b in Gui::Command::_runCommand(char const*, int, Gui::Command::DoCmd_Type, char const*) from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0xdd
0000047 0x7fbc18ffaaea in Gui::Command::_doCommand(char const*, int, Gui::Command::DoCmd_Type, char const*, ...) from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0x128
0000048 0x7fbba925d467 in SketcherGui::TaskDlgEditSketch::reject() from /home/vosk/FreeCAD/build/Mod/Sketcher/SketcherGui.so+0x18f
0000049 0x7fbc19397002 in Gui::TaskView::TaskView::reject() from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0x82
0000050 /home/vosk/FreeCAD/build/lib/libFreeCADGui.so(+0x14c66d9) [0x7fbc193976d9]
0000051 0x7fbc156c4300 in QMetaObject::activate(QObject*, int, int, void**) from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x7d0
0000052 /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x306b5c) [0x7fbc1624eb5c]
0000053 0x7fbc156c4300 in QMetaObject::activate(QObject*, int, int, void**) from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x7d0
0000054 0x7fbc161a7806 in QAbstractButton::clicked(bool) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x46
0000055 /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x25fa2e) [0x7fbc161a7a2e]
0000056 /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x260e73) [0x7fbc161a8e73]
0000057 0x7fbc161a9035 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0xe5
0000058 0x7fbc160f52b6 in QWidget::event(QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x286
0000059 0x7fbc160b2a66 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x86
0000060 0x7fbc160bc343 in QApplication::notify(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x583
0000061 0x7fbc18fb52b2 in Gui::GUIApplication::notify(QObject*, QEvent*) from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0x112
0000062 0x7fbc1569893a in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x18a
0000063 0x7fbc160bb457 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x1b7
0000064 /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x1c935d) [0x7fbc1611135d]
0000065 /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5(+0x1cc1ec) [0x7fbc161141ec]
0000066 0x7fbc160b2a66 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x86
0000067 0x7fbc160bc0f0 in QApplication::notify(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5+0x330
0000068 0x7fbc18fb52b2 in Gui::GUIApplication::notify(QObject*, QEvent*) from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0x112
0000069 0x7fbc1569893a in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x18a
0000070 0x7fbc15a817d3 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5+0x6e3
0000071 0x7fbc15a8310b in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5+0x25b
0000072 0x7fbc15a5d35b in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5+0xbb
0000073 /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5(+0x7932e) [0x7fbc0f43b32e]
0000074 /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x27d) [0x7fbc13376fbd]
0000075 /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x52240) [0x7fbc13377240]
0000076 /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x33) [0x7fbc133772e3]
0000077 0x7fbc156f0565 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x65
0000078 0x7fbc156974db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x12b
0000079 0x7fbc1569f246 in QCoreApplication::exec() from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5+0x96
0000080 0x7fbc18e6d850 in Gui::Application::runApplication() from /home/vosk/FreeCAD/build/lib/libFreeCADGui.so+0x24b6
0000081 ./FreeCAD(+0x9689) [0x55af2b1d5689]
0000082 /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0x7fbc1504b0b3]
0000083 ./FreeCAD(+0x896e) [0x55af2b1d496e]

stacktrace


OS: Linux Mint 20 (X-Cinnamon/cinnamon2d)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.
Build type: Release
Branch: unknown
Hash: f2d17774e8c9154f80b98f797e3561ee2ad36061
Python version: 3.8.5
Qt version: 5.12.8
Coin version: 4.0.0
OCC version: 7.3.0
Locale: English/United States (en_US)

version

chennes

2021-02-04 05:20

developer   ~0015262

In my testing, this is resolved by the fix discussed in 0004543.

Kunda1

2021-02-27 13:30

administrator   ~0015450

@chennes has created a downstream patch that fixes the crash. It is slowly being integrated in to downstream packages (ATM libpack is the only one but more will follow). This issue is therefore being marked as resolved. It will be closed once all packages are patched or when (if) upstream merges.

Issue History

Date Modified Username Field Change
2020-04-20 18:22 axos88 New Issue
2020-04-20 18:22 axos88 File Added: RuhaRudTarto.FCStd
2020-04-22 11:22 Kunda1 Note Added: 0014362
2020-04-22 11:23 Kunda1 Status new => feedback
2020-04-22 11:26 Kunda1 Tag Attached: #post-to-forum
2020-04-22 12:55 axos88 Note Added: 0014364
2020-04-22 12:55 axos88 Status feedback => new
2020-04-22 13:00 Kunda1 Tag Detached: #post-to-forum
2020-04-22 13:00 Kunda1 Tag Attached: #pending-forum
2021-01-02 09:47 voskos Note Added: 0015197
2021-01-25 16:32 wmayer Status new => confirmed
2021-02-03 16:58 Kunda1 Tag Attached: Chamfer
2021-02-03 16:58 Kunda1 Tag Attached: fillet
2021-02-03 16:58 Kunda1 Tag Attached: crash
2021-02-03 16:58 Kunda1 Tag Attached: upstream
2021-02-03 16:58 Kunda1 Tag Attached: OCC Bug
2021-02-04 05:20 chennes Note Added: 0015262
2021-02-06 06:43 abdullah Target Version => 0.20
2021-02-27 13:29 Kunda1 Tag Detached: #pending-forum
2021-02-27 13:30 Kunda1 Assigned To => chennes
2021-02-27 13:30 Kunda1 Status confirmed => resolved
2021-02-27 13:30 Kunda1 Resolution open => fixed
2021-02-27 13:30 Kunda1 Fixed in Version => 0.20
2021-02-27 13:30 Kunda1 Note Added: 0015450
2021-02-27 13:30 Kunda1 Relationship added duplicate of 0004543