View Issue Details

IDProjectCategoryView StatusLast Update
0004317ArchBugpublic2020-09-10 14:55
Reporterazure Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status feedbackResolutionopen 
Summary0004317: Draft grid visible through an arch wall
DescriptionSee the attached screenshot wallbug.png. When looking at an arch wall from the top, the top of the wall appears "open" and you can see the draft grid through it.

The problem seems to occur only if grid spacing is below 5mm. The smaller the spacing is, the larger area of the grid can be seen through the wall.

If spacing is 5mm or larger, as in the screenshot wallbug_grid_50mm.png, the wall looks normal to me.

If I turn the grid off, a black area appears on top of the wall as seen in the screenshot wallbug_grid_off.png
Steps To Reproduce- Use FreeCAD version from git shown in the section FreeCAD information.
- Ensure the grid settings are "factory default".
- Select Arch workbench.
- Load the attached wallbug.FCStd file.
- Make the grid visible (for me the grid is not always visible at first even though I believe it is "on" - I have to turn if off first and then back on).
- Try changing the grid spacing and turning the grid off.
Tags#pending-forum
FreeCAD InformationOS: Ubuntu 19.10 (KDE/plasma)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.20634 (Git)
Build type: Debug
Branch: master
Hash: ba34cc6a96c15d64224e8f0c8b5da874f1e03a07
Python version: 3.7.5
Qt version: 5.12.4
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/United States (en_US)

Activities

azure

2020-04-18 23:29

reporter  

wallbug.png (168,608 bytes)   
wallbug.png (168,608 bytes)   
wallbug.FCStd (8,805 bytes)
wallbug_grid_50mm.png (261,118 bytes)   
wallbug_grid_50mm.png (261,118 bytes)   
wallbug_grid_off.png (168,666 bytes)   
wallbug_grid_off.png (168,666 bytes)   

openBrain

2020-04-19 09:46

developer   ~0014359

@azure : when encountering issue with FreeCAD, please process according our reporting guidelines by first opening a topic in our forum.
Here looks like a graphical issue. Does the problem vanish if you select 'Fit all' view ?

Kunda1

2020-04-25 14:04

administrator   ~0014377

@azure please follow-up by posting a thread to the forum and posting the URL here.

Kunda1

2020-06-07 14:23

administrator   ~0014500

@azure ping

mikeprice99

2020-07-22 19:26

reporter   ~0014678

I occasionally dive in to see if I can help with a bug/issue. I've looked at the sample file for this bug: the "Walltrace" is for a wall 50mm long, 3m high and 200mm thick - and I can't reproduce the 'error'. I wouldn't expect a reasonable interpretation.

Kunda1

2020-09-10 14:54

administrator   ~0014733

Last edited: 2020-09-10 14:55

View 2 revisions

Thanks @mikeprice99. Appreciate any help triaging that you'd offer :)
I'll open a thread on the forum for this since OP ( @azure ) hasn't responded.

Edit: forum thread: https://forum.freecadweb.org/viewtopic.php?f=23&t=50121

Issue History

Date Modified Username Field Change
2020-04-18 23:29 azure New Issue
2020-04-18 23:29 azure File Added: wallbug.png
2020-04-18 23:29 azure File Added: wallbug.FCStd
2020-04-18 23:29 azure File Added: wallbug_grid_50mm.png
2020-04-18 23:29 azure File Added: wallbug_grid_off.png
2020-04-19 09:45 openBrain Tag Attached: #post-to-forum
2020-04-19 09:46 openBrain Status new => feedback
2020-04-19 09:46 openBrain Note Added: 0014359
2020-04-25 14:04 Kunda1 Note Added: 0014377
2020-06-07 14:23 Kunda1 Note Added: 0014500
2020-07-22 19:26 mikeprice99 Note Added: 0014678
2020-09-10 14:54 Kunda1 Note Added: 0014733
2020-09-10 14:55 Kunda1 Note Edited: 0014733 View Revisions
2020-09-10 14:55 Kunda1 Tag Detached: #post-to-forum
2020-09-10 14:55 Kunda1 Tag Attached: #pending-forum