View Issue Details

IDProjectCategoryView StatusLast Update
0004266TechDrawBugpublic2020-02-20 21:22
Reporteruwestoehr Assigned Towandererfan  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.19 
Target Version0.19Fixed in Version0.19 
Summary0004266: crash on selecting TD element in tree when page not shown
Description- open the attached example file.

As you can see the page is not shown. This is important to reproduce the crash.

- double click in the tree on the entry "LeaderLine"

result: you get this error:

Illegal storage access...
<Exception> Illegal storage access! Please save your work under a new file name and restart the application!

Afterwards FC will crash sooner or later.
Additional InformationConfirmed by others: https://forum.freecadweb.org/viewtopic.php?f=35&t=43360
TagsNo tags attached.
FreeCAD InformationOS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.19570 (Git)
Build type: Release
Branch: master
Hash: 53bbf09bf9a624428808c2d528949092adb6fdbf
Python version: 3.6.8
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Germany (de_DE)

Activities

uwestoehr

2020-02-15 16:02

developer  

TD-Cube.FCStd (40,459 bytes)

uwestoehr

2020-02-17 11:32

developer   ~0014160

fixed by: https://github.com/FreeCAD/FreeCAD/commit/e8417c6268

Kunda1

2020-02-20 21:19

administrator   ~0014173

Last edited: 2020-02-20 21:20

View 2 revisions

FreeCAD master e8417c62
FreeCAD master e8417c62

Kunda1

2020-02-20 21:22

administrator   ~0014174

Closing ticket Even though was unsuccessful associating ticket number with GitHub commit using source integration. Probably due to the migration of the tracker to the new host. Closing ticket nonetheless

Issue History

Date Modified Username Field Change
2020-02-15 16:02 uwestoehr New Issue
2020-02-15 16:02 uwestoehr File Added: TD-Cube.FCStd
2020-02-15 16:04 uwestoehr Assigned To => wandererfan
2020-02-15 16:04 uwestoehr Status new => assigned
2020-02-17 11:32 uwestoehr Note Added: 0014160
2020-02-17 11:32 uwestoehr Status assigned => resolved
2020-02-17 11:32 uwestoehr Resolution open => fixed
2020-02-17 11:32 uwestoehr Fixed in Version => 0.19
2020-02-20 21:19 Kunda1 Note Added: 0014173
2020-02-20 21:20 Kunda1 Note Edited: 0014173 View Revisions
2020-02-20 21:22 Kunda1 Status resolved => closed
2020-02-20 21:22 Kunda1 Note Added: 0014174