View Issue Details

IDProjectCategoryView StatusLast Update
0004263FreeCADBugpublic2020-09-12 15:07
Reporterjylandry Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version0.18 
Target Version0.19 
Summary0004263: Problem with negative offset "Placement" when the preference are "Building US" units
Descriptionhttps://forum.freecadweb.org/viewtopic.php?f=8&t=42766

When using "Placement" for an object and working with the unit in "Building US(ft-in/sqft/cuft)"

You can't work with negative number. For example, «-1.5"» or «-1+1/2"» will translate to «-1/2»

The same for «-13'6"» that will become «-12'6"»
Steps To Reproduce1) Put your preference in "Building US(ft-in/sqft/cuft)"

2) Create an empty document with an object like a cube (or anything will do)

3) try to change the "placement" (Translation) -- any of X: Y: or Z: -- Enter «-1.5"» or «-1+1/2"» or «-13'6"»

if you return in placement, the entry «-1.5"» should have been change to «-1/2"»
the entry «-13'6"» shall have been change by «-12'6"»
Tags#pending-forum, units
FreeCAD InformationOS: Ubuntu 18.04.4 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.4.
Build type: Release
Python version: 3.6.8
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)

Relationships

related to 0003925 confirmed Expressions Negative numbers with multiple units interpeted as expressions 

Activities

openBrain

2020-02-10 11:00

developer   ~0014144

Could that be a duplicate of 0003925 ?

jylandry

2020-02-11 02:16

reporter   ~0014149

I look at it. Some aspect of 0003925 might exhibit the same symptom.

However, their is additional problem with the Building US unit related to the interpretation of the fraction.

a) When you enter -10+1/8" and click OK on the "Placement box"... you get -9+7/8". This might be similar to 0003925.

b) When you re-enter the "Placement Box", it does display -8+1/8". I don't think it is the same.

jylandry

2020-02-11 02:17

reporter   ~0014150

if you look at the post https://forum.freecadweb.org/viewtopic.php?f=8&t=42766

I have documented several cases scenario... including one that is not flagged as a bug.

pablito

2020-09-12 15:07

reporter   ~0014744

Independently observed again in 0.19.22366 and discussed in thread : https://forum.freecadweb.org/viewtopic.php?p=429940#p429940

Issue History

Date Modified Username Field Change
2020-02-10 09:40 jylandry New Issue
2020-02-10 11:00 openBrain Relationship added related to 0003925
2020-02-10 11:00 openBrain Note Added: 0014144
2020-02-11 02:16 jylandry Note Added: 0014149
2020-02-11 02:17 jylandry Note Added: 0014150
2020-02-20 21:29 Kunda1 Tag Attached: units
2020-02-20 21:30 Kunda1 Target Version => 0.19
2020-02-20 21:30 Kunda1 Tag Attached: #pending-forum
2020-09-12 15:07 pablito Note Added: 0014744