View Issue Details

IDProjectCategoryView StatusLast Update
0004260PathBugpublic2020-08-04 16:00
Reporterfreman Assigned Tosliptonic  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.19 
Target Version0.19 
Summary0004260: boundaryDressup causing tool crashes.
Descriptionboundarydressup inserts spurious machine position which leads to non vertical cut paths across protected clamps space. This can damage clamps and likely destroy tools, possibly dangerously.

https://forum.freecadweb.org/viewtopic.php?f=15&t=42820
Steps To ReproduceI've detailed this once and bug reporter lost it. I won't start again. Refer to forum post.
TagsNo tags attached.
FreeCAD InformationOS: Fedora 31 (Thirty One) (LXDE/LXDE)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.19317 (Git)
Build type: Release
Branch: spiral-fix
Hash: 2064410da473da178cf79cb8d80ef48952df00c5
Python version: 3.7.6
Qt version: 5.13.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/United Kingdom (en_GB)

Activities

freman

2020-02-05 21:43

reporter   ~0014142

PR to avoid possible tool crashes.

https://github.com/FreeCAD/FreeCAD/pull/3009

Kunda1

2020-02-07 18:22

administrator   ~0014143

Last edited: 2020-02-07 18:24

View 2 revisions

@fremen FYI, it's also possible to reference PRs in github using
p:FreeCAD:3009:

Which looks like this when it's interpreted by Mantisbt.
FreeCAD Pull Request 3009

See https://www.freecadweb.org/wiki/Tracker#MantisBT_.3C.3D.3E_GitHub_Markup for more info.

sliptonic

2020-08-04 16:00

manager   ~0014699

Fix committed to master branch.

Related Changesets

FreeCAD: master c944aafc

2020-02-08 15:10:50

J-Dunn


Committer: GitHub Details Diff
fix missing HorizFeed in boundaryDressup

fix missing HorizFeed in boundaryDressup see bug 0004260
Affected Issues
0004260
mod - src/Mod/Path/PathScripts/PathDressupPathBoundary.py Diff File

FreeCAD: master 5c67c40d

2020-08-04 15:40:13

sliptonic


Committer: GitHub Details Diff
Merge pull request 0003751 from J-Dunn/master

Path: prevent added paths creating tool crash: fixed 0004260
Affected Issues
0004260
mod - src/Mod/Path/PathScripts/PathDressupPathBoundary.py Diff File

Issue History

Date Modified Username Field Change
2020-02-03 09:40 freman New Issue
2020-02-04 16:16 Kunda1 Target Version => 0.19
2020-02-05 21:43 freman Note Added: 0014142
2020-02-07 18:22 Kunda1 Note Added: 0014143
2020-02-07 18:24 Kunda1 Note Edited: 0014143 View Revisions
2020-03-02 20:16 Changeset attached => FreeCAD master c944aafc
2020-08-04 16:00 sliptonic Changeset attached => FreeCAD master 5c67c40d
2020-08-04 16:00 sliptonic Note Added: 0014699
2020-08-04 16:00 sliptonic Assigned To => sliptonic
2020-08-04 16:00 sliptonic Status new => closed
2020-08-04 16:00 sliptonic Resolution open => fixed