View Issue Details

IDProjectCategoryView StatusLast Update
0004259FreeCADBugpublic2020-02-02 20:50
Reporterleong Assigned Totriplus  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformLinux  
Product Version0.19 
Fixed in Version0.19 
Summary0004259: 0.19-19405 frezees computer on startup and consumes all memory
DescriptionJust installed 0.19-19405 appimage. When I run it on my machine it stops with the splash screen up and the message:
"Initializing freecad.asm3
The entire computer freezes and it appears all the memory is being consumed rapidly. This is not an issue with 0.19-19371
Steps To ReproduceInstall appimage
Run appimage
Tags#pending-forum
FreeCAD Information<!--ATTENTION:
COMPLETELY ERASE THIS AFTER PASTING YOUR
Help > About FreeCAD > Copy to clipboard
NOTE: just the snippet alone will do without anything else included.
The ticket will not be submitted without it.
-->

Activities

Genues

2020-01-30 20:49

reporter   ~0014127

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=4&t=42860

openBrain

2020-01-31 10:01

developer   ~0014128

Will wait for forum discussion
@Kunda1 : what do you think we should do with this ? If I understand correctly the forum thread, this happened because @looo decided to merge ASM3 in the AppImage build. Should we care of this as it's not vanilla code ?

Kunda1

2020-01-31 17:05

administrator   ~0014129

@openBrain we need to xpost the ticket to the thread and rename the thread. This will bump the activity. Lets keep the ticket in 'feedback' status as well so we can monitor it.

Genues

2020-02-02 18:20

reporter   ~0014131

Last edited: 2020-02-02 18:21

View 2 revisions

It looks like this problem is now solved. See the forum thread.

triplus

2020-02-02 20:50

developer   ~0014134

The Issue was resolved.

Issue History

Date Modified Username Field Change
2020-01-30 17:57 leong New Issue
2020-01-30 20:49 Genues Note Added: 0014127
2020-01-31 10:01 openBrain Status new => feedback
2020-01-31 10:01 openBrain Note Added: 0014128
2020-01-31 10:01 openBrain Tag Attached: #pending-forum
2020-01-31 17:05 Kunda1 Note Added: 0014129
2020-02-02 18:20 Genues Note Added: 0014131
2020-02-02 18:21 Genues Note Edited: 0014131 View Revisions
2020-02-02 20:50 triplus Assigned To => triplus
2020-02-02 20:50 triplus Status feedback => closed
2020-02-02 20:50 triplus Resolution open => fixed
2020-02-02 20:50 triplus Fixed in Version => 0.19
2020-02-02 20:50 triplus Note Added: 0014134