View Issue Details

IDProjectCategoryView StatusLast Update
0004232FreeCADBugpublic2021-02-24 23:39
Reportermadhead Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinux x64OSManjaro 
Target Version0.19Fixed in Version0.19 
Summary0004232: Recompute failed (SIGSEGV) after editing a cell in a spreadsheet
DescriptionAfter the update from 0.18 to 0.19 FreeCAD crashes on updating spreadsheet cells.

[EDIT(openBrain)]Forum thread
Steps To Reproduce
  1. Open the attached file rig.fcstd.
  2. Open "data" spreadsheet from the tree for editing.
  3. Set cell B15 to, say, 80mm.
  4. Save the spreadsheet.
  5. FreeCAD crashes, log file attached. The issue is not reproducible on 0.18, it started to crash in 0.19 only.
Tags#pending-forum
FreeCAD InformationOS: Manjaro Linux (KDE//usr/share/xsessions/plasma)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.18947 (Git) AppImage
Build type: Release
Branch: master
Hash: 91f6a5e5ee1b48063d5d4b59cc6250fc2a1021b1
Python version: 3.7.3
Qt version: 5.12.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/United Kingdom (en_GB)

Activities

madhead

2019-12-21 18:40

reporter  

FreeCAD.log (Attachment missing)
rig.FCStd (Attachment missing)

openBrain

2019-12-23 17:23

developer   ~0013935

@madhead : thx for reporting. However according guidelines (big yellow box on top of page), possible bugs shall first be discussed by opening a new topic in our forum, so community can confirm and identify it, and eventually narrow down the context. Please accordingly open a topic and cross-link it with this ticket.

madhead

2019-12-25 12:12

reporter   ~0013940

Seems to be fixed in the latest builds (e.g. 19056)!

wmayer

2021-02-24 23:39

administrator   ~0015432

Reporter said it's fixed now.

Issue History

Date Modified Username Field Change
2019-12-21 18:40 madhead New Issue
2019-12-21 18:40 madhead File Added: FreeCAD.log
2019-12-21 18:40 madhead File Added: rig.FCStd
2019-12-23 17:22 openBrain Tag Attached: #post-to-forum
2019-12-23 17:23 openBrain Status new => feedback
2019-12-23 17:23 openBrain Note Added: 0013935
2019-12-23 20:14 openBrain Description Updated
2019-12-23 20:15 openBrain Tag Detached: #post-to-forum
2019-12-23 20:15 openBrain Tag Attached: #pending-forum
2019-12-25 12:12 madhead Note Added: 0013940
2019-12-25 12:12 madhead Status feedback => new
2021-02-06 06:49 abdullah Target Version => 0.20
2021-02-24 23:38 wmayer Target Version 0.20 => 0.19
2021-02-24 23:39 wmayer Status new => closed
2021-02-24 23:39 wmayer Resolution open => fixed
2021-02-24 23:39 wmayer Fixed in Version => 0.19
2021-02-24 23:39 wmayer Note Added: 0015432