View Issue Details

IDProjectCategoryView StatusLast Update
0004229FreeCADBugpublic2020-08-26 12:00
Reporterlonaowna Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.19 
Target Version0.19Fixed in Version0.19 
Summary0004229: Compilation fails with PySide2 5.14: PYSIDE2RCCBINARY missing
DescriptionPySide2 5.14 has removed the pyside2-rcc binary. Similar function is now provided by the rcc binary. See upstream patch.

The cMake/FindPySide2Tools.cmake script should be updated to accept the new rcc as replacement for pyside2-rcc. Currently it fails with the following message:

[ 4%] Generating Material_rc.py
/bin/sh: PYSIDE2RCCBINARY-NOTFOUND: command not found
Tagsupstream
FreeCAD Information-- Build type: Release
-- Compiler: /usr/bin/c++ (9.2.0)
-- Flags: -Wall -Wextra -Wno-write-strings -march=x86-64 -mtune=generic -O2 -pipe -fno-plt
-- Python: [/usr/bin/python3] [.cpython-38-x86_64-linux-gnu]
-- PCL: not enabled
-- pybind11: not enabled
-- Boost: 1.71.0
-- XercesC: [/usr/lib/libxerces-c.so] [/usr/include]
-- ZLIB: 1.2.11
-- PyCXX: [/home/sebas/abs/freecad-git/src/freecad-git/src]
-- OCC: 7.4.0 [TKFillet;TKMesh;TKernel;TKG2d;TKG3d;TKMath;TKIGES;TKSTL;TKShHealing;TKXSBase;TKBin;TKBool;TKBO;TKCDF;TKBRep;TKTopAlgo;TKGeomAlgo;TKGeomBase;TKOffset;TKPrim;TKSTEP;TKSTEPBase;TKSTEPAttr;TKHLR;TKFeat]
-- SMESH: build internal
-- MEDFile: [/usr/lib/libmedC.so;/usr/lib/libmed.so] [/usr/include]
-- HDF5: 1.10.5
-- VTK: 8.2.0
-- NETGEN: not enabled
-- SWIG: 4.0.1
-- Eigen3 3.3.7
-- Qt5Core: 5.14.0
-- Qt5Network: 5.14.0
-- Qt5Xml: 5.14.0
-- Qt5XmlPatterns: 5.14.0
-- Qt5Widgets: 5.14.0
-- Qt5PrintSupport: 5.14.0
-- Qt5OpenGL: 5.14.0
-- Qt5Svg: 5.14.0
-- Qt5UiTools: 5.14.0
-- Qt5Concurrent: 5.14.0
-- Qt5WebKitWidgets: 5.212.0
-- Shiboken2: 5.14.0 [/usr/lib64/cmake/Shiboken2-5.14.0] [/usr/include/shiboken2;/usr/include/python3.8]
-- PySide2: 5.14.0 [/usr/include/PySide2]
-- PySide2Tools: not found
-- Freetype: 2.10.1
-- OpenGLU: /usr/lib/libGLU.so [/usr/lib/libGLU.so][/usr/include]
-- Coin3D: [Coin] []
-- SPNAV: [/usr/lib/libspnav.so] [/usr/include]
-- Matplotlib: 3.1.1
-- Rift: not enabled (BUILD_VR)
-- Doxygen: not found

Relationships

related to 0004195 closedwmayer Python 3.8 Compatibility incl. Shiboken/Pyside (was: Unable to use addon manager) 

Activities

howetuft

2019-12-28 16:31

reporter   ~0013949

Last edited: 2019-12-28 16:38

View 4 revisions

I submitted a patch (PR FreeCAD Pull Request 2846), hope it will work...

Kunda1

2020-01-07 17:12

administrator   ~0014011

Once this PR is merged, please test 0004195 as well? Thanks

Kunda1

2020-01-10 20:48

administrator   ~0014038

@lonaowna can u test the fix please?

lonaowna

2020-01-10 21:26

reporter   ~0014042

@Kunda1 everything is working great! Thanks @howetuft

Aurawin

2020-05-19 14:54

reporter   ~0014422

Last edited: 2020-05-19 18:39

View 2 revisions

I've come across this report while trying to build from the latest source. When trying to build I get to

[ 44%] Generating Material_rc.py
/bin/sh: 1: PYSIDE2RCCBINARY-NOTFOUND: not found
make[2]: *** [src/Mod/Material/CMakeFiles/Material.dir/build.make:90: src/Mod/Material/Material_rc.py] Error 127
make[1]: *** [CMakeFiles/Makefile2:3203: src/Mod/Material/CMakeFiles/Material.dir/all] Error 2
make: *** [Makefile:130: all] Error 2

I'm running Ubuntu 20.04

After reading some issues with changes to PySide-tools from Ubuntu 19.10 to 20.04 I decided to compile PySide-tools from the source. I got past this issue by compiling updated pyside-tools and installing, configure and build freecad source.

maiden

2020-07-07 20:59

reporter   ~0014632

Last edited: 2020-07-07 22:06

View 2 revisions

I see the same issue on Ubuntu 20.04

/bin/sh: 1: PYSIDE2RCCBINARY-NOTFOUND: not found
make[2]: *** [src/Mod/Draft/CMakeFiles/Draft.dir/build.make:970: src/Mod/Draft/Draft_rc.py] Error 127
make[2]: *** Waiting for unfinished jobs....

downloading, compiling and installing from source resolved it for me as well.
https://github.com/pyside/pyside2-tools

Kunda1

2020-07-08 00:47

administrator   ~0014634

Marking this as fixed upstream

Related Changesets

FreeCAD: master 17ed2b19

2019-12-24 15:06:18

howetuft


Committer: yorik Details Diff
[Cmake] Update FindPySide2Tools for PySide2 5.14 - issue 0004229

Since PySide2 5.14, 'pyside2-rcc' and 'pyside2-uic' have been renamed into plain 'rcc' and 'uic'.
This leads FindPySide2Tools.cmake to no longer find rcc/uic, as reported in bug 0004229 (https://www.freecadweb.org/tracker/view.php?id=4229) and prevents compilation.
FindPySide2Tools has been updated accordingly.
Affected Issues
0004229
mod - cMake/FindPySide2Tools.cmake Diff File

Issue History

Date Modified Username Field Change
2019-12-19 16:49 lonaowna New Issue
2019-12-28 16:31 howetuft Note Added: 0013949
2019-12-28 16:32 howetuft Note Edited: 0013949 View Revisions
2019-12-28 16:35 howetuft Note Edited: 0013949 View Revisions
2019-12-28 16:38 howetuft Note Edited: 0013949 View Revisions
2020-01-07 17:08 Kunda1 Relationship added related to 0004195
2020-01-07 17:12 Kunda1 Note Added: 0014011
2020-01-07 17:14 Kunda1 Status new => assigned
2020-01-07 17:14 Kunda1 Target Version => 0.19
2020-01-08 14:20 yorik Changeset attached => FreeCAD master 17ed2b19
2020-01-10 20:48 Kunda1 Note Added: 0014038
2020-01-10 21:26 lonaowna Note Added: 0014042
2020-05-19 14:54 Aurawin Note Added: 0014422
2020-05-19 18:39 Aurawin Note Edited: 0014422 View Revisions
2020-07-07 20:59 maiden Note Added: 0014632
2020-07-07 22:06 maiden Note Edited: 0014632 View Revisions
2020-07-08 00:46 Kunda1 Tag Attached: upstream
2020-07-08 00:47 Kunda1 Status assigned => resolved
2020-07-08 00:47 Kunda1 Resolution open => fixed
2020-07-08 00:47 Kunda1 Note Added: 0014634
2020-08-26 12:00 Kunda1 Status resolved => closed
2020-08-26 12:00 Kunda1 Fixed in Version => 0.19