View Issue Details

IDProjectCategoryView StatusLast Update
0004220SketcherBugpublic2021-10-16 17:24
Reporterleoheck Assigned Toabdullah  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
OSUbuntuOS Version19.10 
Target Version0.20Fixed in Version0.20 
Summary0004220: Most of the sketcher shortcuts are not working
DescriptionMost of the shortcuts in Sketcher do not work. Most of the time they overlap other shortcuts. If it is a 2 letter combination like (V, C) the V is interpreted by some tool and I can't make the combo.

Shortcuts are an important feature to accelerate the design process.

For example (there are many others, mostly starting with C)
C - Is used to create coincident constraint
C, M - Is used to toggle the construction line
Steps To ReproduceTry to use the shortcut (C, M) to toggle the construction line
Tagsshortcuts
FreeCAD InformationI am using version 0.19 build

Help > About FreeCAD > "Copy to clipboard" does not work on Ubuntu (since many versions from now). This is the message displayed instead.

FreeCAD help files not found (/usr/share/doc/freecad-daily-doc/freecad.qhc). You might need to install the FreeCAD documentation package.


Relationships

related to 0001756 assignedwmayer FreeCAD Show all currently assigned Keyboard Shortcuts with commands as list 
related to 0003796 confirmedchennes FreeCAD Shortcuts "V1" .. "V7" to change the "Draw-Style" didn't work in sketch view 

Activities

leoheck

2019-12-10 13:03

reporter   ~0013895

I forgot to say that I posted this here some days ago.
https://forum.freecadweb.org/viewtopic.php?f=3&t=41272&p=353010#p353010

Kunda1

2020-01-15 19:17

administrator   ~0014078

Related threads:
https://forum.freecadweb.org/viewtopic.php?f=3&t=33901
https://forum.freecadweb.org/viewtopic.php?f=3&t=33805#p283072

abdullah

2021-10-16 17:24

manager   ~0015991

git commit 0926a4148bcff11249fd4f56bc30256102ffe105

Issue History

Date Modified Username Field Change
2019-12-10 13:02 leoheck New Issue
2019-12-10 13:03 leoheck Note Added: 0013895
2019-12-10 18:19 openBrain Priority high => normal
2020-01-15 19:16 Kunda1 Tag Attached: shortcuts
2020-01-15 19:17 Kunda1 Note Added: 0014078
2020-01-15 19:18 Kunda1 Relationship added related to 0001756
2020-01-15 19:21 Kunda1 Target Version => 0.19
2020-11-09 18:06 abdullah Target Version 0.19 => 0.20
2021-02-06 06:48 abdullah Target Version => 0.20
2021-08-27 13:27 chennes Assigned To => chennes
2021-08-27 13:27 chennes Status new => assigned
2021-08-27 13:36 chennes Relationship added related to 0003796
2021-08-27 13:36 chennes Status assigned => confirmed
2021-10-16 17:23 abdullah Assigned To chennes => abdullah
2021-10-16 17:24 abdullah Status confirmed => closed
2021-10-16 17:24 abdullah Resolution open => fixed
2021-10-16 17:24 abdullah Fixed in Version => 0.20
2021-10-16 17:24 abdullah Note Added: 0015991