View Issue Details

IDProjectCategoryView StatusLast Update
0004209FreeCADBugpublic2020-06-14 15:53
Reporterchrisb Assigned Toabdullah  
PrioritynormalSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
Product Version0.19 
Target Version0.19Fixed in Version0.19 
Summary0004209: Crash of FreeCAD 0.19 on undo
DescriptionWith a certain sketch deleting of geometric elements cannot be undone.
See forum discussion.
Tagsundo
FreeCAD InformationOS: macOS High Sierra (10.13)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.18811 (Git)
Build type: Release
Branch: master
Hash: b809867021deb37be1039dab37b9fe1cafab254e
Python version: 3.7.3
Qt version: 5.12.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/Germany (en_DE)

Activities

Feuermurmel

2020-05-04 07:28

reporter   ~0014401

Last edited: 2020-05-04 07:31

View 3 revisions

Hi! I just ran in to this myself on FreeCAD 0.19.20900 on macOS 10.13. I see that Reproducibility is set to sometimes. Do you need a reproducer for this? I have found that creating a single slot in an empty sketch, deleting one of the four lines, and hitting command-z leads to a crash ("FreeCAD quit unexpectedly") every time. The sketch with the slot already created can also be loaded from a document instead.

I can provide e.g. a screen recording, document files, or more detailed description if this would be of help.

abdullah

2020-06-06 17:52

manager   ~0014488

@Feuermurmel

I am now with:
OS: Ubuntu 18.04.4 LTS (MATE/mate)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.21505 (Git)
Build type: Debug
Branch: master
Hash: 9801519409c992fb964490abdefc35ae79e0b473
Python version: 3.6.9
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.4.1.dev

I have tried to reproduce this with the version above. In the meantime there have some fixes relating to undo. Could you please check if you can reproduce your issue with a current build?

Feuermurmel

2020-06-06 21:19

reporter   ~0014489

@abdullah I can still reproduce this with the newest version available at https://github.com/FreeCAD/FreeCAD/releases

OS: macOS High Sierra (10.13)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.21329 (Git)
Build type: Release
Branch: master
Hash: 2330eef823b32ac412d839031cc174353a76b013
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)

abdullah

2020-06-13 15:36

manager   ~0014532

Notes:
To reproduce select this geometry and constraints (I generally select first the tangency constraint and then the geometry):
https://forum.freecadweb.org/viewtopic.php?f=3&t=41326&start=20#p407935

A possible fix in here:
https://github.com/FreeCAD/FreeCAD/pull/3610
(subject to review and approval by Wmayer due to the impact in App::Document and DocumentObject).

Issue History

Date Modified Username Field Change
2019-12-01 00:03 chrisb New Issue
2020-01-10 20:54 Kunda1 Status new => confirmed
2020-01-10 20:54 Kunda1 Target Version => 0.19
2020-02-20 21:05 Kunda1 Tag Attached: undo
2020-05-04 07:28 Feuermurmel Note Added: 0014401
2020-05-04 07:29 Feuermurmel Note Edited: 0014401 View Revisions
2020-05-04 07:31 Feuermurmel Note Edited: 0014401 View Revisions
2020-06-06 17:52 abdullah Note Added: 0014488
2020-06-06 21:19 Feuermurmel Note Added: 0014489
2020-06-13 15:36 abdullah Note Added: 0014532
2020-06-13 15:36 abdullah Assigned To => abdullah
2020-06-13 15:36 abdullah Status confirmed => assigned
2020-06-14 15:53 wmayer Status assigned => closed
2020-06-14 15:53 wmayer Resolution open => fixed
2020-06-14 15:53 wmayer Fixed in Version => 0.19