View Issue Details

IDProjectCategoryView StatusLast Update
0004123FreeCADBugpublic2020-09-19 16:53
Reporterjbrant Assigned Tochrisb  
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version0.18 
Summary0004123: MacOS "Datum (whatever dimension) mm for the constraint with index (whatever constraint) is invalid."
DescriptionOS: macOS 10.14
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16117 (Git)
Build type: Release
Branch: (HEAD detached at 0.18.2)
Hash: dbb4cc6415bac848a294f03b80f65e888d531742
Python version: 3.6.7
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)

I found a problem that had been reportedly fixed in this issue ID: 0002167

I may have more information. This is in regards to the error message:

"Datum (whatever dimension) mm for the constraint with index (whatever constraint) is invalid."

This makes the horizontal and vertical "distance" constraints unusable.
Steps To ReproduceI'm new to this application and I am following a tutorial found here:
https://www.youtube.com/watch?v=_HEvhclR4-o&list=PL6fZ68Cq3L8k0JhxnIVjZQN26cn9idJrj

He has us set up a new sketch and then draw a box and add symmetry constraints in Sketcher workbench. Once done, he has us click a side and apply either horizontal or vertical distance of 200mm. If done in this order - the distance tools are not usable and teh error message "Datum (whatever dimension) mm for the constraint with index (whatever constraint) is invalid." is given.

HOWEVER - if you apply the distance BEFORE applying symmetry constraints then the distance tools work fine.
Additional InformationIf I can help or provide more info or screen recordings - happy to do so. Thanks for a great piece of software!
Tags#pending-forum
FreeCAD Information

Relationships

related to 0002167 closedabdullah Datum 10.5295 mm for the constraint with index 8 is invalid 

Activities

Kunda1

2019-09-11 21:23

administrator   ~0013581

Thanks for you report. Can you please (per our guidelines) post to the forum to make sure this is not fixed in 0.19 (per our guidelines in the large banner above) thank you. Please report the forum link back to this ticket and post this ticket to said forum thread.

Max_B

2020-07-12 12:21

reporter   ~0014644

Last edited: 2020-07-12 12:23

View 2 revisions

Hi,
Just signed in to report that this bug is still showing up on 0.19 for MacOS (10.15). On some rare situation it works, most of the time, it fails with the message reported by the OP.
A workaround is to click the formula button and enter the constant in the formula field. Then it is correctly set.

Formula based on spreadsheet works as expected too.

Kunda1

2020-08-26 10:41

administrator   ~0014714

@Max_B please post your full About information.
Note: OP didn't create a forum thread as we requested. I will open one and x-link to this ticket.

Kunda1

2020-08-26 10:50

administrator   ~0014715

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=49765

Max_B

2020-08-26 10:52

reporter   ~0014716

OS: macOS 10.15
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.21857 (Git)
Build type: Release
Branch: master
Hash: 750c169a6cb999f084915494f2fbec7c07297aae
Python version: 3.8.2
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)

Must add that the reported problem showed up when I reopened an old file from free cad 0.17 and after while, when the project was somehow cleaned to run under 0.19, the issue occurs very rarely. I'm not sure of the condition to reproduce.

Kunda1

2020-08-26 11:47

administrator   ~0014717

@Max_B can you attach said file?
BTW, the most up to date version of FC on MacOS is 22284 (please update and test again)

Max_B

2020-08-26 16:06

reporter   ~0014721

The file is here : http://ac-mb.info/perso/turbine%202020.FCStd
I'm not 100% sure of the constraints that were refusing to work, but I think that's the 3 in the sketch 032 (poket12 of corp in part injecteur).
Now you'll find that those constraints are somehow referencing other constraint in the same sketch that I can't find.

For the record, to circumvent the refusal of a constant value, I had to click the formula button and set it there.
It seems that now, one can nil the formula and enter a value.

Max_B

2020-08-26 16:07

reporter   ~0014722

I updated to last Mac version but did not reproduce the issue yet.

OS: macOS 10.15
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.22284 (Git)
Build type: Release
Branch: master
Hash: bf1e8e48389f5e9e25bd77b67fe98da4213e797c
Python version: 3.8.5
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)

Kunda1

2020-08-26 18:23

administrator   ~0014723

do you mind discussing this issue in the dedicated forum thread from here on out?

chrisb

2020-09-19 16:53

developer   ~0014762

Not reproducible in 0.19 with the given information.

Issue History

Date Modified Username Field Change
2019-09-11 18:33 jbrant New Issue
2019-09-11 21:21 Kunda1 Description Updated View Revisions
2019-09-11 21:21 Kunda1 Relationship added related to 0002167
2019-09-11 21:23 Kunda1 Status new => feedback
2019-09-11 21:23 Kunda1 Note Added: 0013581
2019-09-11 21:23 Kunda1 Tag Attached: #post-to-forum
2019-09-11 21:26 Kunda1 Summary MAC "Datum (whatever dimension) mm for the constraint with index (whatever constraint) is invalid." => MacOS "Datum (whatever dimension) mm for the constraint with index (whatever constraint) is invalid."
2020-07-12 12:21 Max_B Note Added: 0014644
2020-07-12 12:23 Max_B Note Edited: 0014644 View Revisions
2020-08-26 10:41 Kunda1 Note Added: 0014714
2020-08-26 10:50 Kunda1 Tag Detached: #post-to-forum
2020-08-26 10:50 Kunda1 Note Added: 0014715
2020-08-26 10:50 Kunda1 Tag Attached: #pending-forum
2020-08-26 10:52 Max_B Note Added: 0014716
2020-08-26 11:47 Kunda1 Note Added: 0014717
2020-08-26 16:06 Max_B Note Added: 0014721
2020-08-26 16:07 Max_B Note Added: 0014722
2020-08-26 18:23 Kunda1 Note Added: 0014723
2020-09-19 16:53 chrisb Assigned To => chrisb
2020-09-19 16:53 chrisb Status feedback => closed
2020-09-19 16:53 chrisb Resolution open => unable to reproduce
2020-09-19 16:53 chrisb Note Added: 0014762