View Issue Details

IDProjectCategoryView StatusLast Update
0000412FreeCADBugpublic2011-08-03 05:00
Reporterunauthenticated Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version0.11 
Fixed in Version0.12 
Summary0000412: special characters in annotation corrupt file
DescriptionWhen you use a special character (in my case the German umlauts Ä Ö Ü, hope you can see those) in an Annotation the are displayed perfect. However when you save and reopen the file appear incomplete or an exception occurs.
Additional InformationTo reproduce:
1) Start with a blank file.
2) Create an annotation with label text [Munich]
3) Save file and reopen => no problem.
4) Alter label text to [München]
5) Save file and reopen => project tree appears empty

TagsNo tags attached.
FreeCAD Information

Activities

2011-08-02 05:21

 

test_ÄÖÜ.FCStd (Attachment missing)

wmayer

2011-08-02 06:20

administrator   ~0000970

When trying to load the above file FreeCAD even crashes and also when I try to write "München" the 'ü' is missing because the OpenInventor library doesn't support this. With which version of FreeCAD and under what platform did you create the file?

wmayer

2011-08-02 09:31

administrator   ~0000971

This bug has been fixed in 0.12 for a couple of weeks. The problem there was the wrong encoding (ISO 8859-1) was used to write out XML data. When reading in it was assumed that everything is in UTF-8 but due to the wrong encoding some forbidden characters has been written out.

wmayer

2011-08-03 05:00

administrator   ~0000972

Fixed sometime in an earlier revision.

Issue History

Date Modified Username Field Change
2011-08-02 05:21 unauthenticated New Issue
2011-08-02 05:21 unauthenticated File Added: test_ÄÖÜ.FCStd
2011-08-02 06:20 wmayer Note Added: 0000970
2011-08-02 09:31 wmayer Note Added: 0000971
2011-08-03 05:00 wmayer Note Added: 0000972
2011-08-03 05:00 wmayer Status new => closed
2011-08-03 05:00 wmayer Resolution open => no change required
2011-08-03 05:00 wmayer Fixed in Version => 0.12