View Issue Details

IDProjectCategoryView StatusLast Update
0004106PartDesignBugpublic2020-03-21 13:32
Reporterjruiz Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Fixed in Version0.19 
Summary0004106: Impossible to assign reference values to Yaw, Pitch and Roll angles.
DescriptionWhen creating datum line, after selecting any reference, the fields Yaw, Pitch and Roll of Attachment offsets, lack of the small button for assigning them reference values.
Steps To Reproduce
  • Create a body.
  • Press Datum line button
  • Select any reference.
The fields Yaw, Pitch and Roll appears without the reference little button.
Tags#post-to-forum
FreeCAD Information

Relationships

child of 0003981 new Expressions Add Expression support to certain fields 

Activities

openBrain

2019-09-01 09:29

developer   ~0013503

@jruiz : Guess you talk about expressions (instead of reference)...

Kunda1

2019-09-10 20:40

administrator   ~0013568

@openBrain where should this ticket go ?
@jruiz please open a forum thread to discuss this. x-post this ticket there and x-post the thread URL back here so we can track it. Also please familiarize yourself with out Tracker Guidelines (yellow banner at the top of this page)

openBrain

2019-09-11 09:21

developer   ~0013572

Last edited: 2019-09-16 08:40

View 2 revisions

@Kunda1 : actually I'm a bit hesitating. Yaw/Pitch/Roll (YPR) was originally listed in the forum thread going with 0003981 that I set as dup. But they have been removed because DeepSOIC (truly) stated that they are a big beast because they don't match any exposed property. So if YPR support expressions, user may first use them, then bind other (conflicting) expressions in the Angle+Axis properties in the Property Editor.
This is also probably an issue by itself that expressions entered in the YPR aren't visible in the Property Editor.
Maybe what could be fair would be to replace the dup of this ticket with a "related" link (as there is no real overlap), and take time to carefully think what to do here.

Kunda1

2019-09-12 16:20

administrator   ~0013584

@openBrain thank you for the comprehensive answer. I think this merits a forum thread for further discussion on how to move forward. Do you mind doing that? ;)

openBrain

2019-09-13 11:53

developer   ~0013591

@Kunda1 I need to clarify something on the original discussion then I'll do accordingly. ;)

openBrain

2019-09-16 08:41

developer   ~0013606

@Kunda1 : My understanding of the problem was actually a bit erroneous. I corrected my note above. Do you think a thread is still needed ?

Zolko

2020-01-28 07:58

reporter   ~0014123

Last edited: 2020-01-28 11:21

View 2 revisions

This is because there are actually 2 dialogs to edit attachments of objects:

- one is src/Mod/Part/Gui/TaskAttacher.ui and this has the ExpressionEngine f(x) icon. This is the one coming with the Part WB
- the other is src/Mod/Part/AttachmentEditor/TaskAttachmentEditor.ui and this one has not. This comes with the PartDesign WB

visually they're identical, and functionally they're similar but slightly different. This is actually the exact same problem as issue 0004258, because these confusions can cause crashes in some circumstances.


EDIT: when a datum is created then src/Mod/Part/AttachmentEditor/TaskAttachmentEditor.ui is called, therefore the AttachmentOffset fields don't have the f(x) buttons. When the datum has been created and later its Attachment property is edited from the property panel (clicking on the tiny button in the MapMode field) then src/Mod/Part/Gui/TaskAttacher.ui is called and this one does have the f(x) buttons.

uwestoehr

2020-03-21 02:45

developer   ~0014254

I opened a forum thread for this: https://forum.freecadweb.org/viewtopic.php?f=10&t=44377

wmayer

2020-03-21 13:32

administrator   ~0014256

https://github.com/FreeCAD/FreeCAD/commit/1cfe6d2cc7c3ccf9bce77bf776898547996195b7

Issue History

Date Modified Username Field Change
2019-09-01 01:13 jruiz New Issue
2019-09-01 01:22 jruiz Tag Attached: Datum Line; Yaw; Pitch; Roll; Referenced value
2019-09-01 09:29 openBrain Note Added: 0013503
2019-09-01 09:32 openBrain Relationship added duplicate of 0003981
2019-09-10 20:38 Kunda1 Tag Detached: Datum Line; Yaw; Pitch; Roll; Referenced value
2019-09-10 20:40 Kunda1 Status new => feedback
2019-09-10 20:40 Kunda1 Note Added: 0013568
2019-09-10 20:40 Kunda1 Tag Attached: #post-to-forum
2019-09-11 09:21 openBrain Note Added: 0013572
2019-09-12 16:20 Kunda1 Note Added: 0013584
2019-09-13 11:53 openBrain Note Added: 0013591
2019-09-16 08:40 openBrain Note Edited: 0013572 View Revisions
2019-09-16 08:41 openBrain Note Added: 0013606
2020-01-09 19:06 Kunda1 Relationship replaced child of 0003981
2020-01-28 07:58 Zolko Note Added: 0014123
2020-01-28 11:21 Zolko Note Edited: 0014123 View Revisions
2020-03-21 02:45 uwestoehr Note Added: 0014254
2020-03-21 13:32 wmayer Assigned To => wmayer
2020-03-21 13:32 wmayer Status feedback => closed
2020-03-21 13:32 wmayer Resolution open => fixed
2020-03-21 13:32 wmayer Fixed in Version => 0.19
2020-03-21 13:32 wmayer Note Added: 0014256