View Issue Details

IDProjectCategoryView StatusLast Update
0004087SketcherBugpublic2020-03-07 03:33
Reporterpaullee Assigned Toabdullah  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSFedora 
Product Version0.19 
Target Version0.19Fixed in Version0.19 
Summary0004087: [Crash FC & Function Bug] - Part:FeatureGeometrySet
DescriptionFC Discussion -
[ Crash FC ]

[ Geometry Extension Set Information Not save in file ]


Steps To ReproduceRepeating Forum discussion:-
[ Crash FC ]
  1. Make a Sketch, draw a rectangle e.g.
  2. run below code
  3. FC CRASH :(

>>> sg0=s.Geometry[0]
>>> sg0.setExtension(Part.GeometryStringExtension("300","width"))
>>> sg0.getExtensions()
[<GeometryStringExtension ('width', 300) >]
>> sg0.setExtension(Part.GeometryStringExtension("2800","height"))
>>> sg0.getExtensions()
[<GeometryStringExtension ('width', 300) >, <GeometryStringExtension ('height', 2800) >]

>>> sg0.setExtension(Part.GeometryStringExtension("200","width"))
CRASH

[ Geometry Extension Set Information Not save in file ]

  1. Created the Sketch in post above, and set all the extension and save the file before crash
  2. Close and re-open the file
  3. Run getExentions(), but all information set is not found ?

TagsGeometry Extension Set
FreeCAD Information

Activities

paullee

2019-08-10 08:28

developer  

paullee

2019-10-06 14:40

developer   ~0013716

Last edited: 2019-10-06 14:41

View 2 revisions

@abdullah is so kind to implement this. He have not appeared since 21.7, hope he is fine. Noting @wmayer merge the GeometryExtension, trying to assign this bug to wmayer, to avoid this being forgotten or to figure out if this worthwhile to pursue or not. Not sure this is correct move, please advise otherwise.

Thanks.

abdullah

2020-03-06 16:24

manager   ~0014212

https://github.com/FreeCAD/FreeCAD/commit/b748cc688495500786f5f3a239bf0379916c915f

Kunda1

2020-03-06 17:30

administrator   ~0014213

FreeCAD master b748cc68

abdullah

2020-03-07 03:33

manager   ~0014215

Fix committed to master branch.

Related Changesets

FreeCAD: master b748cc68

2020-03-06 15:47:42

abdullah


Committer: abdullahtahiriyo Details Diff
Part: GeometryExtensions

========================

fixes 0004087

Missing "break" in loop after finding the extension was causing segfault because of null pointer access, as the unique pointer had been std:move-d when found and was thus no longer valid.
Affected Issues
0004087
mod - src/Mod/Part/App/Geometry.cpp Diff File

Issue History

Date Modified Username Field Change
2019-08-10 08:28 paullee New Issue
2019-08-10 08:28 paullee Tag Attached: Geometry Extension Set
2019-08-10 08:28 paullee File Added: Test_ GeometryExtension_ Sketcher_ 1.fcstd
2019-10-06 14:40 paullee Note Added: 0013716
2019-10-06 14:41 paullee Note Edited: 0013716 View Revisions
2019-10-06 14:41 paullee Assigned To => wmayer
2019-10-06 14:41 paullee Status new => assigned
2020-03-05 18:30 paullee Assigned To wmayer => abdullah
2020-03-06 16:24 abdullah Note Added: 0014212
2020-03-06 16:24 abdullah Status assigned => closed
2020-03-06 16:24 abdullah Resolution open => fixed
2020-03-06 16:24 abdullah Fixed in Version => 0.19
2020-03-06 17:30 Kunda1 Note Added: 0014213
2020-03-07 03:33 abdullah Changeset attached => FreeCAD master b748cc68
2020-03-07 03:33 abdullah Note Added: 0014215