View Issue Details

IDProjectCategoryView StatusLast Update
0004082TechDrawBugpublic2020-06-26 17:12
Reporterwandererfan Assigned Towandererfan  
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionnot fixable 
Product Version0.19 
Target Version0.19 
Summary0004082: TD Fails to Display Section of Assembly
DescriptionForum Discussion

TD displays incorrect results and error messages when trying to make Section view of Assembly file from A2Plus(?).

The assembly pieces are combined into a Compound before Section and Projection processing. The Compound is invalid (Part.CheckGeometry) due to many self intersection errors. The individual pieces pass CheckGeometry.
Additional InformationAssembly file is attached. Original FCStd files for pieces have been requested.
TagsNo tags attached.
FreeCAD Information

Activities

wandererfan

2019-08-08 12:35

manager  

wandererfan

2019-08-08 12:38

manager   ~0013403

Still would like the original files for the assembly pieces.

wandererfan

2019-08-08 12:39

manager   ~0013404

Could a mod please change Project to TechDraw? Thanks.

wandererfan

2019-10-29 17:42

manager   ~0013794

Component "Nut" in the example file has multiple geometric problems when projected or when used in Boolean ops.

I can't tell if the problems are introduced in the assembly process or are there from the original file.

If "nut" is removed from the assembly the section operation works much better, but there is still a problem with the "Spindle" component.

Kunda1

2019-12-29 13:59

administrator   ~0013954

Changing status of ticket from feedback to assigned

wandererfan

2019-12-29 15:33

manager   ~0013957

"Changing status of ticket from feedback to assigned "

Why? Still waiting for feedback. Can't tell what's wrong with the input without the original files from before import to A2+.

wandererfan

2020-06-21 12:58

manager   ~0014578

This is caused by geometry errors in the assembly. See forum discussion here.

wandererfan

2020-06-21 12:59

manager   ~0014579

Not fixable in TechDraw.

Kunda1

2020-06-26 17:12

administrator   ~0014591

Closing ticket

Issue History

Date Modified Username Field Change
2019-08-08 12:35 wandererfan New Issue
2019-08-08 12:35 wandererfan Status new => assigned
2019-08-08 12:35 wandererfan Assigned To => wandererfan
2019-08-08 12:35 wandererfan File Added: screwjack_assmbly_sectionViewCrash.FCStd
2019-08-08 12:38 wandererfan Status assigned => feedback
2019-08-08 12:38 wandererfan Note Added: 0013403
2019-08-08 12:39 wandererfan Note Added: 0013404
2019-08-08 12:51 chrisb Project FreeCAD => TechDraw
2019-10-29 17:42 wandererfan Note Added: 0013794
2019-12-29 13:59 Kunda1 Status feedback => assigned
2019-12-29 13:59 Kunda1 Note Added: 0013954
2019-12-29 15:33 wandererfan Note Added: 0013957
2020-06-21 12:58 wandererfan Note Added: 0014578
2020-06-21 12:59 wandererfan Status assigned => resolved
2020-06-21 12:59 wandererfan Resolution open => not fixable
2020-06-21 12:59 wandererfan Note Added: 0014579
2020-06-26 17:12 Kunda1 Status resolved => closed
2020-06-26 17:12 Kunda1 Note Added: 0014591