View Issue Details

IDProjectCategoryView StatusLast Update
0004035PathBugpublic2020-10-16 16:47
Reporterfreman Assigned Tosliptonic  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.19 
Summary0004035: path pocket crashing on illegal memory access.
DescriptionPocket path tool crashes on this example file.

The key seems to be an illegal memory access.

Program received signal SIGSEGV, Segmentation fault.

.. following several trapped exceptions which produce out like:

PathPocketShape.ERROR: extendWire(): (ePts[0] - endPts[0]).Length
PathPocketShape.ERROR: list index out of range

Russ tested on windows and gets similar output but it seems that Windows is more tolerant of illegal memory access and does not crash.

https://forum.freecadweb.org/viewtopic.php?f=15&t=37259&p=316881#p316610

The model file provided here is slightly changed from the one initially posted there. The bounding block is now correct and 6 holes in previous model were accidentally made as construction circles not real holes. Neither of these factors affect the bug.
Steps To Reproduceopen attached file
select upper face ( Model-body.Face14 )
select pocket path tool by icon
CRASH !

If pocket op is started with no selection , it seems that the out of range errors still happen but a path is created and there is not crash.

In other contexts where I have seen problems, defining the base geometry from the dialogue seems to avoid some issues. This difference probably should be looked into.
Additional InformationOS: Linux (LXDE/LXDE)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.17119 (Git)
Build type: Release
Branch: master
Hash: e72b48e0cfcf4773e4b6527c74f2bac11ccff1ab
Python version: 2.7.15
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedKingdom (en_GB)
Tags#pending, #pending-forum
FreeCAD Information

Activities

freman

2019-06-25 18:10

reporter  

housing-crisis.FCStd (38,261 bytes)

openBrain

2019-06-25 18:49

developer   ~0013308

@freman : could you please carefully select the project linked to a ticket when you enter one ? In this case I guess it's Path.
@Kunda1 : can't change this. ;)

freman

2019-06-25 20:12

reporter   ~0013310

sorry, I thought Path was part of FreeCAD, not a separate project.

Kunda1

2020-10-14 12:35

administrator   ~0014847

Sorry for delay just moved this ticket to Path category.
CC @sliptonic

Kunda1

2020-10-14 12:36

administrator   ~0014848

Confirmed by Russ on the forum thread

Kunda1

2020-10-15 15:53

administrator   ~0014865

@freman care to re-attach .FCStd file? It's corrupted for some reason

freman

2020-10-16 08:49

reporter   ~0014885

Sorry France is descending to 3rd world levels of network connectivity and I have to sit on someone's doorstep to get email access. I'll try to remember to check this whenever I get proper connectivity back on the work machine. Not expecting that in the near future sadly. Ping me in a month if I forget.

sliptonic

2020-10-16 16:47

manager   ~0014889

I don't see where Russ confirmed. He said he made a path _without_ error. GeneFC also can't reproduce. I've also tried and it works fine.
Closing the issue. Will reopen if additional steps can be provided to duplicate the problem

Issue History

Date Modified Username Field Change
2019-06-25 18:10 freman New Issue
2019-06-25 18:10 freman File Added: housing-crisis.FCStd
2019-06-25 18:49 openBrain Note Added: 0013308
2019-06-25 20:12 freman Note Added: 0013310
2020-10-14 12:34 Kunda1 Project FreeCAD => Path
2020-10-14 12:35 Kunda1 Note Added: 0014847
2020-10-14 12:36 Kunda1 Status new => confirmed
2020-10-14 12:36 Kunda1 Note Added: 0014848
2020-10-14 12:38 Kunda1 Tag Attached: #pending
2020-10-14 12:38 Kunda1 Tag Attached: #pending-forum
2020-10-15 15:53 Kunda1 Note Added: 0014865
2020-10-16 08:49 freman Note Added: 0014885
2020-10-16 16:47 sliptonic Assigned To => sliptonic
2020-10-16 16:47 sliptonic Status confirmed => closed
2020-10-16 16:47 sliptonic Resolution open => fixed
2020-10-16 16:47 sliptonic Note Added: 0014889