View Issue Details

IDProjectCategoryView StatusLast Update
0003970PartDesignBugpublic2021-02-27 13:25
Reporterbzb.dev001 Assigned Tochennes  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.18 
Target Version0.20Fixed in Version0.20 
Summary0003970: crash when adding chamfer to an additive primitive
DescriptionAfter creating an additive primitive and adding a fillet to the top face of the primitive, adding a chamfer to the edges to the primitive causes freecad to crash

OS: Ubuntu 18.04.2 bionic
Freecad: FreeCAD_0.18-16110-Linux-Conda_Py3Qt5_glibc2.12-x86_64

Steps To ReproduceOS: Ubuntu 18.04.2 bionic
Freecad: FreeCAD_0.18-16110-Linux-Conda_Py3Qt5_glibc2.12-x86_64

create new document
select 'part design workbench'
create body
click 'additive primitive' button
   adjust draft angle
   select 'neutral plane' for bottom face
   select 'pull direction'
select top face
click 'make fillet' button
select all 4 edges that connects the top face to the bottom
click 'chamfer' button
freecad crashes

Additional InformationI have included a simple test file containing the primitive in question. All you need to do is highlight the 4 edges connecting the top face to the bottom and click on the chamfer button and freecad would crash.
TagsChamfer, crash, fillet, OCC Bug, upstream
FreeCAD Information

Relationships

duplicate of 0004543 resolvedchennes FreeCAD FreeCAD crashes when OCC fails with fillets and chamfers 

Activities

bzb.dev001

2019-05-14 06:29

reporter  

test.FCStd (Attachment missing)

bzb.dev001

2019-05-14 06:32

reporter   ~0013108

OS: Ubuntu 18.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16110 (Git) AppImage
Build type: Release
Branch: (HEAD detached at 0.18.1)
Hash: f7dccfaa909e5b9da26bf50c4a22ccca9bb10c40
Python version: 3.6.7
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/Canada (en_CA)

Kunda1

2019-05-14 16:01

administrator   ~0013109

Thanks @bzb.dev001 for the report. In future please post bugs to the forum first. Many times there is no necessity to open a ticket because the devs solve the issue pretty swiftly. That is why we ask people in the large banner at the top of this page to do that. Nevertheless, can you recreate this issue on 0.19_pre version ? (it can live in parallel with 0.18 on the same machine)

bzb.dev001

2019-05-14 16:38

reporter   ~0013110

Issue persists in latest compile of freecad.
Freecad used is...
OS: Ubuntu 18.04.2 LTS (LXDE/Lubuntu)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.16718 (Git) AppImage
Build type: Release
Branch: master
Hash: cfd04ac6afa091f5c4f18e94756bd58fb6d66806
Python version: 3.7.1
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/Canada (en_CA)

Kunda1

2019-05-15 17:45

administrator   ~0013113

Started discussion thread at https://forum.freecadweb.org/viewtopic.php?f=8&t=36408

chennes

2021-02-04 05:14

developer   ~0015257

In my testing, this is resolved by the fix discussed in 0004543.

Kunda1

2021-02-27 13:25

administrator   ~0015446

@chennes has created a downstream patch that fixes the crash. It is slowly being integrated in to downstream packages (ATM libpack is the only one but more will follow). This issue is therefore being marked as resolved. It will be closed one all packages are patched or when (if) upstream merges.

Issue History

Date Modified Username Field Change
2019-05-14 06:29 bzb.dev001 New Issue
2019-05-14 06:29 bzb.dev001 File Added: test.FCStd
2019-05-14 06:32 bzb.dev001 Note Added: 0013108
2019-05-14 16:01 Kunda1 Status new => feedback
2019-05-14 16:01 Kunda1 Note Added: 0013109
2019-05-14 16:38 bzb.dev001 Note Added: 0013110
2019-05-14 16:38 bzb.dev001 Status feedback => new
2019-05-15 17:45 Kunda1 Note Added: 0013113
2020-10-11 11:59 Kunda1 Tag Attached: #pending-forum
2021-02-03 16:53 Kunda1 Tag Attached: fillet
2021-02-03 16:53 Kunda1 Tag Attached: crash
2021-02-03 16:53 Kunda1 Tag Attached: OCC Bug
2021-02-03 16:53 Kunda1 Tag Attached: upstream
2021-02-03 16:53 Kunda1 Tag Attached: Chamfer
2021-02-04 05:14 chennes Note Added: 0015257
2021-02-06 06:43 abdullah Target Version => 0.20
2021-02-27 13:24 Kunda1 Tag Detached: #pending-forum
2021-02-27 13:25 Kunda1 Assigned To => chennes
2021-02-27 13:25 Kunda1 Status new => resolved
2021-02-27 13:25 Kunda1 Resolution open => fixed
2021-02-27 13:25 Kunda1 Fixed in Version => 0.20
2021-02-27 13:25 Kunda1 Note Added: 0015446
2021-02-27 13:25 Kunda1 Relationship added duplicate of 0004543