View Issue Details

IDProjectCategoryView StatusLast Update
0003967PartDesignBugpublic2020-10-23 02:50
Reporteruwestoehr Assigned Touwestoehr  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target Version0.19Fixed in Version0.19 
Summary0003967: Datum plane yaw setting is ignored
DescriptionThe datum plane yaw setting is ignored if the pitch angle is >= 90°.

Attached is a simple FC file. It contains 2 datum planes.
- edit plane 2 and set its yaw angle to -10°

result: In the preview it looks perfect - both planes are parallel
But when I click OK to finish the editing, the plane yaw angle is reset to 0°, so the change was in fact ignored.

- now set the yaw to -10° and pitch to 89°

result: this works

- now set the yaw to -10° and pitch to 91°

result: you end up with pitch set to 89° and yaw 180°

So in fact the angle setting for datum planes seems to be broken.
Additional Informationhttps://forum.freecadweb.org/viewtopic.php?f=3&t=36321

Confirmed by @DeepSOIC

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16110 (Git)
Build type: Release
Branch: (HEAD detached at upstream/releases/FreeCAD-0-18)
Hash: f7dccfaa909e5b9da26bf50c4a22ccca9bb10c40
Python version: 3.6.6
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Germany (de_DE)
TagsPart Design
FreeCAD Information

Activities

uwestoehr

2019-05-12 21:36

developer  

Datum-Plane-Bug.FCStd (8,503 bytes)

uwestoehr

2019-09-16 11:58

developer   ~0013607

With FC 0.19.18234 it is not better:

- take the initially attached FC file
- edit plane 2 and set its yaw angle subsequently (keeping the task dialog open) to -1, -2, -3 and -4°

result: In the preview it looks as if both planes are parallel. But this is wrong because one needs -10° to have both planes parallel

- nevertheless, keep the -4° and click OK to close the task dialog
- open the task dialog for plane2 again

result: you see that the yaw is 0°

- nevertheless to have some fun, set the yaw again to -1, -2 down to -10°

result: you see that the plane is jumping wildly around, for example when going from -7 to -8° or -10 to -11°

--
OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.18234 (Git)
Build type: Release
Branch: master
Hash: 3af5d97e9b2a60823815f662aba25422c4bc45bb
Python version: 3.6.8
Qt version: 5.12.1
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: German/Germany (de_DE)

uwestoehr

2020-10-23 00:36

developer   ~0014938

I can no longer reproduce the issue with

OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.22831 (Git)
Build type: Release
Branch: master
Hash: fc89f4eb0c2c6295a1bc02a5cd3db0a22547fc22
Python version: 3.6.8
Qt version: 5.12.6
Coin version: 4.0.0a
OCC version: 7.4.0.beta
Locale: German/Germany (de_DE)

uwestoehr

2020-10-23 00:37

developer   ~0014939

I can no longer reproduce the issue with

OS: Windows 10 (10.0)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.22831 (Git)
Build type: Release
Branch: master
Hash: fc89f4eb0c2c6295a1bc02a5cd3db0a22547fc22
Python version: 3.6.8
Qt version: 5.12.6
Coin version: 4.0.0a
OCC version: 7.4.0.beta
Locale: German/Germany (de_DE)

Kunda1

2020-10-23 02:50

administrator   ~0014940

Closing ticket

Issue History

Date Modified Username Field Change
2019-05-12 21:36 uwestoehr New Issue
2019-05-12 21:36 uwestoehr Tag Attached: Part Design
2019-05-12 21:36 uwestoehr File Added: Datum-Plane-Bug.FCStd
2019-05-13 00:17 uwestoehr Description Updated View Revisions
2019-05-13 16:44 Kunda1 Status new => confirmed
2019-05-13 16:44 Kunda1 Target Version => 0.19
2019-06-17 10:07 uwestoehr Additional Information Updated View Revisions
2019-06-17 10:08 uwestoehr Additional Information Updated View Revisions
2019-09-16 11:58 uwestoehr Note Added: 0013607
2020-10-23 00:36 uwestoehr Note Added: 0014938
2020-10-23 00:37 uwestoehr Assigned To => uwestoehr
2020-10-23 00:37 uwestoehr Status confirmed => resolved
2020-10-23 00:37 uwestoehr Resolution open => fixed
2020-10-23 00:37 uwestoehr Fixed in Version => 0.19
2020-10-23 00:37 uwestoehr Note Added: 0014939
2020-10-23 02:50 Kunda1 Status resolved => closed
2020-10-23 02:50 Kunda1 Note Added: 0014940