View Issue Details

IDProjectCategoryView StatusLast Update
0003963FreeCADBugpublic2020-04-09 17:47
ReporteropenBrain Assigned ToopenBrain  
PrioritynormalSeveritymajorReproducibilityalways
Status assignedResolutionreopened 
Product Version0.18 
Target Version0.19 
Summary0003963: Only alpha comma key can be used as decimal separator
DescriptionOn some values in the Property editor panel, only the alpha comma key is accepted as decimal separator.
This is suboptimal (mainly compared to num dot key) when entering numbers
OS: Linux Mint 19.1
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.16093 (Git)
Build type: Release
Branch: releases/FreeCAD-0-18
Hash: 690774c0effe4fd7b8d2b5e2fb2b8c8d145e21ce
Python version: 2.7.15rc1
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/France (fr_FR)
Steps To ReproduceEdit a value directly in the property editing panel.
Some will indifferently accept comma or dot (alpha comma, alpha dot, num dot) - eg Placement Angle - and some will enforce user to use alpha comma - eg Placement x Axis -.
Additional InformationLinked forum thread

AFAIK, no FC forumer natively using dot sign as decimal separator (eg en_US) has confirmed or not the bug. Only users using comma as decimal separator did.
Proposed fix in the forum discussion :
  • Numpad dot key is always accepted as decimal separator
  • User options to enforce FC to specifically accept alpha dot and/or alpha comma as decimal separator
Tags0.18, input, keyboard, units
FreeCAD Information

Relationships

related to 0003795 feedbackuwestoehr Input of floating point values with point ('.') instead of comma (',') 

Activities

openBrain

2020-03-24 12:09

developer   ~0014276

https://github.com/FreeCAD/FreeCAD/pull/3256

openBrain

2020-03-24 12:40

developer   ~0014277

For specific case of TechDraw in the forum discussion, UI files have to be updated to use 'Gui::DoubleSpinBox' instead of 'QDoubleSpinBox'

uwestoehr

2020-03-24 13:25

developer   ~0014279

Duplicate of 0003795

uwestoehr

2020-03-24 13:26

developer   ~0014280

Duplicate of 0003795

openBrain

2020-03-24 13:57

developer   ~0014281

Not duplicate. Related to.

Issue History

Date Modified Username Field Change
2019-05-08 22:31 openBrain New Issue
2019-05-08 22:31 openBrain Tag Attached: 0.18
2019-05-08 22:31 openBrain Tag Attached: input
2019-05-08 22:31 openBrain Tag Attached: keyboard
2019-05-09 01:25 Kunda1 Tag Attached: units
2019-05-09 01:26 Kunda1 Target Version => 0.19
2020-01-11 13:12 Kunda1 Status new => confirmed
2020-03-24 11:46 openBrain Assigned To => openBrain
2020-03-24 11:46 openBrain Status confirmed => assigned
2020-03-24 12:09 openBrain Note Added: 0014276
2020-03-24 12:40 openBrain Note Added: 0014277
2020-03-24 13:25 uwestoehr Note Added: 0014279
2020-03-24 13:26 uwestoehr Status assigned => closed
2020-03-24 13:26 uwestoehr Resolution open => fixed
2020-03-24 13:26 uwestoehr Note Added: 0014280
2020-03-24 13:26 uwestoehr Relationship added duplicate of 0003795
2020-03-24 13:57 openBrain Status closed => feedback
2020-03-24 13:57 openBrain Resolution fixed => reopened
2020-03-24 13:57 openBrain Note Added: 0014281
2020-03-24 13:57 openBrain Relationship deleted 0003795
2020-03-24 13:57 openBrain Relationship added related to 0003795
2020-04-09 17:47 openBrain Status feedback => assigned