View Issue Details

IDProjectCategoryView StatusLast Update
0003954PartBugpublic2021-09-16 13:21
ReporteropenBrain Assigned Tochennes  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target Version0.20Fixed in Version0.20 
Summary0003954: 2D Offset crashes with particular model
DescriptionWith specific models, the 2D Offset function crashed (brutal unexpected exit of FC)

More precisely from forum discussion, Linux & MacOS crash, Windows fails w/o crash with an "Access violation" exception
Steps To Reproduce
  • Open the attached file
  • Select the "Common" object in the tree view
  • Choose Part WB : Part -> 2D Offset
Additional InformationForum thread

Another probably linked forum thread
TagsNo tags attached.
FreeCAD Information

Activities

openBrain

2019-04-30 20:21

developer  

bug_offset.FCStd (8,704 bytes)

Kunda1

2020-12-03 20:44

administrator   ~0015060

It doesn't crash for me but I have to exit the task view using 'Cancel' because it spits out a dialog saying:

15:38:16  <Exception> makeOffset2D: result of offsetting is null!
15:38:16  Recompute failed! Please check report view.

OS: Manjaro Linux (KDE//usr/share/xsessions/plasma)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23141 (Git) AppImage
Build type: Release
Branch: master
Hash: 0eba78d40096720f7a637a9a73c382a08b820bca
Python version: 3.8.6
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: English/United States (en_US)

chennes

2021-09-16 03:45

developer   ~0015932

I get the same results as @Kunda1 on

OS: Windows 10 Version 2009
Word size of FreeCAD: 64-bit
Version: 0.20.25718 +1 (Git)
Build type: Debug
Branch: pr/5031
Hash: 072eef5c940c876ae8f12512a57bddfedc05ca26
Python version: 3.8.6+
Qt version: 5.15.1
Coin version: 4.0.1
OCC version: 7.5.0
Locale: English/United States (en_US)

chennes

2021-09-16 13:21

developer   ~0015937

Per forums discussion, this appears to be resolved.

Issue History

Date Modified Username Field Change
2019-04-30 20:21 openBrain New Issue
2019-04-30 20:21 openBrain File Added: bug_offset.FCStd
2019-05-01 04:32 normandc Project FreeCAD => Part
2020-12-03 20:44 Kunda1 Note Added: 0015060
2021-02-06 06:46 abdullah Target Version => 0.20
2021-09-16 03:45 chennes Note Added: 0015932
2021-09-16 13:21 chennes Assigned To => chennes
2021-09-16 13:21 chennes Status new => closed
2021-09-16 13:21 chennes Resolution open => fixed
2021-09-16 13:21 chennes Fixed in Version => 0.20
2021-09-16 13:21 chennes Note Added: 0015937