View Issue Details

IDProjectCategoryView StatusLast Update
0003872FreeCADBugpublic2020-12-06 00:22
Reporterjmborer Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformAppleOSMac OSOS Version10.14.3
Product Version0.18 
Summary0003872: Crash on "New view creation"
DescriptionThe application crashed when you closed the model view and create a new one.
Steps To ReproduceOpen the ArchDetail sample. Close the "ArchDetail" tab. Go to the menu View > Create new view. The application crashes.
TagsmacOS
FreeCAD Information

Activities

wmayer

2019-02-28 20:55

administrator   ~0012810

Last edited: 2019-02-28 20:55

View 2 revisions

Something must be very wrong with your graphic driver as you have submitted three reports about OpenGL issues now. It's probably best to check for updates of the graphic driver, first.

jmborer

2019-03-01 07:04

reporter   ~0012813

Maybe, maybe not. All I can say is that I have no drawing artifacts with 0.17.
However, it also crashes with the steps explained above.
I cannot update my card drivers. They are included in MacOS X and cannot be updated separately. My card is a built-in Intel Iris...

wmayer

2019-03-01 09:11

administrator   ~0012814

v0.17 uses Qt4 and v0.18 supports Qt5 and Qt4.

The Qt developers have more or less completely reworked the support of OpenGL and the Qt-API to it in Qt5.x.
I think under the hood they use some more modern OpenGL techniques now but this requires that the system OpenGL driver is properly implemented. If not, there is nothing we can do on our side to improve this.

Unfortunately, it's a known fact that Apple doesn't put much effort any more in improving this. They even declared OpenGL as deprecated because they want to push their Metal API.

openBrain

2020-04-13 14:24

developer   ~0014344

@Kunda1 : shall we keep this ticket open according wmayer's comments above ?

Kunda1

2020-10-21 15:46

administrator   ~0014918

@wmayer shall we keep this open ?

Kunda1

2020-12-03 23:59

administrator   ~0015072

@wmayer please advise

chennes

2020-12-04 22:26

reporter   ~0015081

Just as a point of reference, the given steps work as expected for me, with no crash, on
OS: macOS 10.15
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.23141 (Git)
Build type: Release
Branch: master
Hash: 0eba78d40096720f7a637a9a73c382a08b820bca
Python version: 3.8.6
Qt version: 5.12.5
Coin version: 4.0.0
OCC version: 7.4.0
Locale: C/Default (C)

Hardware:
Model Name: MacBook Pro
Model Identifier: MacBookPro16,4
Processor Name: 8-Core Intel Core i9
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 8
L2 Cache (per Core): 256 KB
L3 Cache: 16 MB
Hyper-Threading Technology: Enabled
Memory: 32 GB
Graphics: AMD Radeon Pro 5600M

Kunda1

2020-12-06 00:22

administrator   ~0015088

Thanks chennes.
Closing ticket.

Issue History

Date Modified Username Field Change
2019-02-28 18:02 jmborer New Issue
2019-02-28 20:55 wmayer Note Added: 0012810
2019-02-28 20:55 wmayer Note Edited: 0012810 View Revisions
2019-03-01 07:04 jmborer Note Added: 0012813
2019-03-01 09:11 wmayer Note Added: 0012814
2019-03-03 21:06 Kunda1 Tag Attached: MacOSX
2019-03-03 21:07 Kunda1 Priority urgent => normal
2020-04-13 14:24 openBrain Note Added: 0014344
2020-10-21 15:46 Kunda1 Note Added: 0014918
2020-11-13 14:08 Kunda1 Tag Renamed MacOSX => macOS
2020-12-03 23:59 Kunda1 Note Added: 0015072
2020-12-04 22:26 chennes Note Added: 0015081
2020-12-06 00:22 Kunda1 Status new => closed
2020-12-06 00:22 Kunda1 Resolution open => unable to reproduce
2020-12-06 00:22 Kunda1 Note Added: 0015088