View Issue Details

IDProjectCategoryView StatusLast Update
0003857PartFeaturepublic2020-12-01 11:29
Reporteruwestoehr Assigned Touwestoehr  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Fixed in Version0.19 
Summary0003857: Helix is not editable via its task dialog
Description- create a helix with the Part WB

This opens a task dialog where you can specify its settings

- after the creation, double-click on the helix in the model tree

result: the task dialog to change its settings does not show up

Since there exists a nice task dialog for helices, it should be shown.
Additional InformationIn principle the same issue than with ShapeStrings: 0003853
TagsTask View
FreeCAD Information

Relationships

related to 0003853 assignedyorik Draft ShapeString is not editable 

Activities

uwestoehr

2019-02-24 14:00

developer   ~0012741

In principle the same issue than with ShapeStrings: 0003853

wmayer

2019-02-24 17:20

administrator   ~0012751

Might be in principle the same as with the ShapeString but this ticket is clearly a feature request and not a bug.

uwestoehr

2019-02-24 18:13

developer   ~0012757

The issue is not only about helices, it applies for all parametric primitives in the Part WB.

uwestoehr

2020-11-08 21:24

developer   ~0014967

This was implemented yesterday:
- https://github.com/FreeCAD/FreeCAD/commit/6d831627839daff3e856682848dcfd6e6c4ff96c
- https://github.com/FreeCAD/FreeCAD/commit/80626d3a1f5e412463d2caabbf50f5c962554010
- https://github.com/FreeCAD/FreeCAD/commit/f23187cd0eb4e6153c8b2190753a26678714dc75

Meanwhile the editing has also a live preview.

Kunda1

2020-11-16 22:52

administrator   ~0014995

Last edited: 2020-11-16 22:53

View 2 revisions

FreeCAD master 6d831627
FreeCAD master 80626d3a
FreeCAD master f23187cd

Kunda1

2020-12-01 11:29

administrator   ~0015036

Closing ticket

Related Changesets

FreeCAD: master 6d831627

2020-10-25 21:52:31

uwestoehr


Committer: wmayer Details Diff
[Part] allow to edit helices via a dialog

fixes https://tracker.freecadweb.org/view.php?id=3857

Currently primitives of the Part WB can only be created suing a dialog. Editing is not possible that way.

This PR makes the first step in achieving this:

- Helices can now be edited using the same dialog ans when created

- New location dialog. The Gui::LocationWidget used there is not aware of the rotation angle and it treats the rotation axis as direction. To fix this, I set changed the dialog so that one can define every parameter as in the PartDesign attacher dialog (Placement, rotation axis and rotation angle separately). Another reason for this change was that one could not use the location dialog, fill it with the placement properties of the object, and close the dialog without any change. Because of the missing angle info the objects was then always rotated despite nothing was changed.

If this PR goes in, I will extend it for the other primitives.

Todo for the future: allow a preview of the changes made in the dialog. (I could not find out how this is done.)
Affected Issues
0003857
mod - src/Mod/Part/Gui/DlgPrimitives.cpp Diff File
mod - src/Mod/Part/Gui/DlgPrimitives.h Diff File
mod - src/Mod/Part/Gui/Location.ui Diff File
mod - src/Mod/Part/Gui/ViewProviderHelixParametric.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderHelixParametric.h Diff File

FreeCAD: master 80626d3a

2020-11-06 18:59:14

wmayer

Details Diff
[Part] allow to edit helices via a dialog
+ add class ViewProviderPrimitive to avoid to re-implement setEdit/unsetEdit methods for each sub-class separately
+ avoid using global variables
+ when editing a feature directly pass it to the dialogs
+ when editing a feature then do not use active document as this could point to the wrong object
+ fix undo/redo message
+ re-add '3D View' button to location dialog
Affected Issues
0003857
mod - src/Mod/Part/Gui/AppPartGui.cpp Diff File
mod - src/Mod/Part/Gui/DlgPrimitives.cpp Diff File
mod - src/Mod/Part/Gui/DlgPrimitives.h Diff File
mod - src/Mod/Part/Gui/Location.ui Diff File
mod - src/Mod/Part/Gui/ViewProvider.cpp Diff File
mod - src/Mod/Part/Gui/ViewProvider.h Diff File
mod - src/Mod/Part/Gui/ViewProviderBox.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderBox.h Diff File
mod - src/Mod/Part/Gui/ViewProviderCircleParametric.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderCircleParametric.h Diff File
mod - src/Mod/Part/Gui/ViewProviderConeParametric.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderConeParametric.h Diff File
mod - src/Mod/Part/Gui/ViewProviderCylinderParametric.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderCylinderParametric.h Diff File
mod - src/Mod/Part/Gui/ViewProviderEllipseParametric.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderEllipseParametric.h Diff File
mod - src/Mod/Part/Gui/ViewProviderHelixParametric.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderHelixParametric.h Diff File
mod - src/Mod/Part/Gui/ViewProviderLineParametric.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderLineParametric.h Diff File
mod - src/Mod/Part/Gui/ViewProviderPlaneParametric.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderPlaneParametric.h Diff File
mod - src/Mod/Part/Gui/ViewProviderPointParametric.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderPointParametric.h Diff File
mod - src/Mod/Part/Gui/ViewProviderPrism.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderPrism.h Diff File
mod - src/Mod/Part/Gui/ViewProviderRegularPolygon.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderRegularPolygon.h Diff File
mod - src/Mod/Part/Gui/ViewProviderSphereParametric.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderSphereParametric.h Diff File
mod - src/Mod/Part/Gui/ViewProviderTorusParametric.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderTorusParametric.h Diff File

FreeCAD: master f23187cd

2020-11-06 22:12:40

wmayer

Details Diff
Part: allow to edit primitives via dialog Affected Issues
0003857
mod - src/Mod/Part/Gui/DlgPrimitives.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderHelixParametric.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderHelixParametric.h Diff File

Issue History

Date Modified Username Field Change
2019-02-24 13:51 uwestoehr New Issue
2019-02-24 14:00 uwestoehr Tag Attached: Task View
2019-02-24 14:00 uwestoehr Note Added: 0012741
2019-02-24 17:20 wmayer Category Bug => Feature
2019-02-24 17:20 wmayer Note Added: 0012751
2019-02-24 18:13 uwestoehr Note Added: 0012757
2020-11-08 21:24 uwestoehr Assigned To => uwestoehr
2020-11-08 21:24 uwestoehr Status new => resolved
2020-11-08 21:24 uwestoehr Resolution open => fixed
2020-11-08 21:24 uwestoehr Fixed in Version => 0.19
2020-11-08 21:24 uwestoehr Note Added: 0014967
2020-11-16 22:52 Kunda1 Note Added: 0014995
2020-11-16 22:53 Kunda1 Changeset attached => FreeCAD master 6d831627
2020-11-16 22:53 Kunda1 Note Edited: 0014995 View Revisions
2020-11-16 22:54 Kunda1 Changeset attached => FreeCAD master 80626d3a
2020-11-16 22:54 Kunda1 Changeset attached => FreeCAD master f23187cd
2020-11-16 23:44 Kunda1 Relationship added related to 0003853
2020-11-16 23:45 Kunda1 Additional Information Updated View Revisions
2020-12-01 11:29 Kunda1 Status resolved => closed
2020-12-01 11:29 Kunda1 Note Added: 0015036