View Issue Details

IDProjectCategoryView StatusLast Update
0003831SketcherBugpublic2020-06-05 17:23
Reporterchrisb Assigned Toabdullah  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Fixed in Version0.19 
Summary0003831: Coincidence marks the center as being coincident with an external geometry point
DescriptionTo reproduce:
- create additive cube in PartDesign, e.g. in XY plane, leave all parameters as is;
- attach a sketch to a face by selecting a face and create sketch
- select the pont opposite to the origin for external reference
- create a line with one point coincident with the external point
- select the coincidence in the list of constraints.

Result: the selected point and the origin are shown in green, as if they were connected.

OS: Ubuntu 18.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15780 (Git)
Build type: Release
Branch: master
Hash: f94e76c1116ec3b818961ff65131b3d86fa5b95e
Python version: 2.7.15rc1
Qt version: 5.9.5
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/France (fr_FR)

An example is given in the corresponding forum discussion.
TagsNo tags attached.
FreeCAD Information

Activities

abdullah

2020-05-25 16:46

manager   ~0014426

https://github.com/FreeCAD/FreeCAD/pull/3507

abdullah

2020-05-27 17:48

manager   ~0014429

git commit 4de7acff64838f8ef92e49d35813d9c245872aaf

abdullah

2020-06-05 17:23

manager   ~0014481

Fix committed to master branch.

Related Changesets

FreeCAD: master 4de7acff

2020-05-25 16:40:16

abdullah


Committer: abdullahtahiriyo Details Diff
Sketcher: Root point selected when endpoint in external geometry point

======================================================================

fixes 0003831

Solver Interface getPointId method is only intended for normal geometry, and returns -1 if geoid is out of range, which was misinterpreted as root point selection.
Affected Issues
0003831
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.cpp Diff File

Issue History

Date Modified Username Field Change
2019-02-12 06:44 chrisb New Issue
2019-02-12 06:44 chrisb Status new => assigned
2019-02-12 06:44 chrisb Assigned To => abdullah
2019-02-12 06:46 chrisb Description Updated View Revisions
2019-02-12 17:30 chrisb Description Updated View Revisions
2020-05-25 16:46 abdullah Note Added: 0014426
2020-05-27 17:48 abdullah Status assigned => closed
2020-05-27 17:48 abdullah Resolution open => fixed
2020-05-27 17:48 abdullah Fixed in Version => 0.19
2020-05-27 17:48 abdullah Note Added: 0014429
2020-06-05 17:23 abdullah Changeset attached => FreeCAD master 4de7acff
2020-06-05 17:23 abdullah Note Added: 0014481